summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-01-05 00:41:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-01-05 00:41:06 +0000
commit43ba10633617ef6ab43cd6c434b3f971e4480488 (patch)
tree5935f95879ec0f07b25c771a1e64b004acaf429f /sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild
parentUnmask wxpython-2.8. (diff)
downloadhistorical-43ba10633617ef6ab43cd6c434b3f971e4480488.tar.gz
historical-43ba10633617ef6ab43cd6c434b3f971e4480488.tar.bz2
historical-43ba10633617ef6ab43cd6c434b3f971e4480488.zip
Minor bump for the newer debian patch. Cleans up manpage and uses system header instead of bundled header. Also clean up ebuilds to modern standards.
Package-Manager: portage-2.1.4_rc11
Diffstat (limited to 'sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild')
-rw-r--r--sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild b/sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild
index 0bf6e59c59d8..e83778e709eb 100644
--- a/sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild
+++ b/sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild,v 1.2 2007/07/12 05:10:21 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/input-utils/input-utils-0.0.1_pre20051128.ebuild,v 1.3 2008/01/05 00:41:06 robbat2 Exp $
inherit eutils
MY_P="input-${PV/0.0.1_pre/}-143821"
-DEBIAN_P="${PN}_${PV/1_pre/}-1.diff.gz"
+DEBIAN_PR=1
+DEBIAN_P="${PN}_${PV/1_pre/}-${DEBIAN_PR}.diff.gz"
DESCRIPTION="Small collection of linux input layer utils"
HOMEPAGE="http://dl.bytesex.org/cvs-snapshots/"
SRC_URI="http://dl.bytesex.org/cvs-snapshots/${MY_P}.tar.gz
- http://ftp.debian.org/debian/pool/main/i/input-utils/${DEBIAN_P}"
+ mirror://debian/pool/main/i/input-utils/${DEBIAN_P}"
LICENSE="GPL-2"
SLOT="0"
@@ -24,16 +25,16 @@ S="${WORKDIR}/input"
src_unpack() {
unpack ${MY_P}.tar.gz
- EPATCH_OPTS="-d ${S} -p1 " epatch ${DISTDIR}/${DEBIAN_P}
- for p in $(<${S}/debian/patches/series) ; do
- EPATCH_OPTS="-d ${S} -p1 " epatch ${S}/debian/patches/${p}
+ EPATCH_OPTS="-d ${S} -p1 " epatch "${DISTDIR}"/${DEBIAN_P}
+ for p in $(<"${S}"/debian/patches/series) ; do
+ EPATCH_OPTS="-d ${S} -p1 " epatch "${S}"/debian/patches/${p}
done
- sed -i -e '/INSTALL_BINARY/s,-s,,g' ${S}/mk/Variables.mk \
+ sed -i -e '/INSTALL_BINARY/s,-s,,g' "${S}"/mk/Variables.mk \
|| die "Failed to sed"
}
src_install() {
- make install bindir=${D}/usr/bin mandir=${D}/usr/share/man || die "make install failed"
+ make install bindir="${D}"/usr/bin mandir="${D}"/usr/share/man || die "make install failed"
dodoc lircd.conf
dodoc README
}