summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-05-18 15:08:07 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-05-18 15:08:07 +0000
commit300275c5cbd22f9eb9b428845bf384782a8d8dee (patch)
tree592cb92f1b3d1cf74f33bcc66139215847ab0504 /sys-apps/ifplugd/ifplugd-0.25.ebuild
parentadding other arches from 0.3 (diff)
downloadhistorical-300275c5cbd22f9eb9b428845bf384782a8d8dee.tar.gz
historical-300275c5cbd22f9eb9b428845bf384782a8d8dee.tar.bz2
historical-300275c5cbd22f9eb9b428845bf384782a8d8dee.zip
Version bumped. Closes 51234
Diffstat (limited to 'sys-apps/ifplugd/ifplugd-0.25.ebuild')
-rw-r--r--sys-apps/ifplugd/ifplugd-0.25.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/ifplugd/ifplugd-0.25.ebuild b/sys-apps/ifplugd/ifplugd-0.25.ebuild
new file mode 100644
index 000000000000..91766dd44c7a
--- /dev/null
+++ b/sys-apps/ifplugd/ifplugd-0.25.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ifplugd/ifplugd-0.25.ebuild,v 1.1 2004/05/18 15:08:07 mholzer Exp $
+
+DESCRIPTION="Brings up/down ethernet ports automatically with cable detection"
+HOMEPAGE="http://0pointer.de/lennart/projects/ifplugd/"
+SRC_URI="http://0pointer.de/lennart/projects/ifplugd/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="doc"
+DEPEND=">=dev-libs/libdaemon-0.5
+ doc? ( app-doc/doxygen net-www/lynx )"
+
+# Gentoo-provided scripts. Version is for the scripts, not ifplugd.
+INITSCRIPT=${FILESDIR}/gentoo-ifplugd-init-v3
+ACTIONSCRIPT=${FILESDIR}/gentoo-ifplugd.action-v2
+CONFFILE=${FILESDIR}/gentoo-ifplugd-conf-v3
+
+src_unpack() {
+ unpack ${A}
+
+ cp ${INITSCRIPT} ${T}/ifplugd
+ cp ${ACTIONSCRIPT} ${T}/ifplugd.action
+
+ # This moves the default location for the script that handles
+ # calling the distro network scripts to /usr/sbin. The reason
+ # is that the user very probably shouldn't mess with it.
+ cd ${S}
+ sed -i~ 's:SYSCONFDIR"/ifplugd/:"/usr/sbin/:' src/ifplugd.c
+}
+
+src_compile() {
+ local myconf
+
+ # These are not needed for building
+ myconf="--disable-xmltoman --disable-subversion"
+ myconf="${myconf} --with-initdir=${D}/etc/init.d"
+
+ use doc \
+ && myconf="${myconf} --enable-doxygen --enable-lynx" \
+ || myconf="${myconf} --disable-doxygen --disable-lynx"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+
+ # Fix init.d configuration
+ cd ${D}/etc
+ rm -rf ifplugd/
+ rm -f init.d/ifplugd
+
+ use doc && dohtml doc/*.html doc/*.css
+
+ dodir /etc/conf.d
+ cp ${CONFFILE} conf.d/ifplugd
+
+ dosbin ${T}/ifplugd.action
+
+ exeinto /etc/init.d
+ doexe ${T}/ifplugd
+}