summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-11-08 15:05:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-11-08 15:05:53 +0000
commit704d0d082fd4ea6246914fbddffeb16e7244a335 (patch)
tree4eb02998a1ce42b6c4044e54ff51fd42ef697dc6 /sys-apps/eject
parentVersion bumped. Closes #32953 (diff)
downloadhistorical-704d0d082fd4ea6246914fbddffeb16e7244a335.tar.gz
historical-704d0d082fd4ea6246914fbddffeb16e7244a335.tar.bz2
historical-704d0d082fd4ea6246914fbddffeb16e7244a335.zip
Version bumped. Closes #32953
Diffstat (limited to 'sys-apps/eject')
-rw-r--r--sys-apps/eject/Manifest5
-rw-r--r--sys-apps/eject/eject-2.0.13.ebuild39
-rw-r--r--sys-apps/eject/files/digest-eject-2.0.131
-rw-r--r--sys-apps/eject/files/eject-2.0.13-kernel25-support.patch17
4 files changed, 60 insertions, 2 deletions
diff --git a/sys-apps/eject/Manifest b/sys-apps/eject/Manifest
index 8126f645b44a..c6f514bbe609 100644
--- a/sys-apps/eject/Manifest
+++ b/sys-apps/eject/Manifest
@@ -1,9 +1,9 @@
-MD5 727929a5afe72a9b42eac1314ea4902a ChangeLog 2156
+MD5 f4fada754f12c4519871b2aa9919100b ChangeLog 2335
MD5 4abbe18bd8824879aed713d37f9b5a27 eject-2.0.10.ebuild 944
MD5 bea13fc7954cdf2c55f4b466200a4c99 eject-2.0.12-r1.ebuild 1128
MD5 0c6e67c7c4c4184a76625fdf35e0f72f eject-2.0.12.ebuild 839
MD5 ac6f2a99fba8a90f778b44468d52d7ec eject-2.0.6.ebuild 834
-MD5 db1eed08e0075ab4b454e901d7dace93 eject-2.0.13.ebuild 1158
+MD5 04fccbbd90534a83ca43b6c510a2daff eject-2.0.13.ebuild 1089
MD5 56bca47a22682dc0a0ad2919e80fde16 files/digest-eject-2.0.10 63
MD5 82c97e826738221130b24eebca6fbb65 files/digest-eject-2.0.12 63
MD5 82c97e826738221130b24eebca6fbb65 files/digest-eject-2.0.12-r1 63
@@ -11,3 +11,4 @@ MD5 404e43cb4c87c1d4e594a5057e6e7e68 files/digest-eject-2.0.6 62
MD5 b84674293450f0dab61ed0af08dac6bb files/eject-2.0.12-gentoo.security.patch 406
MD5 6225e895d76b4a648a529c73d72e08ac files/eject-2.0.12-kernel25-support.patch 534
MD5 a8f6893c482c2b74b0e799b6cd81e867 files/digest-eject-2.0.13 63
+MD5 0be093fc73fcb931944eecca3111bdd8 files/eject-2.0.13-kernel25-support.patch 508
diff --git a/sys-apps/eject/eject-2.0.13.ebuild b/sys-apps/eject/eject-2.0.13.ebuild
new file mode 100644
index 000000000000..f9946a843271
--- /dev/null
+++ b/sys-apps/eject/eject-2.0.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/eject/eject-2.0.13.ebuild,v 1.1 2003/11/08 15:05:48 mholzer Exp $
+
+inherit eutils
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="A command to eject a disc from the CD-ROM drive"
+SRC_URI="http://www.ibiblio.org/pub/Linux/utils/disk-management/${P}.tar.gz
+ http://www.pobox.com/~tranter/${P}.tar.gz"
+HOMEPAGE="http://eject.sourceforge.net/"
+
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Get this puppy working with kernel 2.5.x
+ # <azarah@gentoo.org> (06 March 2003)
+ epatch ${FILESDIR}/${P}-kernel25-support.patch || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man1
+
+# Full install breaks sandbox, and I'm too lazy to figure out how, so:
+
+ make DESTDIR=${D} install-binPROGRAMS || die
+ make DESTDIR=${D} install-man1 || die
+ make DESTDIR=${D} install-man || die
+
+ dodoc ChangeLog COPYING README PORTING TODO
+ dodoc AUTHORS NEWS PROBLEMS
+}
diff --git a/sys-apps/eject/files/digest-eject-2.0.13 b/sys-apps/eject/files/digest-eject-2.0.13
new file mode 100644
index 000000000000..3c64dc062a37
--- /dev/null
+++ b/sys-apps/eject/files/digest-eject-2.0.13
@@ -0,0 +1 @@
+MD5 b796ad77beb4e7bdd08d6149701ab778 eject-2.0.13.tar.gz 59504
diff --git a/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch b/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch
new file mode 100644
index 000000000000..4a161242cb2b
--- /dev/null
+++ b/sys-apps/eject/files/eject-2.0.13-kernel25-support.patch
@@ -0,0 +1,17 @@
+--- eject.c.orig 2002-12-09 22:28:08.000000000 +0000
++++ eject.c 2003-11-08 17:06:43.000000000 +0000
+@@ -58,7 +58,13 @@
+ #include <sys/ioctl.h>
+ #include <sys/wait.h>
+ #include <sys/mtio.h>
+-#include <linux/types.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,5,0) /* 2.5.x breaks things again */
++# define __KERNEL__
++# include <linux/types.h>
++# undef __KERNEL__
++#else
++# include <linux/types.h>
++#endif
+ #include <linux/cdrom.h>
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(2,1,0)
+ #include <linux/ucdrom.h>