summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:44:02 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-10-06 16:44:02 +0000
commit93edc958c77b220bcd93ecf29e71759d48504693 (patch)
tree5b33829fdc488a8805629d8ec1c0d758c8adb90f /sys-apps/bzip2
parentmissed bonobo-conf (diff)
downloadhistorical-93edc958c77b220bcd93ecf29e71759d48504693.tar.gz
historical-93edc958c77b220bcd93ecf29e71759d48504693.tar.bz2
historical-93edc958c77b220bcd93ecf29e71759d48504693.zip
fixums
Diffstat (limited to 'sys-apps/bzip2')
-rw-r--r--sys-apps/bzip2/bzip2-1.0.1-r3.ebuild69
-rw-r--r--sys-apps/bzip2/bzip2-1.0.1-r4.ebuild87
2 files changed, 31 insertions, 125 deletions
diff --git a/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild b/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild
deleted file mode 100644
index 2f729927833c..000000000000
--- a/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r3.ebuild,v 1.1 2001/02/27 16:19:27 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo"
-SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${A}
- ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${A}"
-
-HOMEPAGE="http://sourceware.cygnus.com/bzip2/"
-
-DEPEND="virtual/glibc"
-
-src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- patch -p0 < ${FILESDIR}/bzip2-1.0.1-Makefile-gentoo.diff
- cp ${FILESDIR}/Makefile.dietlibc .
-}
-
-src_compile() {
-
- if [ -z "`use build`" ]
- then
- try pmake -f Makefile-libbz2_so all
- fi
- if [ -z "`use static`" ]
- then
- try pmake all
- else
- if [ "`use diet`" ]
- then
- try pmake LDFLAGS=-static -f Makefile.dietlibc all
- else
- try pmake LDFLAGS=-static all
- fi
- fi
-
-}
-src_install() {
-
- if [ -z "`use build`" ]
- then
- try make DESTDIR=${D} install
- try make DESTDIR=${D} -f Makefile-libbz2_so install
-
- mv ${D}/usr/bin ${D}
-
- dodoc README LICENSE CHANGES Y2K_INFO
- docinto txt
- dodoc bzip2.txt
- docinto ps
- dodoc manual.ps
- docinto html
- dodoc manual_*.html
- else
- into /
- dobin bzip2
- cd ${D}/bin
- ln -s bzip2 bunzip2
- fi
-
-}
-
-
diff --git a/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild b/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
index 2933690d6232..04fe8ca32b35 100644
--- a/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
+++ b/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild
@@ -1,72 +1,47 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild,v 1.1 2001/08/04 18:22:45 pete Exp $
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/bzip2/bzip2-1.0.1-r4.ebuild,v 1.2 2001/10/06 16:44:02 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo"
-SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${A}
- ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${A}"
-
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+SRC_URI="ftp://sourceware.cygnus.com/pub/bzip2/v100/${P}.tar.gz ftp://ftp.freesoftware.com/pub/sourceware/bzip2/v100/${P}.tar.gz"
HOMEPAGE="http://sourceware.cygnus.com/bzip2/"
-
DEPEND="virtual/glibc"
src_unpack() {
-
- unpack ${A}
-
- cd ${S}
- patch -p0 < ${FILESDIR}/bzip2-1.0.1-Makefile-gentoo.diff
- cp ${FILESDIR}/Makefile.dietlibc .
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/bzip2-1.0.1-Makefile-gentoo.diff
+ cp ${FILESDIR}/Makefile.dietlibc .
}
src_compile() {
- if [ -z "`use build`" ] && [ -z "`use bootcd`" ]
- then
- try pmake -f Makefile-libbz2_so all
- fi
- if [ -z "`use static`" ]
- then
- try pmake all
- else
- if [ "`use diet`" ]
- then
- try pmake LDFLAGS=-static -f Makefile.dietlibc all
- else
- try pmake LDFLAGS=-static all
- fi
- fi
+ if [ -z "`use build`" ]
+ then
+ emake -f Makefile-libbz2_so all || die
+ fi
+ emake all || die
}
src_install() {
-
- if [ -z "`use build`" ]
- then
- try make DESTDIR=${D} install
- mv ${D}/usr/bin ${D}
-
- if [ -z "`use bootcd`" ]
- then
- try make DESTDIR=${D} -f Makefile-libbz2_so install
-
- dodoc README LICENSE CHANGES Y2K_INFO
- docinto txt
- dodoc bzip2.txt
- docinto ps
- dodoc manual.ps
- docinto html
- dodoc manual_*.html
- else
- rm -rf ${D}/usr
- fi
+ if [ -z "`use build`" ]
+ then
+ make DESTDIR=${D} install || die
+ mv ${D}/usr/bin ${D}
+ make DESTDIR=${D} -f Makefile-libbz2_so install || die
+ dodoc README LICENSE CHANGES Y2K_INFO
+ docinto txt
+ dodoc bzip2.txt
+ docinto ps
+ dodoc manual.ps
+ docinto html
+ dodoc manual_*.html
else
- into /
- dobin bzip2
- cd ${D}/bin
- ln -s bzip2 bunzip2
- fi
-
+ into /
+ dobin bzip2
+ cd ${D}/bin
+ ln -s bzip2 bunzip2
+ fi
}