summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-25 20:31:01 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-25 20:31:01 +0000
commit580468cf5e3c373351a08018dad5690443517a3b (patch)
tree15177ea082003ffd556d9a48cb8b4799e6d6910a /sys-apps/baselayout
parentstable on amd64 (diff)
downloadhistorical-580468cf5e3c373351a08018dad5690443517a3b.tar.gz
historical-580468cf5e3c373351a08018dad5690443517a3b.tar.bz2
historical-580468cf5e3c373351a08018dad5690443517a3b.zip
QA - fix use invocation
Diffstat (limited to 'sys-apps/baselayout')
-rw-r--r--sys-apps/baselayout/ChangeLog6
-rw-r--r--sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild20
-rw-r--r--sys-apps/baselayout/baselayout-1.8.6.13.ebuild24
3 files changed, 27 insertions, 23 deletions
diff --git a/sys-apps/baselayout/ChangeLog b/sys-apps/baselayout/ChangeLog
index d5beaf65ab5b..981624457e28 100644
--- a/sys-apps/baselayout/ChangeLog
+++ b/sys-apps/baselayout/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for sys-apps/baselayout
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.152 2004/06/24 21:59:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/ChangeLog,v 1.153 2004/06/25 20:26:33 agriffis Exp $
# See the gentoo-src rc-scripts ChangeLog for up-to-date release information:
# http://www.gentoo.org/cgi-bin/viewcvs.cgi/rc-scripts/ChangeLog?rev=HEAD&cvsroot=gentoo-src&content-type=text/vnd.viewcvs-markup
+ 25 Jun 2004; Aron Griffis <agriffis@gentoo.org>
+ baselayout-1.8.6.13-r1.ebuild, baselayout-1.8.6.13.ebuild:
+ QA - fix use invocation
+
15 Jun 2004; <solar@gentoo.org> baselayout-1.9.4-r2.ebuild:
remove unneeded /etc/nsswitch.conf with USE=uclibc
diff --git a/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild b/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild
index ab8d7c3bbe6f..edfda3a11bde 100644
--- a/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild
+++ b/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild,v 1.8 2004/06/24 21:59:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13-r1.ebuild,v 1.9 2004/06/25 20:26:33 agriffis Exp $
inherit eutils
@@ -41,7 +41,7 @@ src_unpack() {
cd ${S2}
cp Makefile Makefile.orig
sed -e "s:-O2:${CFLAGS}:" Makefile.orig >Makefile || die
- if [ -n "`use build`" ]
+ if use build
then
# Do not build sulogin, as it needs libcrypt which is not in the
# build image.
@@ -88,7 +88,7 @@ src_compile() {
make CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Build sysvinit stuff
cd ${S2}
@@ -350,7 +350,7 @@ src_install() {
# if 'build' or 'bootstrap' is not in USE. This will
# change if we have sys-apps/gawk-3.1.1-r1 or later in
# the build image ...
- if [ -z "`use build`" ]
+ if ! use build
then
# This is for new depscan.sh and env-update.sh
# written in awk
@@ -373,7 +373,7 @@ src_install() {
einfo "Installing utilities..."
make DESTDIR="${D}" install || die "problem installing utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Install sysvinit stuff
cd ${S2}
@@ -444,8 +444,8 @@ src_install() {
keepdir ${svcdir} >/dev/null 2>&1
- if [ -n "$(use build)" -o -n "$(use bootstrap)" -o \
- ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
+ if use build || use bootstrap || \
+ [ ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
# Ok, create temp device nodes
mkdir -p "${T}/udev-$$"
@@ -521,7 +521,7 @@ pkg_postinst() {
if [ "${altmerge}" -eq "0" -a ! -e "${ROOT}/dev/.udev" -a \
-f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
- if [ -n "$(use build)" -o -n "$(use bootstrap)" ]
+ if use build || use bootstrap
then
einfo "Populating /dev with device nodes..."
if [ -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
@@ -588,7 +588,7 @@ EOF
# Touching /etc/passwd and /etc/shadow after install can be fatal, as many
# new users do not update them properly. thus remove all ._cfg files if
# we are not busy with a bootstrap.
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
ewarn "Removing invalid backup copies of critical config files..."
rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
@@ -597,7 +597,7 @@ EOF
# Reload init to fix unmounting problems of / on next reboot
# this is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [ "${ROOT}" = "/" -a -z "`use build`" -a -z "`use bootstrap`" ]
+ if [ "${ROOT}" = "/" ] && ! use build && ! use bootstrap
then
echo
# Do not return an error if this fails
diff --git a/sys-apps/baselayout/baselayout-1.8.6.13.ebuild b/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
index 51dfc346e883..66e0390a1217 100644
--- a/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
+++ b/sys-apps/baselayout/baselayout-1.8.6.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13.ebuild,v 1.8 2004/06/24 21:59:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/baselayout/baselayout-1.8.6.13.ebuild,v 1.9 2004/06/25 20:26:33 agriffis Exp $
inherit eutils
@@ -44,7 +44,7 @@ src_unpack() {
cd ${S2}
cp Makefile Makefile.orig
sed -e "s:-O2:${CFLAGS}:" Makefile.orig >Makefile || die
- if [ -n "`use build`" ]
+ if use build
then
# Do not build sulogin, as it needs libcrypt which is not in the
# build image.
@@ -75,7 +75,7 @@ src_unpack() {
;;
esac
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
# Sanity check to see if has version works
if has_version '>=sys-apps/baselayout-1.8' &> /dev/null
@@ -101,7 +101,7 @@ src_compile() {
make CC="${CC:-gcc}" LD="${CC:-gcc} ${LDFLAGS}" \
CFLAGS="${CFLAGS}" || die "problem compiling utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Build sysvinit stuff
cd ${S2}
@@ -350,7 +350,7 @@ src_install() {
# if 'build' or 'bootstrap' is not in USE. This will
# change if we have sys-apps/gawk-3.1.1-r1 or later in
# the build image ...
- if [ -z "`use build`" ]
+ if ! use build
then
# This is for new depscan.sh and env-update.sh
# written in awk
@@ -373,7 +373,7 @@ src_install() {
einfo "Installing utilities..."
make DESTDIR="${D}" install || die "problem installing utilities"
- if [ -z "`use build`" ]
+ if ! use build
then
# Install sysvinit stuff
cd ${S2}
@@ -444,8 +444,8 @@ src_install() {
keepdir ${svcdir} >/dev/null 2>&1
- if [ -n "$(use build)" -o -n "$(use bootstrap)" -o \
- ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
+ if use build || use bootstrap || \
+ [ ! -f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
# Ok, create temp device nodes
mkdir -p "${T}/udev-$$"
@@ -555,7 +555,7 @@ pkg_postinst() {
if [ "${altmerge}" -eq "0" -a ! -e "${ROOT}/dev/.udev" -a \
-f "${ROOT}/lib/udev-state/devices.tar.bz2" ]
then
- if [ -n "$(use build)" -o -n "$(use bootstrap)" ]
+ if use build || use bootstrap
then
einfo "Populating /dev with device nodes..."
[ ! -e "${ROOT}/dev" ] && mkdir -p "${ROOT}/dev"
@@ -616,7 +616,7 @@ EOF
# Make sure we get everything ready for $svcdir that moved to
# /var/lib/init.d ....
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
local oldsvcdir="${svcdir}"
local rcconfd="/etc/conf.d/rc"
@@ -675,7 +675,7 @@ EOF
# Touching /etc/passwd and /etc/shadow after install can be fatal, as many
# new users do not update them properly. thus remove all ._cfg files if
# we are not busy with a bootstrap.
- if [ -z "`use build`" -a -z "`use bootstrap`" ]
+ if ! use build && ! use bootstrap
then
ewarn "Removing invalid backup copies of critical config files..."
rm -f ${ROOT}/etc/._cfg????_{passwd,shadow}
@@ -684,7 +684,7 @@ EOF
# Reload init to fix unmounting problems of / on next reboot
# this is really needed, as without the new version of init cause init
# not to quit properly on reboot, and causes a fsck of / on next reboot.
- if [ "${ROOT}" = "/" -a -z "`use build`" -a -z "`use bootstrap`" ]
+ if [ "${ROOT}" = "/" ] && ! use build && ! use bootstrap
then
echo
# Do not return an error if this fails