summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-12-31 13:53:53 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-12-31 13:53:53 +0000
commit95cb23f8e519c5a416ddea78c6a76432a7d5951d (patch)
tree6be90c080c3ec33ccf68ac11bc1951a11027146d /sys-apps/apmd
parentfixed newdepend <> DEPEND (diff)
downloadhistorical-95cb23f8e519c5a416ddea78c6a76432a7d5951d.tar.gz
historical-95cb23f8e519c5a416ddea78c6a76432a7d5951d.tar.bz2
historical-95cb23f8e519c5a416ddea78c6a76432a7d5951d.zip
Fixed the 2.6 kernel headers patch which somehow got removed <Ahem!> and also fixed a bad Makefile problem which installed things in totally the wrong place.
Diffstat (limited to 'sys-apps/apmd')
-rw-r--r--sys-apps/apmd/Manifest15
-rw-r--r--sys-apps/apmd/apmd-3.2.0.ebuild11
-rw-r--r--sys-apps/apmd/files/apmd-3.2.0.kernel26x.patch21
3 files changed, 35 insertions, 12 deletions
diff --git a/sys-apps/apmd/Manifest b/sys-apps/apmd/Manifest
index 998302005deb..b1048601eedc 100644
--- a/sys-apps/apmd/Manifest
+++ b/sys-apps/apmd/Manifest
@@ -1,17 +1,18 @@
-MD5 dc8b813777e25c9774d298e46d0e66e1 apmd-3.0.2-r3.ebuild 1815
-MD5 b34c869514e68d3c5083e76865a03bf0 apmd-3.0.2-r2.ebuild 1486
-MD5 a561ffca7ceefdd3d1a6f4aabb8b4cd4 apmd-3.2.0.ebuild 1946
MD5 77429c8b0f0da62c07ce8cab66f4b2ec ChangeLog 2096
+MD5 b34c869514e68d3c5083e76865a03bf0 apmd-3.0.2-r2.ebuild 1486
+MD5 dc8b813777e25c9774d298e46d0e66e1 apmd-3.0.2-r3.ebuild 1815
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 3b4b8a9b5ba1d88d898899c726f9e871 apmd-3.2.0.ebuild 1947
MD5 d02f7a9cc759fc9f70027a7d8f984dd3 apmd-3.0.2-r1.ebuild 1366
+MD5 bed1c6668552bbf528df267c302a75eb files/apmd-3.2.0.kernel26x.patch 627
+MD5 ad21c10734c08e19968e2c8c9560957c files/apmsleep.c.diff 367
+MD5 a2b499e3ffda161e88b518f5b830a434 files/digest-apmd-3.2.0 66
MD5 41d93c73cf8e247bd38b863d1aa4e196 files/run 246
-MD5 7bb0220959a949bad3d9726cf05ebcf9 files/digest-apmd-3.0.2-r1 61
+MD5 bae01c156ae6240672f7ee5ebfcadf61 files/svc-apmd 861
MD5 7bb0220959a949bad3d9726cf05ebcf9 files/digest-apmd-3.0.2-r2 61
MD5 7bb0220959a949bad3d9726cf05ebcf9 files/digest-apmd-3.0.2-r3 61
-MD5 ad21c10734c08e19968e2c8c9560957c files/apmsleep.c.diff 367
MD5 c2edd6e21cae8a8167c1f717165b6d21 files/apmd.rc6 689
+MD5 7bb0220959a949bad3d9726cf05ebcf9 files/digest-apmd-3.0.2-r1 61
MD5 02fc246d5b2fde52708927cb672239f1 files/apmd.kernel26x.patch 644
MD5 253b79375ab72606e4fdf89109ed2c03 files/apmsleep.c.diff.3.2.0 301
-MD5 a2b499e3ffda161e88b518f5b830a434 files/digest-apmd-3.2.0 66
MD5 1cb28b2ee147ffb8a402956d9b429c12 files/apmd.confd 72
-MD5 bae01c156ae6240672f7ee5ebfcadf61 files/svc-apmd 861
diff --git a/sys-apps/apmd/apmd-3.2.0.ebuild b/sys-apps/apmd/apmd-3.2.0.ebuild
index b1c5c7842069..1ffddaae8a41 100644
--- a/sys-apps/apmd/apmd-3.2.0.ebuild
+++ b/sys-apps/apmd/apmd-3.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/apmd/apmd-3.2.0.ebuild,v 1.1 2003/12/30 23:12:19 warpzero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/apmd/apmd-3.2.0.ebuild,v 1.2 2003/12/31 13:53:36 plasmaroo Exp $
inherit eutils
@@ -42,19 +42,19 @@ src_unpack() {
epatch ${FILESDIR}/apmsleep.c.diff.3.2.0
# This closes bug #29636: needs 2.6 patching [plasmaroo@gentoo.org]
- #epatch ${FILESDIR}/apmd.kernel26x.patch
- #this doesn't seem to be needed anymore [warpzero@gentoo.org]
+ # If this does not compile with newer versions, rediff the patch
+ # and DO NOT just ignore it.
+ epatch ${FILESDIR}/apmd-3.2.0.kernel26x.patch
}
src_compile() {
- #make CFLAGS="${CFLAGS}" || die "compile problem"
emake || die
}
S="${WORKDIR}/${PN}-${PV}.orig"
src_install() {
- make DESTDIR=${D} install || die "install failed"
+ make DESTDIR=${D} PREFIX=/usr install || die "install failed"
dodir /etc/apm/{event.d,suspend.d,resume.d}
exeinto /etc/apm ; doexe debian/apmd_proxy
@@ -71,4 +71,5 @@ src_install() {
then
rm -rf ${D}/usr/share/man/fr
fi
+
}
diff --git a/sys-apps/apmd/files/apmd-3.2.0.kernel26x.patch b/sys-apps/apmd/files/apmd-3.2.0.kernel26x.patch
new file mode 100644
index 000000000000..83a796b239a6
--- /dev/null
+++ b/sys-apps/apmd/files/apmd-3.2.0.kernel26x.patch
@@ -0,0 +1,21 @@
+--- apmsleep.c 2003-12-31 13:29:52.000000000 +0000
++++ apmsleep.c.plasmaroo@gentoo.org 2003-12-31 13:35:06.000000000 +0000
+@@ -45,11 +45,15 @@
+ #include <stdio.h>
+ #include <linux/version.h>
+
+-#if LINUX_VERSION_CODE > KERNEL_VERSION(2,2,0)
+-#include <linux/spinlock.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,0)
++ #include <linux/rtc.h>
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2,2,0)
++ #include <linux/spinlock.h>
+ #endif
+
+-#include <linux/mc146818rtc.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
++ #include <linux/mc146818rtc.h>
++#endif
+ #include <sys/ioctl.h>
+ #include <sys/time.h>
+ #include <sys/types.h>