summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-03-04 22:32:22 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-03-04 22:32:22 +0000
commit0c7a001b21ed936eb40dfa8431bf7e79fb3be986 (patch)
treebec726d560c6524a7d46eb0b7c2cae75cc38f5cd /sci-physics/bullet/bullet-2.81.ebuild
parentsys-cluster/swift spelling fix for bug 457628 (diff)
downloadhistorical-0c7a001b21ed936eb40dfa8431bf7e79fb3be986.tar.gz
historical-0c7a001b21ed936eb40dfa8431bf7e79fb3be986.tar.bz2
historical-0c7a001b21ed936eb40dfa8431bf7e79fb3be986.zip
Version bump
Package-Manager: portage-2.2.01.21688-prefix/cvs/Linux x86_64 Manifest-Sign-Key: 0x13CB1360
Diffstat (limited to 'sci-physics/bullet/bullet-2.81.ebuild')
-rw-r--r--sci-physics/bullet/bullet-2.81.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sci-physics/bullet/bullet-2.81.ebuild b/sci-physics/bullet/bullet-2.81.ebuild
new file mode 100644
index 000000000000..e6f5da829f75
--- /dev/null
+++ b/sci-physics/bullet/bullet-2.81.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-physics/bullet/bullet-2.81.ebuild,v 1.1 2013/03/04 22:32:13 bicatali Exp $
+
+EAPI=5
+
+inherit eutils cmake-utils
+
+# version release, check http://code.google.com/p/bullet/downloads/list
+MYP=${P}-rev2613
+
+DESCRIPTION="Continuous Collision Detection and Physics Library"
+HOMEPAGE="http://www.bulletphysics.com/"
+SRC_URI="http://bullet.googlecode.com/files/${MYP}.tgz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc double-precision examples extras"
+
+RDEPEND="
+ virtual/opengl
+ media-libs/freeglut"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.78-soversion.patch )
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # allow to generate docs
+ sed -i -e 's/GENERATE_HTMLHELP.*//g' Doxyfile || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_CPU_DEMOS=OFF
+ -DBUILD_DEMOS=OFF
+ -DUSE_GRAPHICAL_BENCHMARK=OFF
+ -DINSTALL_LIBS=ON
+ -DINSTALL_EXTRA_LIBS=ON
+ $(cmake-utils_use_build extras EXTRAS)
+ $(cmake-utils_use_use double-precision DOUBLE_PRECISION)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc *.pdf && dohtml -r html/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r Extras Demos
+ fi
+}