summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <tanderson@gentoo.org>2009-02-20 17:39:28 +0000
committerThomas Anderson <tanderson@gentoo.org>2009-02-20 17:39:28 +0000
commite20fb29a1e7ed70c80916ce057562fb80b58b759 (patch)
tree4b6fb608cf3f26ba1399b2a736b950924153cf0e /sci-mathematics
parentMigrate to EAPI 2 use deps (diff)
downloadhistorical-e20fb29a1e7ed70c80916ce057562fb80b58b759.tar.gz
historical-e20fb29a1e7ed70c80916ce057562fb80b58b759.tar.bz2
historical-e20fb29a1e7ed70c80916ce057562fb80b58b759.zip
Fix EAPI 2 function additions
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/dataplot/ChangeLog6
-rw-r--r--sci-mathematics/dataplot/Manifest4
-rw-r--r--sci-mathematics/dataplot/dataplot-20080225.ebuild8
3 files changed, 10 insertions, 8 deletions
diff --git a/sci-mathematics/dataplot/ChangeLog b/sci-mathematics/dataplot/ChangeLog
index fdd4247ecd3f..944eea9e7634 100644
--- a/sci-mathematics/dataplot/ChangeLog
+++ b/sci-mathematics/dataplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-mathematics/dataplot
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/ChangeLog,v 1.6 2009/02/20 17:36:44 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/ChangeLog,v 1.7 2009/02/20 17:39:12 gentoofan23 Exp $
+
+ 20 Feb 2009; Thomas Anderson <gentoofan23@gentoo.org>
+ dataplot-20080225.ebuild:
+ Fix EAPI 2 function additions
20 Feb 2009; Thomas Anderson <gentoofan23@gentoo.org>
dataplot-20080225.ebuild:
diff --git a/sci-mathematics/dataplot/Manifest b/sci-mathematics/dataplot/Manifest
index fbaa6a09c71f..6c5f4fe1bf69 100644
--- a/sci-mathematics/dataplot/Manifest
+++ b/sci-mathematics/dataplot/Manifest
@@ -1,5 +1,5 @@
-MISC ChangeLog 4478 RMD160 b17bcda64623a34399209698a16a86482eb2b841 SHA1 6abe8e1023db41aa8c16b5ff14aa2bc37294898d SHA256 de78c889f0f004dc2239be178c795e410d07c3c249751055bf2092ef0df09e4f
-EBUILD dataplot-20080225.ebuild 2375 RMD160 332bfaa67cd76dd87903b8d71404aaa1bd08a1cb SHA1 c4488de097e5b5771e7a9d1e11aad2ece2855959 SHA256 0408fd242dadd64133b374bd355efea4d2550cae8fd766d9a60794fb526563d1
+MISC ChangeLog 4595 RMD160 5de829817dfbae238751f140d73e8eb6ad36481f SHA1 a16e86c8cde5bc5a32a2a1ac5b3a1c604ab747b4 SHA256 681fc6979e77fc394515b81f08f0904da1eb10f534b58a7c4e8a07ae397c6626
+EBUILD dataplot-20080225.ebuild 2326 RMD160 43c0af9679ccd635b0cab8c9bb7111d1756fd48a SHA1 53d11c6c3d2c202bdd1e98b5bebaeae54f94963d SHA256 c8eb3665d2a07dc92bd32a7adbdf04b2275c24999b9e4f8638a14c41852be7c3
AUX 90dataplot 75 RMD160 d561beb32d6b98a1809fa46a103beaa115450585 SHA1 160b11d262ee4aac6d1af48dc96af905d1724a55 SHA256 a0e547d52eca3ec872bd996712e93d550d65f66a693416ce6944504cab78df6c
AUX Makefile.am.20080225 1246 RMD160 05e5b07336606da88381a31882f32b482e807d22 SHA1 acb5e834086dbf895e60cb75a8807dfa763f5372 SHA256 083de39fb87096dc26209b2084d04d9ead949a0c8a87f6da9dddb21899acbfef
AUX configure.ac.20080225 2967 RMD160 7e5f8a192fba3e5e4441b912bec60e97f3c3c981 SHA1 2a8ea0e90240071cd3d80d1af88fc54266ad9a07 SHA256 a89eade674ffaf683b73537133e56df6d6ccc3093ea78c783049400a845eec85
diff --git a/sci-mathematics/dataplot/dataplot-20080225.ebuild b/sci-mathematics/dataplot/dataplot-20080225.ebuild
index 31302ccb8c14..c2b0154b400b 100644
--- a/sci-mathematics/dataplot/dataplot-20080225.ebuild
+++ b/sci-mathematics/dataplot/dataplot-20080225.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20080225.ebuild,v 1.5 2009/02/20 17:36:44 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/dataplot/dataplot-20080225.ebuild,v 1.6 2009/02/20 17:39:12 gentoofan23 Exp $
EAPI="2"
inherit eutils toolchain-funcs autotools fortran
@@ -58,14 +58,12 @@ src_unpack() {
eautoreconf
}
-src_compile() {
+src_configure() {
econf \
$(use_enable gd) \
$(use_enable gs) \
$(use_enable opengl) \
- $(use_enable X) || die "Econf failed"
-
- emake || die "Make failed"
+ $(use_enable X)
}
src_install() {