summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-05-13 22:59:14 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-05-13 22:59:14 +0000
commit5ba48be5eb898d7b28376f8c9c56c4fa621bac95 (patch)
treec702dfd78432da4dab4d991786f3e6ed69d50c80 /sci-libs
parentadded {blas,lapack}-atlas-3.7.10 due to massive changes and testing. (diff)
downloadhistorical-5ba48be5eb898d7b28376f8c9c56c4fa621bac95.tar.gz
historical-5ba48be5eb898d7b28376f8c9c56c4fa621bac95.tar.bz2
historical-5ba48be5eb898d7b28376f8c9c56c4fa621bac95.zip
Experimental ebuild for 3.7.10. Use with care. Uses eclectic from start.
Package-Manager: portage-2.0.51.21-r1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog9
-rw-r--r--sci-libs/blas-atlas/Manifest12
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.10.ebuild160
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.102
4 files changed, 177 insertions, 6 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 2037c089b583..bcd98ab2ba77 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.4 2005/03/30 20:51:43 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.5 2005/05/13 22:59:14 kugelfang Exp $
+
+*blas-atlas-3.7.10 (14 May 2005)
+
+ 14 May 2005; Danny van Dyk <kugelfang@gentoo.org>
+ +blas-atlas-3.7.10.ebuild:
+ Version bump to 3.7.10, but still in package.mask. First version to rely on
+ eclectic instead of blas-config.
30 Mar 2005; Danny van Dyk <kugelfang@gentoo.org> files/c-threaded-ATLAS:
Fixed BUG #83849 (typo).
diff --git a/sci-libs/blas-atlas/Manifest b/sci-libs/blas-atlas/Manifest
index 82ee0bc8866b..0858233d651f 100644
--- a/sci-libs/blas-atlas/Manifest
+++ b/sci-libs/blas-atlas/Manifest
@@ -1,19 +1,21 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 465ac03444e536707001390b257192c3 ChangeLog 3536
+MD5 34fc46a3c66727fbedf3f93124d20dde ChangeLog 3765
MD5 d3f9840c74e78f05c11a81d70309edf3 blas-atlas-3.6.0.ebuild 4158
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 e3aff2a6a60b92467ced6aab5b01511c blas-atlas-3.7.10.ebuild 4091
MD5 646c8df3efa24d6573a870dbb0f5fc8d files/f77-ATLAS 457
MD5 73bb69e091e5629e3d47ec813d560223 files/c-ATLAS 497
MD5 869c65bd1672b6bea4f03520e7e1cdf9 files/c-threaded-ATLAS 563
MD5 c1c57e922c1763ddde357504442e94c4 files/digest-blas-atlas-3.6.0 139
MD5 c0a79db6ec6fb95a56ce677107f08c01 files/f77-threaded-ATLAS 492
MD5 13d26350d75e6993f1b3ec48ca97f14e files/war 545
+MD5 e092f2baac7a6c4e34591acb77552017 files/digest-blas-atlas-3.7.10 140
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
+Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCSxHU5mJXAu5GbtIRAoSdAJ9PJvqqyjYU5yyFpbsDsfSETb2dMACfaEs4
-P3QNbGdysD3AjzE3KDGn9sw=
-=JwGG
+iD8DBQFChTHf5mJXAu5GbtIRAkXIAJ4gyMimyQf0SIL6NRyBxGPIO73EnwCfcnUD
+/f72EM9DmMeEtZodn4xQcIU=
+=GPvo
-----END PGP SIGNATURE-----
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.10.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.10.ebuild
new file mode 100644
index 000000000000..ba192dc2a37f
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.10.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.10.ebuild,v 1.1 2005/05/13 22:59:14 kugelfang Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+MY_PV=3.6.0
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/atlas${MY_PV}-shared-libs.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~ppc64 ~sparc ~alpha"
+IUSE="doc"
+
+DEPEND=">=app-admin/eclectic-0.9.2
+ >=sys-devel/libtool-1.5"
+RDEPEND=">=app-admin/eclectic-0.9.2"
+PROVIDE="virtual/blas"
+S=${WORKDIR}/ATLAS
+FORTRAN="g77"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${DISTDIR}/atlas3.6.0-shared-libs.patch.bz2
+ sed -i \
+ -e "s:ASM:ASM VOLATILE:" \
+ include/contrib/camm_dpa.h \
+ || die "sed failed to fix clobbering"
+
+ cp ${FILESDIR}/war ${S}
+ chmod a+x ${S}/war
+}
+
+atlas_fail() {
+ eerror
+ eerror "ATLAS auto-config failed."
+ eerror "Please run 'interactive=1 emerge blas-atlas' to configure manually."
+ eerror
+ die "ATLAS auto-config failed."
+}
+
+# Added to allow compilation on sparc architecture. The default CCFLAG0
+# and MMFLAGS are *bad*.
+# Danny van Dyk <kugelfang@gentoo.org> 2004/07/02
+#
+reconfigure() {
+ case "`uname -p`" in
+ "sun4m")
+ MY_CCFLAGS="-O3 -mcpu=v8"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=v8"
+ MY_LDFLAGS=""
+ ;;
+ "sun4u")
+ MY_CCFLAGS="-O3 -mcpu=ultrasparc"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=ultrasparc"
+ MY_LDFLAGS=""
+ ;;
+ *)
+ MY_CCFLAGS="${CFLAGS}"
+ MY_CXXFLAGS="${CXXFLAGS}"
+ MY_MMFLAGS="${CFLAGS}"
+ MY_LDFLAGS="${LDFLAGS}"
+ ;;
+ esac
+
+ MY_FILE="`find -name Make.Linux*`"
+
+ sed -i -e "s/CCFLAG0 =.*/CCFLAG0 = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CCFLAGS =.*/CCFLAGS = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CLINKFLAGS =.*/CLINKFLAGS =\$(CDEFS) ${MY_LDFLAGS}/" \
+ -e "s/XCCFLAGS =.*/XCCFLAGS =\$(CDEFS) ${MY_CXXFLAGS}/" \
+ -e "s/MMFLAGS =.*/MMFLAGS = ${MY_MMFLAGS}/" \
+ ${MY_FILE} || die "sed didnt complete"
+}
+
+src_compile() {
+ # Libraries will be installed in ${RPATH}/atlas and ${RPATH}/threaded-atlas:
+ RPATH="${DESTTREE}/$(get_libdir)/blas"
+
+ if [ -n "${interactive}" ]
+ then
+ echo "${interactive}"
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
+ else
+ # Use ATLAS defaults for all questions:
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
+ fi
+
+ reconfigure
+
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+
+ make install arch=${ATLAS_ARCH} || die
+
+ make shared-strip arch=${ATLAS_ARCH} RPATH=${RPATH}/atlas || die
+
+ # Build shared versions of the threaded libs.
+ # ATLAS only compiles threaded libs on multiprocessor machines.
+ if [ -d gentoo/libptf77blas.a ]
+ then
+ make ptshared-strip \
+ arch=${ATLAS_ARCH} RPATH=${RPATH}/threaded-atlas || die
+ fi
+}
+
+src_install () {
+ dodir ${RPATH}/atlas
+ cd ${S}/gentoo/libs
+ cp -P libatlas* ${D}/${DESTTREE}/$(get_libdir)
+ cp -P *blas* ${D}/${RPATH}/atlas #the rest really
+
+ insinto ${RPATH}
+ doins ${FILESDIR}/c-ATLAS ${FILESDIR}/f77-ATLAS
+
+ if [ -d ${S}/gentoo/threaded-libs ]
+ then
+ dodir ${RPATH}/threaded-atlas
+ cd ${S}/gentoo/threaded-libs
+ cp -P * ${D}/${RPATH}/threaded-atlas
+ doins ${FILESDIR}/c-threaded-ATLAS ${FILESDIR}/f77-threaded-ATLAS
+ fi
+
+ insinto ${DESTTREE}/include/atlas
+ doins ${S}/include/cblas.h
+
+ # These headers contain the architecture-specific optimizations determined
+ # by ATLAS. The atlas-lapack build is much shorter if they are available,
+ # so save them:
+ doins ${S}/include/${ATLAS_ARCH}/*.h
+
+ #some docs
+ cd ${S}
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ if [ -d ${RPATH}/threaded-atlas ]
+ then
+ ${DESTTREE}/bin/blas-config threaded-ATLAS
+ else
+ ${DESTTREE}/bin/blas-config ATLAS
+ fi
+
+ einfo
+ einfo "Fortran users link using -lblas"
+ einfo
+ einfo "C users compile against the header /usr/include/atlas/cblas.h and"
+ einfo "link using -lcblas"
+ einfo
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.10 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.10
new file mode 100644
index 000000000000..634949f44b4b
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.10
@@ -0,0 +1,2 @@
+MD5 c24aa9f676122fe6331fa63dd88c4113 atlas3.7.10.tar.bz2 2033340
+MD5 743b75ec473ab0f0edda6b649aa89060 atlas3.6.0-shared-libs.patch.bz2 5140