summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2006-05-10 18:37:21 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2006-05-10 18:37:21 +0000
commit40a91e8df30c23201ebd1488a1ccd8fd355bc084 (patch)
tree361fbbdc21c392b031720cab562732a97e25ce3c /sci-libs/acml
parentAdded ~hppa and fixed access voilation. (diff)
downloadhistorical-40a91e8df30c23201ebd1488a1ccd8fd355bc084.tar.gz
historical-40a91e8df30c23201ebd1488a1ccd8fd355bc084.tar.bz2
historical-40a91e8df30c23201ebd1488a1ccd8fd355bc084.zip
Fixed bug #128084: Symlinking acml.h to /usr/include/.
Diffstat (limited to 'sci-libs/acml')
-rw-r--r--sci-libs/acml/ChangeLog6
-rw-r--r--sci-libs/acml/acml-2.5.0.ebuild10
-rw-r--r--sci-libs/acml/acml-2.7.0.ebuild6
-rw-r--r--sci-libs/acml/acml-3.0.0.ebuild6
-rw-r--r--sci-libs/acml/acml-3.1.0.ebuild6
5 files changed, 23 insertions, 11 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index ca81cb6f9628..e777f9620824 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/acml
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.6 2006/05/10 18:05:27 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.7 2006/05/10 18:37:21 kugelfang Exp $
+
+ 10 May 2006; Danny van Dyk <kugelfang@gentoo.org> acml-2.5.0.ebuild,
+ acml-2.7.0.ebuild, acml-3.0.0.ebuild, acml-3.1.0.ebuild:
+ Fixed bug #128084: Symlinking acml.h to /usr/include/.
*acml-3.1.0 (10 May 2006)
diff --git a/sci-libs/acml/acml-2.5.0.ebuild b/sci-libs/acml/acml-2.5.0.ebuild
index 7fe41cb64485..4163965e2440 100644
--- a/sci-libs/acml/acml-2.5.0.ebuild
+++ b/sci-libs/acml/acml-2.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.5.0.ebuild,v 1.2 2005/08/31 21:33:40 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.5.0.ebuild,v 1.3 2006/05/10 18:37:21 kugelfang Exp $
inherit eutils
@@ -51,6 +51,8 @@ src_install() {
# Headers
mkdir -p ${D}/usr/include/acml/
cp ${S}/gnu${SUFFIX}/include/* ${D}/usr/include/acml/
+ cd ${D}/usr/include
+ ln -s acml/acml.h acml.h
# Libraries
mkdir -p ${D}/usr/$(get_libdir)/
@@ -67,7 +69,7 @@ src_install() {
pkg_postinst() {
einfo "To use ACML's BLAS features, you have to issue (as root):"
- einfo "\n\t/usr/bin/blas-config ACML"
+ einfo "\n\t/usr/bin/eselect blas set ACML"
einfo "To use ACML's LAPACK features, you have to issue (as root):"
- einfo "\n\t/usr/bin/lapack-config ACML"
+ einfo "\n\t/usr/bin/eselect lapack set ACML"
}
diff --git a/sci-libs/acml/acml-2.7.0.ebuild b/sci-libs/acml/acml-2.7.0.ebuild
index e8ce9228e599..9380ce6911a8 100644
--- a/sci-libs/acml/acml-2.7.0.ebuild
+++ b/sci-libs/acml/acml-2.7.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.7.0.ebuild,v 1.2 2005/11/16 22:52:32 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-2.7.0.ebuild,v 1.3 2006/05/10 18:37:21 kugelfang Exp $
inherit eutils
@@ -51,6 +51,8 @@ src_install() {
# Headers
mkdir -p ${D}/usr/include/acml/
cp ${S}/gnu${BITS}${SUFFIX}/include/* ${D}/usr/include/acml/
+ cd ${D}/usr/include
+ ln -s acml/acml.h acml.h
# Libraries
mkdir -p ${D}/usr/$(get_libdir)/
diff --git a/sci-libs/acml/acml-3.0.0.ebuild b/sci-libs/acml/acml-3.0.0.ebuild
index b7dfafa5035a..f8154081823d 100644
--- a/sci-libs/acml/acml-3.0.0.ebuild
+++ b/sci-libs/acml/acml-3.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.0.0.ebuild,v 1.2 2006/05/10 18:05:27 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.0.0.ebuild,v 1.3 2006/05/10 18:37:21 kugelfang Exp $
inherit eutils
@@ -51,7 +51,9 @@ src_install() {
# Headers
mkdir -p ${D}/usr/include/acml/
cp ${S}/gnu${BITS}${SUFFIX}/include/* ${D}/usr/include/acml/ \
- || die "Could not copy include files"
+ || die "Could not copy header file"
+ cd ${D}/usr/include
+ ln -s acml/acml.h acml.h
# Libraries
mkdir -p ${D}/usr/$(get_libdir)/
diff --git a/sci-libs/acml/acml-3.1.0.ebuild b/sci-libs/acml/acml-3.1.0.ebuild
index 12b6b77829ad..a88ef2b9101d 100644
--- a/sci-libs/acml/acml-3.1.0.ebuild
+++ b/sci-libs/acml/acml-3.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.1.0.ebuild,v 1.1 2006/05/10 18:05:27 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.1.0.ebuild,v 1.2 2006/05/10 18:37:21 kugelfang Exp $
inherit eutils
@@ -51,7 +51,9 @@ src_install() {
# Headers
mkdir -p ${D}/usr/include/acml/
cp ${S}/gnu${BITS}${SUFFIX}/include/* ${D}/usr/include/acml/ \
- || die "Could not copy include files"
+ || die "Could not copy header file"
+ cd ${D}/usr/include
+ ln -s acml/acml.h acml.h
# Libraries
mkdir -p ${D}/usr/$(get_libdir)/