summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-12-29 15:57:02 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-12-29 15:57:02 +0000
commite0e3cafcf0785610bfeb601da99915fcf86a486c (patch)
treec7cd372f1fd1ddd00c6c130842c06fd3c3090c0f /sci-electronics/ng-spice-rework
parentMarked ~amd64, resolves #75728. (diff)
downloadhistorical-e0e3cafcf0785610bfeb601da99915fcf86a486c.tar.gz
historical-e0e3cafcf0785610bfeb601da99915fcf86a486c.tar.bz2
historical-e0e3cafcf0785610bfeb601da99915fcf86a486c.zip
Fixing GCC 3.4 compile issues; bug #75901.
Diffstat (limited to 'sci-electronics/ng-spice-rework')
-rw-r--r--sci-electronics/ng-spice-rework/ChangeLog6
-rw-r--r--sci-electronics/ng-spice-rework/Manifest15
-rw-r--r--sci-electronics/ng-spice-rework/files/ng-spice-rework-15.gcc-3.4.patch37
-rw-r--r--sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild11
4 files changed, 55 insertions, 14 deletions
diff --git a/sci-electronics/ng-spice-rework/ChangeLog b/sci-electronics/ng-spice-rework/ChangeLog
index dd6ff9f7ea60..dc6f1bbebd3a 100644
--- a/sci-electronics/ng-spice-rework/ChangeLog
+++ b/sci-electronics/ng-spice-rework/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-electronics/ng-spice-rework
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ChangeLog,v 1.2 2004/12/27 21:04:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ChangeLog,v 1.3 2004/12/29 15:57:02 plasmaroo Exp $
+
+ 29 Dec 2004; <plasmaroo@gentoo.org> ng-spice-rework-15.ebuild,
+ +files/ng-spice-rework-15.gcc-3.4.patch:
+ Fixing GCC 3.4 compile issues; bug #75901.
*ng-spice-rework-15 (27 Dec 2004)
diff --git a/sci-electronics/ng-spice-rework/Manifest b/sci-electronics/ng-spice-rework/Manifest
index a6e6baefc757..37faf4bc8b38 100644
--- a/sci-electronics/ng-spice-rework/Manifest
+++ b/sci-electronics/ng-spice-rework/Manifest
@@ -1,16 +1,7 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 f317f19761af21bea1d8c6ea5255052a ChangeLog 1232
MD5 a11a25807dd08cbe161eedb1b6a5ad09 ng-spice-rework-14.ebuild 647
-MD5 bd46708ab196c551c95069e9dbe3eff7 ChangeLog 1077
+MD5 efe502b2460e37e7d13e81cf7e4d09b1 ng-spice-rework-15.ebuild 1028
MD5 e49bb02132d2cd74ad4e6ee291e102d9 metadata.xml 220
-MD5 a50b259c76cf3ea0a8f3f836d266920e ng-spice-rework-15.ebuild 931
+MD5 c9ab994f230b3c02ffca2d9d02e7d33b files/ng-spice-rework-15.gcc-3.4.patch 804
MD5 419df059e644593b30561622cf904785 files/digest-ng-spice-rework-14 71
MD5 cdcbac36f6d0470a9935636cb8ca3306 files/digest-ng-spice-rework-15 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFB0HjUI1lqEGTUzyQRAj3pAKCQejHo/ihnQclhulAc87C9T45HGwCeN2lj
-aY+U4g/10Mg8Qn+nXFKyN7U=
-=1KCa
------END PGP SIGNATURE-----
diff --git a/sci-electronics/ng-spice-rework/files/ng-spice-rework-15.gcc-3.4.patch b/sci-electronics/ng-spice-rework/files/ng-spice-rework-15.gcc-3.4.patch
new file mode 100644
index 000000000000..cd9f6ba49ad8
--- /dev/null
+++ b/sci-electronics/ng-spice-rework/files/ng-spice-rework-15.gcc-3.4.patch
@@ -0,0 +1,37 @@
+--- src/frontend/control.c.old 2004-12-29 13:53:16.012519944 +0000
++++ src/frontend/control.c 2004-12-29 13:53:17.683265952 +0000
+@@ -818,6 +818,17 @@
+ return (0); /* va: which value? */
+ }
+
++/* va: This totally frees the control structures */
++void cp_free_control(void)
++{
++ int i;
++
++ for (i=stackp; i>=0; i--) ctl_free(control[i]);
++
++ control[0] = cend[0] = NULL;
++ stackp = 0;
++}
++
+ /* This blows away the control structures... */
+ void
+ cp_resetcontrol(void)
+@@ -878,16 +889,3 @@
+ cend[stackp] = cend[stackp]->co_parent;
+ return;
+ }
+-
+-
+-/* va: This totally frees the control structures */
+-void cp_free_control(void)
+-{
+- int i;
+-
+- for (i=stackp; i>=0; i--) ctl_free(control[i]);
+-
+- control[0] = cend[0] = NULL;
+- stackp = 0;
+-}
+-
diff --git a/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild b/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild
index 5520710177a6..b1aefe9d838b 100644
--- a/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild
+++ b/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild,v 1.1 2004/12/27 20:05:13 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-electronics/ng-spice-rework/ng-spice-rework-15.ebuild,v 1.2 2004/12/29 15:57:02 plasmaroo Exp $
+
+inherit eutils
DESCRIPTION="NGSpice - The Next Generation Spice (Circuit Emulator)"
SRC_URI="http://www.geda.seul.org/dist/ngspice-rework${PV}.tgz"
@@ -13,6 +15,13 @@ KEYWORDS="~x86 ~ppc"
DEPEND=">=sys-libs/glibc-2.1.3"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}.gcc-3.4.patch
+}
+
src_compile() {
econf || die
emake || die