summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2005-12-20 03:56:38 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2005-12-20 03:56:38 +0000
commitcb14998ee1dbbd590b4b50589f470fef8a856c98 (patch)
tree8c308f49a990a7631d0807edc7dce6df8eea22a1 /sci-chemistry
parentAdd sci-chemistry/caver:pymol. (diff)
downloadhistorical-cb14998ee1dbbd590b4b50589f470fef8a856c98.tar.gz
historical-cb14998ee1dbbd590b4b50589f470fef8a856c98.tar.bz2
historical-cb14998ee1dbbd590b4b50589f470fef8a856c98.zip
New package providing rapid, accurate and fully automated calculation of pathways leading from buried cavities to outside solvent in static and dynamic protein structures. Also has a neat PyMol plugin.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/caver/ChangeLog12
-rw-r--r--sci-chemistry/caver/Manifest4
-rw-r--r--sci-chemistry/caver/caver-0.99.1.ebuild49
-rw-r--r--sci-chemistry/caver/files/digest-caver-0.99.12
-rw-r--r--sci-chemistry/caver/metadata.xml9
5 files changed, 76 insertions, 0 deletions
diff --git a/sci-chemistry/caver/ChangeLog b/sci-chemistry/caver/ChangeLog
new file mode 100644
index 000000000000..1cd00b2ff2dd
--- /dev/null
+++ b/sci-chemistry/caver/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for sci-chemistry/caver
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.1 2005/12/20 03:56:38 spyderous Exp $
+
+*caver-0.99.1 (20 Dec 2005)
+
+ 20 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml,
+ +caver-0.99.1.ebuild:
+ New package providing rapid, accurate and fully automated calculation of
+ pathways leading from buried cavities to outside solvent in static and
+ dynamic protein structures. Also has a neat PyMol plugin.
+
diff --git a/sci-chemistry/caver/Manifest b/sci-chemistry/caver/Manifest
new file mode 100644
index 000000000000..c9d229267e6f
--- /dev/null
+++ b/sci-chemistry/caver/Manifest
@@ -0,0 +1,4 @@
+MD5 8ce02fd5913949883e8686e441725d75 ChangeLog 546
+MD5 bb4a1218e09746c04c1f3da50f76eb66 caver-0.99.1.ebuild 1382
+MD5 946c4f9350e2386e497befe7afbe9cc2 files/digest-caver-0.99.1 130
+MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
diff --git a/sci-chemistry/caver/caver-0.99.1.ebuild b/sci-chemistry/caver/caver-0.99.1.ebuild
new file mode 100644
index 000000000000..737c2859a97a
--- /dev/null
+++ b/sci-chemistry/caver/caver-0.99.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/caver-0.99.1.ebuild,v 1.1 2005/12/20 03:56:38 spyderous Exp $
+
+inherit multilib python
+
+MY_PN="${PN}_unix"
+MY_P="${MY_PN}_v${PV}"
+DESCRIPTION="Rapid, accurate and fully automated calculation of pathways leading from buried cavities to outside solvent in static and dynamic protein structures"
+HOMEPAGE="http://viper.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.tar.gz
+ pymol? ( pymolplug.tar.gz )"
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="pymol"
+RDEPEND="media-libs/qhull
+ pymol? ( sci-chemistry/pymol )"
+DEPEND="${RDEPEND}"
+RESTRICT="fetch"
+S="${WORKDIR}/${MY_P}"
+
+pkg_nofetch() {
+ einfo "Download ${MY_P}.tar.gz"
+ if use pymol; then
+ einfo "and pymolplug.tar.gz"
+ fi
+ einfo "from ${HOMEPAGE}. This requires registration."
+ einfo "Place them in ${DISTDIR}."
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ if use pymol; then
+ python_version
+ sed -i \
+ -e "s:^\(CAVER_BINARY_LOCATION\).*:\1 = \"${ROOT}usr/bin/caver\":g" \
+ ${WORKDIR}/pymolplug/caver.py
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages/pmg_tk/startup
+ doins ${WORKDIR}/pymolplug/caver.py
+ fi
+}
+
+pkg_postinst() {
+ if use pymol; then
+ python_mod_compile \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/pmg_tk/startup/caver.py
+ fi
+}
diff --git a/sci-chemistry/caver/files/digest-caver-0.99.1 b/sci-chemistry/caver/files/digest-caver-0.99.1
new file mode 100644
index 000000000000..80f3e372b61f
--- /dev/null
+++ b/sci-chemistry/caver/files/digest-caver-0.99.1
@@ -0,0 +1,2 @@
+MD5 7dfc10f67d345d81fa74f0c2c8bbca8d caver_unix_v0.99.1.tar.gz 898765
+MD5 522581ce929adb5d3bef0fa540382362 pymolplug.tar.gz 81137
diff --git a/sci-chemistry/caver/metadata.xml b/sci-chemistry/caver/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/caver/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>