summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-02-03 02:20:37 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-02-03 02:20:37 +0000
commit16656aa4c7d0faeb143b0334d23fb55f673508c0 (patch)
treebccb9fd42d1501d13d000c0251893b48122f89db /sci-biology/mrbayes
parentBugfix release (diff)
downloadhistorical-16656aa4c7d0faeb143b0334d23fb55f673508c0.tar.gz
historical-16656aa4c7d0faeb143b0334d23fb55f673508c0.tar.bz2
historical-16656aa4c7d0faeb143b0334d23fb55f673508c0.zip
Moved from sci-biology/MrBayes to sci-biology/mrbayes.
Diffstat (limited to 'sci-biology/mrbayes')
-rw-r--r--sci-biology/mrbayes/ChangeLog17
-rw-r--r--sci-biology/mrbayes/Manifest4
-rw-r--r--sci-biology/mrbayes/files/digest-mrbayes-3.01
-rw-r--r--sci-biology/mrbayes/metadata.xml18
-rw-r--r--sci-biology/mrbayes/mrbayes-3.0.ebuild40
5 files changed, 80 insertions, 0 deletions
diff --git a/sci-biology/mrbayes/ChangeLog b/sci-biology/mrbayes/ChangeLog
new file mode 100644
index 000000000000..a12a0e6d0910
--- /dev/null
+++ b/sci-biology/mrbayes/ChangeLog
@@ -0,0 +1,17 @@
+# ChangeLog for sci-biology/MrBayes
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/ChangeLog,v 1.1 2005/02/03 02:20:37 j4rg0n Exp $
+
+*mrbayes-3.0 (02 Feb 2005)
+
+ 02 Feb 2005; <burgundy@gentoo.org> +metadata.xml, +mrbayes-3.0.ebuild:
+ Moved from sci-biology/MrBayes to sci-biology/mrbayes.
+
+*MrBayes-3.0 (30 Jan 2005)
+
+ 30 Jan 2005; Olivier Fisette <ribosome@gentoo.org> MrBayes-3.0.ebuild:
+ Check for "sed" exit code.
+
+ 19 Jan 2005; Lina Pezzella <j4rg0n@gentoo.org> :
+ Initial commit
+
diff --git a/sci-biology/mrbayes/Manifest b/sci-biology/mrbayes/Manifest
new file mode 100644
index 000000000000..a6fd168d4d5f
--- /dev/null
+++ b/sci-biology/mrbayes/Manifest
@@ -0,0 +1,4 @@
+MD5 f464ab228b7479f5821cec0105927b05 MrBayes-3.0.ebuild 841
+MD5 f3b54ff169e97f1f03375bd80dac4c0e ChangeLog 413
+MD5 3fd56e7547b0f35a37db19dd45932fef metadata.xml 792
+MD5 98b5d381ba0621a27ffce26bf40da031 files/digest-MrBayes-3.0 64
diff --git a/sci-biology/mrbayes/files/digest-mrbayes-3.0 b/sci-biology/mrbayes/files/digest-mrbayes-3.0
new file mode 100644
index 000000000000..f79cf0de2b89
--- /dev/null
+++ b/sci-biology/mrbayes/files/digest-mrbayes-3.0
@@ -0,0 +1 @@
+MD5 be98da64334732b9b12dde1da2907850 MrBayes-3.0.tar.bz2 300352
diff --git a/sci-biology/mrbayes/metadata.xml b/sci-biology/mrbayes/metadata.xml
new file mode 100644
index 000000000000..eade7f81070b
--- /dev/null
+++ b/sci-biology/mrbayes/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-biology</herd>
+<maintainer>
+ <email>j4rg0n@gentoo.org</email>
+</maintainer>
+<longdescription>
+MrBayes is a program for the Bayesian estimation of phylogeny.
+Bayesian inference of phylogeny is based upon a quantity called the
+posterior probability distribution of trees, which is the probability of a
+tree conditioned on the observations. The conditioning is accomplished using
+Bayes's theorem. The posterior probability distribution of trees is
+impossible to calculate analytically; instead, MrBayes uses a simulation
+technique called Markov chain Monte Carlo (or MCMC) to approximate the
+posterior probabilities of trees.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-biology/mrbayes/mrbayes-3.0.ebuild b/sci-biology/mrbayes/mrbayes-3.0.ebuild
new file mode 100644
index 000000000000..90516b6e5398
--- /dev/null
+++ b/sci-biology/mrbayes/mrbayes-3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mrbayes/mrbayes-3.0.ebuild,v 1.1 2005/02/03 02:20:37 j4rg0n Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Bayesian Inference of Phylogeny"
+HOMEPAGE="http://morphbank.ebc.uu.se/mrbayes/"
+SRC_URI="mirror://gentoo/MrBayes-3.0.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # TODO: Implement MPI-aware ebuild/use flags, etc. to use Makefile-Mpi
+
+ # Fix the non-standard Makefile.
+ sed -i \
+ -e "s:-O4:${CFLAGS}:" \
+ -e "s:gcc:${CC}:" \
+ Makefile || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ || die "emake failed"
+}
+
+src_install() {
+ # Non-standard manual install
+ into /usr
+ dobin mb
+}