summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2010-11-29 16:27:46 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2010-11-29 16:27:46 +0000
commit593a065beb7398c1189d18eaa219ecf28bd8356e (patch)
treeec3c0ed49477dda72d67f56b8a9efcd281ba3380 /sci-biology/last/last-146.ebuild
parentVersion bump (diff)
downloadhistorical-593a065beb7398c1189d18eaa219ecf28bd8356e.tar.gz
historical-593a065beb7398c1189d18eaa219ecf28bd8356e.tar.bz2
historical-593a065beb7398c1189d18eaa219ecf28bd8356e.zip
Version bump
Package-Manager: portage-2.2_rc86/cvs/Linux x86_64
Diffstat (limited to 'sci-biology/last/last-146.ebuild')
-rw-r--r--sci-biology/last/last-146.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/last/last-146.ebuild b/sci-biology/last/last-146.ebuild
new file mode 100644
index 000000000000..ae9c26505e70
--- /dev/null
+++ b/sci-biology/last/last-146.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-146.ebuild,v 1.1 2010/11/29 16:27:46 weaver Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Genome-scale comparison of biological sequences"
+HOMEPAGE="http://last.cbrc.jp/"
+SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_compile() {
+ emake -e -C src CXX="$(tc-getCXX)" \
+ STRICT="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin src/last{al,db} || die
+ exeinto /usr/share/${PN}/scripts
+ doexe scripts/* || die
+ dodoc doc/*.txt ChangeLog.txt README.txt || die
+}