summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-05 22:05:26 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-05 22:05:26 +0000
commite6d83fbcc0d3932ae5ec29df17b38302193ad976 (patch)
treef3ce0e06560e1e667f10418f22ad5f8a3d9019fa /sci-astronomy
parentSmall improvements of init-script. Do run udev-postmount always (diff)
downloadhistorical-e6d83fbcc0d3932ae5ec29df17b38302193ad976.tar.gz
historical-e6d83fbcc0d3932ae5ec29df17b38302193ad976.tar.bz2
historical-e6d83fbcc0d3932ae5ec29df17b38302193ad976.zip
Initial import
Package-Manager: portage-2.2_rc11/cvs/Linux 2.6.25-gentoo-r7 x86_64
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/ast/ChangeLog10
-rw-r--r--sci-astronomy/ast/Manifest14
-rw-r--r--sci-astronomy/ast/ast-4.6.2.ebuild42
-rw-r--r--sci-astronomy/ast/metadata.xml12
4 files changed, 78 insertions, 0 deletions
diff --git a/sci-astronomy/ast/ChangeLog b/sci-astronomy/ast/ChangeLog
new file mode 100644
index 000000000000..232e1fef0e7e
--- /dev/null
+++ b/sci-astronomy/ast/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/ast
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ChangeLog,v 1.1 2008/11/05 22:05:26 bicatali Exp $
+
+*ast-4.6.2 (05 Nov 2008)
+
+ 05 Nov 2008; SĂ©bastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +ast-4.6.2.ebuild:
+ Initial import
+
diff --git a/sci-astronomy/ast/Manifest b/sci-astronomy/ast/Manifest
new file mode 100644
index 000000000000..9384cabe1ac0
--- /dev/null
+++ b/sci-astronomy/ast/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST ast-4.6-2.tar.gz 11584346 RMD160 da6870fb2fed4b45d3e945541d5bf87dcbd4d7f6 SHA1 dcbd3a66852c9d63861f03998bada01aa7a20164 SHA256 47178d778517e65e213a49c5db59bc123507724d397593a95783cb92cbc9cd0e
+EBUILD ast-4.6.2.ebuild 1105 RMD160 f83b52a3d429ba8039d746ee6a00bbe5152b1e2a SHA1 bd8fdcdb3a854f59f0cf56df267a9cce2bb202f1 SHA256 e0f52a7001b23286020dc80ade3838633b979edf169f37d121e539be97e608b3
+MISC ChangeLog 344 RMD160 6a4722779406fd28350ccd8a810ae76460c68c14 SHA1 4f31cbdc0c6bf9fd8bcb92596530a30929adbf6b SHA256 b30e4e1c016dc37dde1f6f173a4e0ba8c64fc39c78445145a01c9ce0efa1f121
+MISC metadata.xml 525 RMD160 0ae28b2258b73b243a0a15af6be1451aaeff7e36 SHA1 6f630d82b6864565d1accaa59c27ed08477e222d SHA256 89798b5d9777297df075ff76257d62740b18eed26028938fa2e13a8686068cfa
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.9 (GNU/Linux)
+
+iEYEARECAAYFAkkSGNIACgkQ1ycZbhPLE2A3oACfdbL/vUZqXFFnKbrqziSMLipX
+q7cAn3ifaqP8L0o4Q4E7UsUPQjDzOTIZ
+=1ztp
+-----END PGP SIGNATURE-----
diff --git a/sci-astronomy/ast/ast-4.6.2.ebuild b/sci-astronomy/ast/ast-4.6.2.ebuild
new file mode 100644
index 000000000000..0459cfb42daf
--- /dev/null
+++ b/sci-astronomy/ast/ast-4.6.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ast-4.6.2.ebuild,v 1.1 2008/11/05 22:05:26 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator
+
+MYP="${PN}-$(replace_version_separator 2 '-')"
+DESCRIPTION="Library for handling World Coordinate Systems in astronomy"
+HOMEPAGE="http://www.starlink.ac.uk/~dsb/ast/ast.html"
+SRC_URI="http://www.starlink.ac.uk/~dsb/${PN}/${MYP}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # dont do sed in Makefile.am because it requires special starlink automake
+ sed -i \
+ -e 's/@STAR_LATEX_DOCUMENTATION@//' \
+ -e 's/ast.news//' \
+ -e 's/LICENCE//' \
+ -e 's/starfacs_DATA =.*/starfacs_DATA =/' \
+ -e '/$(INSTALL_DATA) $$MF/d' \
+ Makefile.in || die
+}
+
+src_configure() {
+ PATH=.:${PATH} econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ast.news fac_1521_err
+ if use doc; then
+ dodoc *.ps || die "doc install failed"
+ fi
+}
diff --git a/sci-astronomy/ast/metadata.xml b/sci-astronomy/ast/metadata.xml
new file mode 100644
index 000000000000..d708cee05f81
--- /dev/null
+++ b/sci-astronomy/ast/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The AST library provides a comprehensive range of facilities for
+ attaching world coordinate systems to astronomical data, for
+ retrieving and interpreting that information and for generating
+ graphical output based on it. It's easy to use, has plot facilities,
+ converting facilities, searching coordinate systems.
+</longdescription>
+</pkgmetadata>