summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-10-31 04:12:39 +0000
committerTorsten Veller <tove@gentoo.org>2011-10-31 04:12:39 +0000
commit20c46a14cb9329e67d5246e9ea54f5dd29f2d728 (patch)
tree76f54dbfca544f87d9310dc877021d4214a9ab31 /perl-core/Compress-Raw-Zlib
parent[bump] virtual/perl-Compress-Raw-Bzip2-2.40.0 (diff)
downloadhistorical-20c46a14cb9329e67d5246e9ea54f5dd29f2d728.tar.gz
historical-20c46a14cb9329e67d5246e9ea54f5dd29f2d728.tar.bz2
historical-20c46a14cb9329e67d5246e9ea54f5dd29f2d728.zip
[bump] perl-core/Compress-Raw-Zlib-2.40.0
Package-Manager: portage-2.2.0_alpha71/cvs/Linux x86_64
Diffstat (limited to 'perl-core/Compress-Raw-Zlib')
-rw-r--r--perl-core/Compress-Raw-Zlib/ChangeLog8
-rw-r--r--perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.40.0.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/perl-core/Compress-Raw-Zlib/ChangeLog b/perl-core/Compress-Raw-Zlib/ChangeLog
index a3e1bb1adcac..26dc08afb8fe 100644
--- a/perl-core/Compress-Raw-Zlib/ChangeLog
+++ b/perl-core/Compress-Raw-Zlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for perl-core/Compress-Raw-Zlib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.42 2011/07/30 12:11:52 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/ChangeLog,v 1.43 2011/10/31 04:12:39 tove Exp $
+
+*Compress-Raw-Zlib-2.40.0 (31 Oct 2011)
+
+ 31 Oct 2011; Torsten Veller <tove@gentoo.org>
+ +Compress-Raw-Zlib-2.40.0.ebuild:
+ Version bump
30 Jul 2011; Torsten Veller <tove@gentoo.org> Compress-Raw-Zlib-2.024.ebuild,
Compress-Raw-Zlib-2.33.ebuild, Compress-Raw-Zlib-2.35.0.ebuild,
diff --git a/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.40.0.ebuild b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.40.0.ebuild
new file mode 100644
index 000000000000..260326bb06bb
--- /dev/null
+++ b/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.40.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Compress-Raw-Zlib/Compress-Raw-Zlib-2.40.0.ebuild,v 1.1 2011/10/31 04:12:39 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=2.040
+inherit multilib perl-module
+
+DESCRIPTION="Low-Level Interface to zlib compression library"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=sys-libs/zlib-1.2.5"
+DEPEND="${RDEPEND}"
+# test? ( dev-perl/Test-Pod )"
+
+SRC_TEST=parallel
+
+src_prepare() {
+ perl-module_src_prepare
+
+ cat <<-EOF > "${S}/config.in"
+ BUILD_ZLIB = False
+ INCLUDE = ${EPREFIX}/usr/include
+ LIB = ${EPREFIX}/usr/$(get_libdir)
+
+ OLD_ZLIB = False
+ GZIP_OS_CODE = AUTO_DETECT
+ EOF
+}