summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-03-13 09:11:25 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-03-13 09:11:25 +0000
commit0639ad69296202e4c91923cde9a8c3dc8cef7053 (patch)
tree1b802c13cae00e14747c348fcd750489be9fba05 /net-zope
parentclean up (diff)
downloadhistorical-0639ad69296202e4c91923cde9a8c3dc8cef7053.tar.gz
historical-0639ad69296202e4c91923cde9a8c3dc8cef7053.tar.bz2
historical-0639ad69296202e4c91923cde9a8c3dc8cef7053.zip
System for managing development buildouts.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zcbuildout/ChangeLog10
-rw-r--r--net-zope/zcbuildout/Manifest4
-rw-r--r--net-zope/zcbuildout/metadata.xml22
-rw-r--r--net-zope/zcbuildout/zcbuildout-1.1.1.ebuild23
4 files changed, 59 insertions, 0 deletions
diff --git a/net-zope/zcbuildout/ChangeLog b/net-zope/zcbuildout/ChangeLog
new file mode 100644
index 000000000000..ee5c2be9c1ac
--- /dev/null
+++ b/net-zope/zcbuildout/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zcbuildout
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcbuildout/ChangeLog,v 1.1 2009/03/13 09:11:25 tupone Exp $
+
+*zcbuildout-1.1.1 (13 Mar 2009)
+
+ 13 Mar 2009; Alfredo Tupone <tupone@gentoo.org> +metadata.xml,
+ +zcbuildout-1.1.1.ebuild:
+ System for managing development buildouts.
+
diff --git a/net-zope/zcbuildout/Manifest b/net-zope/zcbuildout/Manifest
new file mode 100644
index 000000000000..345f2edcec81
--- /dev/null
+++ b/net-zope/zcbuildout/Manifest
@@ -0,0 +1,4 @@
+DIST zc.buildout-1.1.1.tar.gz 205601 RMD160 8d56c0d8e60f5461415535a2eb8113142382bf85 SHA1 48b42ed2a39e643a593bbfa194b2b5eb85647abc SHA256 2a41289e79b0c88b3e4dc734e0f1e4c19acbc235163d77bc91e584712e8d359b
+EBUILD zcbuildout-1.1.1.ebuild 583 RMD160 152a0c5bbc08c8556f68197b6646e91ce7df8481 SHA1 54e4838ac85ad6e153f80d6d7bfd6d62ee359a86 SHA256 e1f93d1334d11cd46e155f96d3552bf4524eed87b15d6b60799a9cff55b545c6
+MISC ChangeLog 383 RMD160 de0a02e2a79b282a9c67e450235d02a5489626a8 SHA1 68acfd5d72caa3c3c07754d6cc64d9b887bcfd68 SHA256 d43488a09857564d5d595e7dcf8569d57008462b70be7df4ffd90c71988f371f
+MISC metadata.xml 1350 RMD160 b412e4487cc88100887c5b2475df2381da9a90f0 SHA1 c62e4dbaf4b808842bdb357d5b7a57646fcdea59 SHA256 048e69827f60b6172cd7865f1b17646707f2d32aec4d82310688304f1a064a92
diff --git a/net-zope/zcbuildout/metadata.xml b/net-zope/zcbuildout/metadata.xml
new file mode 100644
index 000000000000..93d60c5c9928
--- /dev/null
+++ b/net-zope/zcbuildout/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-zope</herd>
+<maintainer>
+<email>tupone@gentoo.org</email>
+<name>Alfredo Tupone</name>
+</maintainer>
+<longdescription lang="en">
+Buildout is a system for managing development buildouts. While often identified as a Zope project,
+and indeed licensed under the ZPL by Zope creator Jim Fulton, buildout is useful for configurations
+beyond Zope, and even, in rare cases, a few that have nothing to do with Python.
+The Buildout project provides support for creating applications, especially Python applications. It
+provides tools for assembling applications from multiple parts, Python or otherwise. An application
+may actually contain multiple programs, processes, and configuration settings.
+The word .buildout. refers to a description of a set of parts and the software to create and assemble
+them. It is often used informally to refer to an installed system based on a buildout definition. For
+example, if we are creating an application named .Foo., then .the Foo buildout. is the collection of
+configuration and application-specific software that allows an instance of the application to be
+created. We may refer to such an instance of the application informally as .a Foo buildout..
+</longdescription>
+</pkgmetadata>
diff --git a/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild b/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild
new file mode 100644
index 000000000000..4bd19cf803e0
--- /dev/null
+++ b/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zcbuildout/zcbuildout-1.1.1.ebuild,v 1.1 2009/03/13 09:11:25 tupone Exp $
+
+inherit distutils
+
+MY_PN="zc.buildout"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="System for managing development buildouts"
+HOMEPAGE="http://buildout.zope.org/"
+SRC_URI="http://pypi.python.org/packages/source/z/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}"/${MY_P}