summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2004-09-26 18:12:47 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2004-09-26 18:12:47 +0000
commit07658396a6a1158af9b4cb9e041750f4ea768070 (patch)
treec9caec909664194b5134bddc7931383ef6842488 /net-zope/zope
parentMan iifest updates (diff)
downloadhistorical-07658396a6a1158af9b4cb9e041750f4ea768070.tar.gz
historical-07658396a6a1158af9b4cb9e041750f4ea768070.tar.bz2
historical-07658396a6a1158af9b4cb9e041750f4ea768070.zip
fixed bug #59616
Diffstat (limited to 'net-zope/zope')
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/Manifest4
-rw-r--r--net-zope/zope/zope-2.6.4-r1.ebuild19
3 files changed, 19 insertions, 11 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 2ba09b24e37c..ced65a241285 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.47 2004/09/26 09:51:15 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.48 2004/09/26 18:12:47 radek Exp $
+
+ 26 Sep 2004; Radoslaw Stachowiak <radek@gentoo.org> zope-2.6.4-r1.ebuild:
+ Fixed permission problem (775/664 or 755/644 depending on new/present
+ installation). Removed default instance creation at emerge time (zope-config
+ gives errors).
26 Sep 2004; Radoslaw Stachowiak <radek@gentoo.org> zope-2.7.2-r2.ebuild:
fixed bug #65254, removed init.d dir creation, changed --prefix to .
diff --git a/net-zope/zope/Manifest b/net-zope/zope/Manifest
index 4b5f07e1d801..7e0b51106107 100644
--- a/net-zope/zope/Manifest
+++ b/net-zope/zope/Manifest
@@ -1,8 +1,8 @@
MD5 05451aa19ac4681fd16a5a480f1c7ea5 zope-2.7.1.ebuild 3860
MD5 63ef64592d4abf31e444d6cce4228ada zope-2.7.2-r1.ebuild 5042
-MD5 95db19264fc46abc1bf3fd25469fcc56 zope-2.6.4-r1.ebuild 5359
+MD5 f22fdd902bc0d23c6f51f13498a2a502 zope-2.6.4-r1.ebuild 5644
MD5 a7b4f0510d44c03e310bf769fee46b18 zope-2.7.2.ebuild 4745
-MD5 e0449063f88fe5280dc08283bb694073 ChangeLog 8556
+MD5 70706a1a49d55a7a165d907309e08acb ChangeLog 8801
MD5 7890d88c5c6d189fbe6b187a3ebb6532 metadata.xml 161
MD5 2fa867d71fe8821e5d44fb147a0295eb zope-2.7.2-r2.ebuild 3220
MD5 ddddbf81a9803fef7474cb22df00a924 files/digest-zope-2.6.4-r1 64
diff --git a/net-zope/zope/zope-2.6.4-r1.ebuild b/net-zope/zope/zope-2.6.4-r1.ebuild
index f6cbec331e27..a2c93207d537 100644
--- a/net-zope/zope/zope-2.6.4-r1.ebuild
+++ b/net-zope/zope/zope-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.6.4-r1.ebuild,v 1.11 2004/09/06 00:29:39 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.6.4-r1.ebuild,v 1.12 2004/09/26 18:12:47 radek Exp $
inherit eutils
@@ -57,6 +57,10 @@ RCNAME=zope.initd
# * Other's should not have any access to ${ZSERVDIR},
# because they can work through the Zope web interface.
# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
# Parameters:
# $1 = instance directory
@@ -65,14 +69,13 @@ RCNAME=zope.initd
setup_security() {
chown -R ${ZUID}:${2} ${1}
chmod -R g+u ${1}
- chmod -R o-rwx ${1}
+ # 20040926 <radek@gentoo.org> changed, due to errors in ebuild and policy
+ chmod -R go+rX ${1}
}
install_help() {
- einfo "Need to setup an inituser (admin) before executing zope:"
- einfo "\tzope-config --zpasswd"
- einfo "To execute default Zope instance:"
- einfo "\t/etc/init.d/${ZGID} start"
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
}
pkg_preinst() {
@@ -165,8 +168,8 @@ src_install() {
pkg_postinst() {
# Here we add our default zope instance.
- /usr/sbin/zope-config --zserv=${ZSERVDIR} --zinst=${ZINSTDIR} \
- --zgid=${ZGID}
+ # UPDATE 20040925: disabled due to zope-config, errors
+ #/usr/sbin/zope-config --zserv=${ZSERVDIR} --zinst=${ZINSTDIR} --zgid=${ZGID}
install_help
}