summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-08 13:49:08 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-11-08 13:49:08 +0000
commita0fcd3964d16ed592b434b803443046f7c5a59bc (patch)
tree5debe8dae25b08cfed24f2f9a95f9072f6a769fb /net-zope/zope-app-intid
parentVersion bump. Fix distutils.eclass usage wrt #313501. Use virtual/jpeg wrt #3... (diff)
downloadhistorical-a0fcd3964d16ed592b434b803443046f7c5a59bc.tar.gz
historical-a0fcd3964d16ed592b434b803443046f7c5a59bc.tar.bz2
historical-a0fcd3964d16ed592b434b803443046f7c5a59bc.zip
Initial addition.
Package-Manager: portage-2.2.0_alpha4_p14/cvs/Linux x86_64
Diffstat (limited to 'net-zope/zope-app-intid')
-rw-r--r--net-zope/zope-app-intid/ChangeLog10
-rw-r--r--net-zope/zope-app-intid/metadata.xml5
-rw-r--r--net-zope/zope-app-intid/zope-app-intid-3.7.1.ebuild33
3 files changed, 48 insertions, 0 deletions
diff --git a/net-zope/zope-app-intid/ChangeLog b/net-zope/zope-app-intid/ChangeLog
new file mode 100644
index 000000000000..4ca96827d721
--- /dev/null
+++ b/net-zope/zope-app-intid/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-zope/zope-app-intid
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-app-intid/ChangeLog,v 1.1 2010/11/08 13:44:14 arfrever Exp $
+
+*zope-app-intid-3.7.1 (08 Nov 2010)
+
+ 08 Nov 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +zope-app-intid-3.7.1.ebuild, +metadata.xml:
+ Initial addition. Ebuild written by me.
+
diff --git a/net-zope/zope-app-intid/metadata.xml b/net-zope/zope-app-intid/metadata.xml
new file mode 100644
index 000000000000..42125e6223db
--- /dev/null
+++ b/net-zope/zope-app-intid/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-zope</herd>
+</pkgmetadata>
diff --git a/net-zope/zope-app-intid/zope-app-intid-3.7.1.ebuild b/net-zope/zope-app-intid/zope-app-intid-3.7.1.ebuild
new file mode 100644
index 000000000000..21a6319bfa26
--- /dev/null
+++ b/net-zope/zope-app-intid/zope-app-intid-3.7.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-app-intid/zope-app-intid-3.7.1.ebuild,v 1.1 2010/11/08 13:44:14 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+MY_PN="${PN//-/.}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="ZMI views for Integer Id Utility"
+HOMEPAGE="http://pypi.python.org/pypi/zope.app.intid"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-zope/zope-intid
+ net-zope/zope-security
+ net-zope/zope-traversing"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="CHANGES.txt README.txt"
+PYTHON_MODNAME="${PN//-//}"