summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2004-03-07 17:24:51 +0000
committerBrad Laue <brad@gentoo.org>2004-03-07 17:24:51 +0000
commit9e05dd28dd960b256ca25395325f89e55c3c822a (patch)
treeda81fcb45659797a87f5c505266f2e509a612588 /net-www
parentXinerama support, new enigmail (diff)
downloadhistorical-9e05dd28dd960b256ca25395325f89e55c3c822a.tar.gz
historical-9e05dd28dd960b256ca25395325f89e55c3c822a.tar.bz2
historical-9e05dd28dd960b256ca25395325f89e55c3c822a.zip
Xinerama support
Diffstat (limited to 'net-www')
-rw-r--r--net-www/mozilla-firefox/ChangeLog7
-rw-r--r--net-www/mozilla-firefox/Manifest6
-rw-r--r--net-www/mozilla-firefox/files/digest-mozilla-firefox-0.8-r11
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-0.8-r1.ebuild275
4 files changed, 286 insertions, 3 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index f3cb7409b189..397f8964c226 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.14 2004/02/26 15:08:15 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.15 2004/03/07 17:24:51 brad Exp $
+
+*mozilla-firefox-0.8-r1 (07 Mar 2004)
+
+ 07 Mar 2004; Brad Laue <brad@gentoo.org> mozilla-firefox-0.8-r1.ebuild:
+ Add Xinerama support.
26 Feb 2004; Aron Griffis <agriffis@gentoo.org> files/firefox:
Add a PATH fix from Bob Bell to be able to find xwininfo
diff --git a/net-www/mozilla-firefox/Manifest b/net-www/mozilla-firefox/Manifest
index 2dfb31a084ac..fd25fac36d2a 100644
--- a/net-www/mozilla-firefox/Manifest
+++ b/net-www/mozilla-firefox/Manifest
@@ -1,9 +1,11 @@
+MD5 a8ec9df898714effc2570276b0d77b02 ChangeLog 2408
MD5 ce23390351fe8020387d93ee29e09a3d metadata.xml 160
MD5 4a0f098fe65f44ad956d91fedce0251f mozilla-firefox-0.8.ebuild 7660
-MD5 a6f25b2e4cd08315ffadc0c06b24ead6 ChangeLog 2274
-MD5 e05944e11df3e5b45d4e206a17a0bba7 files/firefox 4050
+MD5 c00a7b16b8078de6cc9fa3b7a67746a8 mozilla-firefox-0.8-r1.ebuild 7818
MD5 606e82226379fd5ae6cd1d0d1faff7ff files/10MozillaFirefox 31
MD5 507a3d1338e85acc8828cec7c91d22df files/digest-mozilla-firefox-0.8 73
MD5 23d1fbd03cc6dd346a4e4ce8f2d88ebf files/mozilla-1.3-alpha-stubs.patch 4646
MD5 f0e9adeb0454377ce019e8969e644efb files/mozilla-firebird-amd64.patch 35052
+MD5 b26500869faf5f20034c378b495c3722 files/firefox 4038
+MD5 507a3d1338e85acc8828cec7c91d22df files/digest-mozilla-firefox-0.8-r1 73
MD5 bff260036c5dcca45da3218517fb33d8 files/icon/firefox-icon.png 3979
diff --git a/net-www/mozilla-firefox/files/digest-mozilla-firefox-0.8-r1 b/net-www/mozilla-firefox/files/digest-mozilla-firefox-0.8-r1
new file mode 100644
index 000000000000..23be07a3e957
--- /dev/null
+++ b/net-www/mozilla-firefox/files/digest-mozilla-firefox-0.8-r1
@@ -0,0 +1 @@
+MD5 cdc85152f4219bf3e3f1a8dc46e04654 firefox-source-0.8.tar.bz2 31102943
diff --git a/net-www/mozilla-firefox/mozilla-firefox-0.8-r1.ebuild b/net-www/mozilla-firefox/mozilla-firefox-0.8-r1.ebuild
new file mode 100644
index 000000000000..14370277ab49
--- /dev/null
+++ b/net-www/mozilla-firefox/mozilla-firefox-0.8-r1.ebuild
@@ -0,0 +1,275 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.8-r1.ebuild,v 1.1 2004/03/07 17:24:51 brad Exp $
+
+inherit makeedit flag-o-matic gcc nsplugins eutils
+
+S=${WORKDIR}/mozilla
+
+DESCRIPTION="The Mozilla Firefox Web Browser"
+HOMEPAGE="http://www.mozilla.org/projects/firefox/"
+SRC_URI="http://ftp.mozilla.org/pub/firefox/releases/${PV}/firefox-source-${PV}.tar.bz2"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64 ~ia64"
+SLOT="0"
+LICENSE="MPL-1.1 | NPL-1.1"
+IUSE="java gtk2 ipv6 gnome moznoxft xinerama"
+
+RDEPEND="virtual/x11
+ >=dev-libs/libIDL-0.8.0
+ >=gnome-base/ORBit-0.5.10-r1
+ virtual/xft
+ >=sys-libs/zlib-1.1.4
+ >=media-libs/jpeg-6b
+ >=media-libs/libmng-1.0.0
+ >=media-libs/libpng-1.2.1
+ >=sys-apps/portage-2.0.36
+ dev-libs/expat
+ app-arch/zip
+ app-arch/unzip
+ ( gtk2? >=x11-libs/gtk+-2.1.1 :
+ =x11-libs/gtk+-1.2* )
+ java? ( virtual/jre )
+ !net-www/mozilla-firefox-bin"
+
+DEPEND="${RDEPEND}
+ virtual/glibc
+ dev-util/pkgconfig
+ dev-lang/perl
+ java? ( >=dev-java/java-config-0.2.0 )"
+
+# needed by src_compile() and src_install()
+export MOZ_PHOENIX=1
+export MOZ_CALENDAR=0
+export MOZ_ENABLE_XFT=1
+
+src_unpack() {
+ unpack firefox-source-${PV}.tar.bz2
+
+ # alpha stubs patch from lfs project.
+ # <taviso@gentoo.org> (26 Jun 2003)
+ use alpha && epatch ${FILESDIR}/mozilla-1.3-alpha-stubs.patch
+ use amd64 && epatch ${FILESDIR}/mozilla-firebird-amd64.patch
+
+}
+
+src_compile() {
+ local enable_optimize=''
+ local myconf="--disable-composer \
+ --with-x \
+ --with-system-jpeg \
+ --with-system-zlib \
+ --with-system-png \
+ --with-system-mng \
+ --disable-mailnews \
+ --disable-calendar \
+ --disable-pedantic \
+ --disable-svg \
+ --enable-mathml \
+ --without-system-nspr \
+ --enable-nspr-autoconf \
+ --enable-xsl \
+ --enable-crypto \
+ --with-java-supplement \
+ --with-pthreads \
+ --with-default-mozilla-five-home=/usr/lib/MozillaFirefox \
+ --with-user-appdir=.phoenix \
+ --disable-jsd \
+ --disable-accessibility \
+ --disable-tests \
+ --disable-debug \
+ --disable-dtd-debug \
+ --disable-logging \
+ --enable-reorder \
+ --enable-strip \
+ --enable-strip-libs \
+ --enable-cpp-rtti \
+ --enable-xterm-updates \
+ --disable-ldap \
+ --disable-toolkit-qt \
+ --disable-toolkit-xlib \
+ --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help"
+
+ if [ -n "`use gtk2`" ] ; then
+ myconf="${myconf} --enable-toolkit-gtk2 \
+ --enable-default-toolkit=gtk2 \
+ --disable-toolkit-gtk"
+ else
+ myconf="${myconf} --enable-toolkit-gtk \
+ --enable-default-toolkit=gtk \
+ --disable-toolkit-gtk2"
+ fi
+
+ if [ -z "`use moznoxft`" ]
+ then
+ if [ -n "`use gtk2`" ]
+ then
+ local pango_version=""
+
+ # We need Xft2.0 localy installed
+ if (test -x /usr/bin/pkg-config) && (pkg-config xft)
+ then
+ pango_version="`pkg-config --modversion pango | cut -d. -f1,2`"
+ pango_version="`echo ${pango_version} | sed -e 's:\.::g'`"
+
+ # We also need pango-1.1, else Mozilla links to both
+ # Xft1.1 *and* Xft2.0, and segfault...
+ if [ "${pango_version}" -gt "10" ]
+ then
+ einfo "Building with Xft2.0 (Gtk+-2.0) support!"
+ myconf="${myconf} --enable-xft --disable-freetype2"
+ touch ${WORKDIR}/.xft
+ else
+ ewarn "Building without Xft2.0 support!"
+ myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
+ fi
+ else
+ ewarn "Building without Xft2.0 support!"
+ myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
+ fi
+ else
+ einfo "Building with Xft2.0 (Gtk+-1.0) support!"
+ myconf="${myconf} --enable-xft --disable-freetype2"
+ touch ${WORKDIR}/.xft
+ fi
+ else
+ myconf="${myconf} --disable-xft `use_enable truetype freetype2`"
+ fi
+
+ if [ -n "`use ipv6`" ] ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+
+ # Check for xinerama - closes #19369
+ if [ -n "`use xinerama`" ] ; then
+ myconf="${myconf} --enable-xinerama=yes"
+ else
+ myconf="${myconf} --enable-xinerama=no"
+ fi
+
+ # Per-architecture flags
+ case "${ARCH}" in
+ alpha|amd64|ia64)
+ # 64-bit needs -fPIC
+ append-flags -fPIC
+ ;;
+ sparc)
+ # Added to get MozillaFirebird to compile on sparc
+ replace-sparc64-flags
+ ;;
+ ppc)
+ # Fix to avoid gcc-3.3.x miscompilation issues.
+ if [ "$(gcc-major-version).$(gcc-minor-version)" = "3.3" ]; then
+ append-flags -fno-strict-aliasing
+ fi
+ ;;
+ esac
+
+ # 32-bit vs. 64-bit optimization
+ case "${ARCH}" in
+ alpha|amd64|ia64)
+ # Allow -O0 or -O1: Anything more than this causes
+ # segfaults on startup on 64-bit (bug 33767)
+ enable_optimize=$(echo "$CFLAGS" | sed 's/.*\(-O[01]\?\).*/\1/p')
+ enable_optimize=${enable_optimize:--O1}
+ filter-flags -O -O?
+ ;;
+ *)
+ # -O2 and below allowed on 32-bit
+ enable_optimize=$(echo "$CFLAGS" | sed 's/.*\(-O[012]\?\).*/\1/p')
+ enable_optimize=${enable_optimize:--O2}
+ filter-flags -O -O?
+ ;;
+ esac
+
+ # Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fomit-frame-pointer -mpowerpc-gfxopt
+ filter-flags -ffast-math
+ append-flags -s -fforce-addr
+
+ if [ "$(gcc-major-version)" -eq "3" ]; then
+ # Currently gcc-3.2 or older do not work well if we specify "-march"
+ # and other optimizations for pentium4.
+ if [ "$(gcc-minor-version)" -lt "3" ]; then
+ replace-flags -march=pentium4 -march=pentium3
+ filter-flags -msse2
+ fi
+
+ # Enable us to use flash, etc plugins compiled with gcc-2.95.3
+ if [ "${ARCH}" = "x86" ]; then
+ myconf="${myconf} --enable-old-abi-compat-wrappers"
+ fi
+ fi
+
+ econf --enable-optimize="${enable_optimize}" ${myconf} || die
+
+ edit_makefiles
+ emake MOZ_PHOENIX=1 || die
+}
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir ${PLUGIN_DIR}
+
+ dodir /usr/lib
+ dodir /usr/lib/MozillaFirefox
+ cp -RL --no-preserve=links ${S}/dist/bin/* ${D}/usr/lib/MozillaFirefox
+
+ #fix permissions
+ chown -R root:root ${D}/usr/lib/MozillaFirefox
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /usr/lib/MozillaFirefox/plugins
+
+ dobin ${FILESDIR}/firefox
+ insinto /etc/env.d
+ doins ${FILESDIR}/10MozillaFirefox
+
+ # Fix icons to look the same everywhere
+ insinto /usr/lib/MozillaFirefox/icons
+ doins ${S}/build/package/rpm/SOURCES/mozicon16.xpm
+ doins ${S}/build/package/rpm/SOURCES/mozicon50.xpm
+
+ # Install icon and .desktop for menu entry
+ if [ "`use gnome`" ]
+ then
+ insinto /usr/share/pixmaps
+ doins ${FILESDIR}/icon/firefox-icon.png
+ # Fix comment of menu entry
+ cd ${S}/build/package/rpm/SOURCES
+ cp mozilla.desktop mozillafirefox.desktop
+ perl -pi -e 's:Name=Mozilla:Name=Mozilla Firefox:' mozillafirefox.desktop
+ perl -pi -e 's:Comment=Mozilla:Comment=Mozilla Firefox Web Browser:' mozillafirefox.desktop
+ perl -pi -e 's:Exec=/usr/bin/mozilla:Exec=/usr/bin/firefox:' mozillafirefox.desktop
+ perl -pi -e 's:Icon=mozilla-icon.png:Icon=firefox-icon.png:' mozillafirefox.desktop
+ cd ${S}
+ insinto /usr/share/gnome/apps/Internet
+ doins ${S}/build/package/rpm/SOURCES/mozillafirefox.desktop
+ fi
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ pkg_mv_plugins /usr/lib/MozillaFirefox/plugins
+}
+
+pkg_postinst() {
+
+ export MOZILLA_FIVE_HOME="${ROOT}/usr/lib/MozillaFirefox"
+
+ # Needed to update the run time bindings for REGXPCOM
+ # (do not remove next line!)
+ env-update
+ # Register Components and Chrome
+ einfo "Registering Components and Chrome..."
+ LD_LIBRARY_PATH=/usr/lib/MozillaFirefox ${MOZILLA_FIVE_HOME}/regxpcom
+ LD_LIBRARY_PATH=/usr/lib/MozillaFirefox ${MOZILLA_FIVE_HOME}/regchrome
+ # Fix permissions of component registry
+ chmod 0644 ${MOZILLA_FIVE_HOME}/components/compreg.dat
+ # Fix directory permissions
+ find ${MOZILLA_FIVE_HOME}/ -type d -perm 0700 -exec chmod 0755 {} \; || :
+ # Fix permissions on chrome files
+ find ${MOZILLA_FIVE_HOME}/chrome/ -name '*.rdf' -exec chmod 0644 {} \; || :
+
+}