summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stewart <vericgar@gentoo.org>2005-12-11 03:01:15 +0000
committerMichael Stewart <vericgar@gentoo.org>2005-12-11 03:01:15 +0000
commit9c972cd93d81c5f6c410bbe645431975cdd6ea73 (patch)
tree63cb77ee08f27d5b4fef7654360327125812d05c /net-www
parentMarked ppc stable. (diff)
downloadhistorical-9c972cd93d81c5f6c410bbe645431975cdd6ea73.tar.gz
historical-9c972cd93d81c5f6c410bbe645431975cdd6ea73.tar.bz2
historical-9c972cd93d81c5f6c410bbe645431975cdd6ea73.zip
Remove generated/unused mime.types to fix bug 108200. Fix enewgroup/enewuser call location so that we work when installed from a binary package - fixes bug 110636.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog8
-rw-r--r--net-www/apache/Manifest6
-rw-r--r--net-www/apache/apache-2.0.54-r31.ebuild8
-rw-r--r--net-www/apache/apache-2.0.55.ebuild9
4 files changed, 23 insertions, 8 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index c1cedb10ea18..d8432be99101 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-www/apache
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.431 2005/12/04 08:19:11 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.432 2005/12/11 03:01:15 vericgar Exp $
+
+ 11 Dec 2005; Michael Stewart <vericgar@gentoo.org>
+ apache-2.0.54-r31.ebuild, apache-2.0.55.ebuild:
+ Remove generated/unused mime.types to fix bug 108200. Fix enewgroup/enewuser
+ call location so that we work when installed from a binary package - fixes
+ bug 110636.
*apache-1.3.33-r13 (04 Dec 2005)
diff --git a/net-www/apache/Manifest b/net-www/apache/Manifest
index 170f77f4e247..b5a110be78fb 100644
--- a/net-www/apache/Manifest
+++ b/net-www/apache/Manifest
@@ -1,4 +1,3 @@
-MD5 93a84e44400c5bec74660cb772bd56d3 ChangeLog 72429
MD5 b56779cb8460b101ad6912c8f45ff583 apache-1.3.29-r2.ebuild 7237
MD5 3e32afd7bbab740bdce0fc0cf45d5be3 apache-1.3.31-r1.ebuild 6816
MD5 a448a0e7566f85098cf55c54e4c6621f apache-1.3.31-r2.ebuild 6941
@@ -18,10 +17,11 @@ MD5 17e12318b6dd1cd8bb25cb987490c7fd apache-1.3.33-r6.ebuild 7108
MD5 ca6b47f0c2a0006b71fc1153937824e5 apache-1.3.33.ebuild 6927
MD5 8dfa3f0fbdc01264e754bd3ebf7b8a5a apache-2.0.54-r15.ebuild 12594
MD5 be59fbc220730a0212fbf6f34a1a6652 apache-2.0.54-r30.ebuild 12930
-MD5 2106ad9aafa7004e5d3e0f2a105f6ee3 apache-2.0.54-r31.ebuild 13258
+MD5 263979050e43b813bc0e092380262bb8 apache-2.0.54-r31.ebuild 13378
MD5 e1e33b99a1b8f95a419f0e95a6ebb2dc apache-2.0.54-r9.ebuild 12595
MD5 27c9cb37c510e08bb69df277229a03ea metadata.xml 566
-MD5 ff6c0c34f1e2a3feee2109b7dacabca4 apache-2.0.55.ebuild 13261
+MD5 92bcd37add7d46179b05da2170dcea55 apache-2.0.55.ebuild 13421
+MD5 dab5527b9062729187156c5628b261ad ChangeLog 72703
MD5 f154daabfa5b59d9597f8ede26b839d2 apache-1.3.33-r13.ebuild 8674
MD5 8b12871dd74fcd3f4fdf451c9d8c259e files/00_apache_manual.conf 781
MD5 998b4b7df08eb15641e0b9132443b365 files/apache-1.3.27-apachectl.patch 1328
diff --git a/net-www/apache/apache-2.0.54-r31.ebuild b/net-www/apache/apache-2.0.54-r31.ebuild
index 9c6556011c3a..64e24646c5d8 100644
--- a/net-www/apache/apache-2.0.54-r31.ebuild
+++ b/net-www/apache/apache-2.0.54-r31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.16 2005/10/07 18:11:47 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.54-r31.ebuild,v 1.17 2005/12/11 03:01:15 vericgar Exp $
inherit eutils gnuconfig multilib
@@ -264,6 +264,7 @@ src_install () {
mv usr/sbin/envvars* usr/$(get_libdir)/apache2/build
dodoc etc/apache2/*-std.conf
rm -f etc/apache2/*.conf
+ rm -f etc/apache2/mime.types
rm -rf var/run var/log
# we DEPEND on net-www/gentoo-webroot-default for sharing this by now
@@ -306,8 +307,11 @@ src_install () {
}
pkg_postinst() {
+ # setup apache user and group
+ enewgroup apache 81
+ enewuser apache 81 -1 /var/www apache
- # Automatically generate test ceritificates if ssl USE flag is beeing set
+ # Automatically generate test ceritificates if ssl USE flag is being set
if useq ssl -a !-e ${ROOT}/etc/apache2/ssl/server.crt; then
cd ${ROOT}/etc/apache2/ssl
einfo
diff --git a/net-www/apache/apache-2.0.55.ebuild b/net-www/apache/apache-2.0.55.ebuild
index 41d24a13a7b5..5a1a931f2031 100644
--- a/net-www/apache/apache-2.0.55.ebuild
+++ b/net-www/apache/apache-2.0.55.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.55.ebuild,v 1.2 2005/10/23 23:23:45 vericgar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.55.ebuild,v 1.3 2005/12/11 03:01:15 vericgar Exp $
inherit eutils gnuconfig multilib
@@ -264,6 +264,7 @@ src_install () {
mv usr/sbin/envvars* usr/$(get_libdir)/apache2/build
dodoc etc/apache2/*-std.conf
rm -f etc/apache2/*.conf
+ rm -f etc/apache2/mime.types
rm -rf var/run var/log
# we DEPEND on net-www/gentoo-webroot-default for sharing this by now
@@ -306,8 +307,12 @@ src_install () {
}
pkg_postinst() {
+ # setup apache user and group
+ # we do this twice for binary packages
+ enewgroup apache 81
+ enewuser apache 81 -1 /var/www apache
- # Automatically generate test ceritificates if ssl USE flag is beeing set
+ # Automatically generate test ceritificates if ssl USE flag is being set
if useq ssl -a !-e ${ROOT}/etc/apache2/ssl/server.crt; then
cd ${ROOT}/etc/apache2/ssl
einfo