summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-04-26 04:40:40 +0000
committerAron Griffis <agriffis@gentoo.org>2004-04-26 04:40:40 +0000
commit7acf3a27d2c34c83c7ca0a9f0e3fb1169711e43c (patch)
tree56ca2f681a6e130d6cd774eca0344601bfcb6855 /net-www/mozilla-firefox
parent- Honor moznomail for enigmail, ipc and gnupg in SRC_URI. - Fix bug 45671 (mo... (diff)
downloadhistorical-7acf3a27d2c34c83c7ca0a9f0e3fb1169711e43c.tar.gz
historical-7acf3a27d2c34c83c7ca0a9f0e3fb1169711e43c.tar.bz2
historical-7acf3a27d2c34c83c7ca0a9f0e3fb1169711e43c.zip
Filter -fstack-protector to fix bug 45671
Diffstat (limited to 'net-www/mozilla-firefox')
-rw-r--r--net-www/mozilla-firefox/ChangeLog6
-rw-r--r--net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild3
2 files changed, 7 insertions, 2 deletions
diff --git a/net-www/mozilla-firefox/ChangeLog b/net-www/mozilla-firefox/ChangeLog
index 50c36daf81a9..669e00fd1359 100644
--- a/net-www/mozilla-firefox/ChangeLog
+++ b/net-www/mozilla-firefox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-www/mozilla-firefox
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.27 2004/04/26 04:11:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/ChangeLog,v 1.28 2004/04/26 04:40:40 agriffis Exp $
+
+ 26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+ mozilla-firefox-0.8-r3.ebuild:
+ Filter -fstack-protector to fix bug 45671
26 Apr 2004; Aron Griffis <agriffis@gentoo.org>
+mozilla-firefox-0.8-r3.ebuild:
diff --git a/net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild b/net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild
index 011d86232895..305607c4f033 100644
--- a/net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild
+++ b/net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild,v 1.1 2004/04/26 04:11:22 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firefox/mozilla-firefox-0.8-r3.ebuild,v 1.2 2004/04/26 04:40:40 agriffis Exp $
inherit makeedit flag-o-matic gcc nsplugins eutils
@@ -174,6 +174,7 @@ src_compile() {
esac
# Crashes on start when compiled with -fomit-frame-pointer
+ filter-flags -fstack-protector # see bug 45671
filter-flags -fomit-frame-pointer -mpowerpc-gfxopt
filter-flags -ffast-math
append-flags -s -fforce-addr