summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-05-15 12:23:37 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-05-15 12:23:37 +0000
commit625db27b7d99c4e0bed99f97bdfb84c13555d42a (patch)
tree7ac643cd8d8b762902c180b12843dd5c2bf6bd16 /net-wireless
parentfixed bug 21050 (at least I hope I did) (diff)
downloadhistorical-625db27b7d99c4e0bed99f97bdfb84c13555d42a.tar.gz
historical-625db27b7d99c4e0bed99f97bdfb84c13555d42a.tar.bz2
historical-625db27b7d99c4e0bed99f97bdfb84c13555d42a.zip
fixed bug 21050 (at least I hope I did)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/hostap/Manifest4
-rw-r--r--net-wireless/hostap/files/digest-hostap-0.0.24
-rw-r--r--net-wireless/hostap/files/digest-hostap-0.0.2-r11
-rw-r--r--net-wireless/hostap/hostap-0.0.2-r1.ebuild160
4 files changed, 163 insertions, 6 deletions
diff --git a/net-wireless/hostap/Manifest b/net-wireless/hostap/Manifest
index c7fb410a372b..131e50a72fb1 100644
--- a/net-wireless/hostap/Manifest
+++ b/net-wireless/hostap/Manifest
@@ -1,7 +1,7 @@
-MD5 9a707000b69439cec58c9bee73c84583 hostap-0.0.2-r1.ebuild 4295
+MD5 0cccc8dc56ab904fd60590fd9a5066ac hostap-0.0.2-r1.ebuild 4289
MD5 1792c1d78c928fa0e303eb5c36860bf3 hostap-0.0.1.ebuild 4295
MD5 9a707000b69439cec58c9bee73c84583 hostap-0.0.2.ebuild 4295
-MD5 83438082f5d9bb726fa53ed5a481ec38 ChangeLog 2208
+MD5 53856306049be550eecbd2512fd633b2 ChangeLog 2461
MD5 f4a8c5996d013e8a161bf699bb7a2f83 files/digest-hostap-0.0.2-r1 64
MD5 423cd360c12fa0a6530fb01f334a0bd6 files/digest-hostap-0.0.1 354
MD5 f4a8c5996d013e8a161bf699bb7a2f83 files/digest-hostap-0.0.2 64
diff --git a/net-wireless/hostap/files/digest-hostap-0.0.2 b/net-wireless/hostap/files/digest-hostap-0.0.2
index f5bbd5d57676..b8da58ce4cdf 100644
--- a/net-wireless/hostap/files/digest-hostap-0.0.2
+++ b/net-wireless/hostap/files/digest-hostap-0.0.2
@@ -1,5 +1 @@
MD5 78b4043f36b11ae7d549e3111698ac7f hostap-0.0.2.tar.gz 263095
-MD5 7e9f01a697d2e3e5164340d79474ea30 pcmcia-cs-3.2.1.tar.gz 1250413
-MD5 24e8c68d0eac2a9b3446acdd259c22a0 pcmcia-cs-3.2.1-3.2.2.diff.gz 246919
-MD5 9ed9491a743b7400b382b199377c7279 pcmcia-cs-3.2.1-3.2.3.diff.gz 247541
-MD5 c94ce648d1e420be0cf02246236dc387 pcmcia-cs-3.2.1-3.2.4.diff.gz 305171
diff --git a/net-wireless/hostap/files/digest-hostap-0.0.2-r1 b/net-wireless/hostap/files/digest-hostap-0.0.2-r1
new file mode 100644
index 000000000000..b8da58ce4cdf
--- /dev/null
+++ b/net-wireless/hostap/files/digest-hostap-0.0.2-r1
@@ -0,0 +1 @@
+MD5 78b4043f36b11ae7d549e3111698ac7f hostap-0.0.2.tar.gz 263095
diff --git a/net-wireless/hostap/hostap-0.0.2-r1.ebuild b/net-wireless/hostap/hostap-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..e229d08b998e
--- /dev/null
+++ b/net-wireless/hostap/hostap-0.0.2-r1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/hostap/hostap-0.0.2-r1.ebuild,v 1.1 2003/05/15 12:23:29 phosphan Exp $
+
+inherit eutils
+
+DESCRIPTION="HostAP wireless drivers"
+HOMEPAGE="http://hostap.epitest.fi/"
+
+MY_PCMCIA="pcmcia-cs-3.2.1"
+PATCH_3_2_2="${MY_PCMCIA}-3.2.2.diff.gz"
+PATCH_3_2_3="${MY_PCMCIA}-3.2.3.diff.gz"
+PATCH_3_2_4="${MY_PCMCIA}-3.2.4.diff.gz"
+
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz
+ pcmcia? ( mirror://sourceforge/pcmcia-cs/${MY_PCMCIA}.tar.gz )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_2} )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_3} )
+ pcmcia? ( mirror://gentoo/${PATCH_3_2_4} )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="pcmcia"
+
+DEPEND=">=net-wireless/wireless-tools-25
+ pcmcia? ( >=sys-apps/pcmcia-cs-3.2.1* )"
+
+LIB_PATH="/lib/modules/${KV}"
+
+if [ x"${HOSTAP_DRIVERS}" = x ]; then
+ CUSTOM="no"
+else
+ CUSTOM="yes"
+fi
+
+src_unpack() {
+ check_KV
+ unpack ${P}.tar.gz
+
+ if [ -n "`use pcmcia`" ]; then
+ unpack ${MY_PCMCIA}.tar.gz
+ cd ${WORKDIR}/${MY_PCMCIA}
+ if [ -z "`has_version =sys-apps/pcmcia-cs-3.2.4*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_4}
+ elif [ -z "`has_version =sys-apps/pcmcia-cs-3.2.3*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_3}
+ elif [ -z "`has_version =sys-apps/pcmcia-cs-3.2.2*`" ]; then
+ epatch ${DISTDIR}/${PATCH_3_2_2}
+ fi
+ fi
+
+
+ cd ${S}
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ -e "s:\$(EXTRA_CFLAGS):\$(EXTRA_CFLAGS) -DPRISM2_HOSTAPD:" \
+ ${T}/Makefile > Makefile
+
+ if [ -n "`use pcmcia`" ] || [[ "${HOSTAP_DRIVERS}" == *pccard* ]]; then
+ mv Makefile ${T}
+ sed -e "s:^PCMCIA_PATH=:PCMCIA_PATH=${WORKDIR}/${MY_PCMCIA}:" \
+ ${T}/Makefile > Makefile
+ fi
+
+ cd ${S}/hostapd
+ mv Makefile ${T}
+ sed -e "s:gcc:${CC}:" \
+ -e "s:-O2:${CFLAGS}:" \
+ ${T}/Makefile > Makefile
+}
+
+src_compile() {
+ #
+ # This ebuild now uses a system similar to the alsa ebuild.
+ # By default, it will install the pci and plx drivers, and
+ # the pcmcia drivers if pcmcia is in your use variables. To
+ # specify exactly which drivers to build, do something like
+ #
+ # HOSTAP_DRIVERS="pci pccard" emerge hostap
+ #
+ # Available options are pci, plx, and pccard.
+ #
+ # If you experience problems compiling the hostap_pci module,
+ # try disabling CONFIG_MODVERSION from your kernel.
+ #
+
+ if [ "${CUSTOM}" == yes ]; then
+ einfo "Building the folowing drivers: ${HOSTAP_DRIVERS}"
+ emake ${HOSTAP_DRIVERS} hostap crypt || die
+ else
+ if [ -n "`use pcmcia`" ]; then
+ einfo "Building the folowing drivers: pci plx pccard"
+ emake pci plx pccard || die
+ else
+ einfo "Building the folowing drivers: pci plx"
+ emake pci plx || die
+ fi
+ fi
+
+ cd ${S}/hostapd
+ emake || die
+}
+
+src_install() {
+ dodir ${LIB_PATH}/net
+ cp ${S}/driver/modules/{hostap.o,hostap_crypt.o,hostap_crypt_wep.o}\
+ ${D}${LIB_PATH}/net/
+
+ if [ "${CUSTOM}" == "no" ]; then
+
+ if [ -n "`use pcmcia`" ]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+ for driver in ${HOSTAP_DRIVERS}; do
+ cp ${S}/driver/modules/hostap_${driver}.o\
+ ${D}${LIB_PATH}/net/;
+ done
+ elif [ "${CUSTOM}" == "yes" ]; then
+ if [[ "${HOSTAP_DRIVERS}" = *pccard* ]]; then
+ dodir ${LIB_PATH}/pcmcia
+ dodir /etc/pcmcia
+ cp ${S}/driver/modules/hostap_cs.o ${D}/${LIB_PATH}/pcmcia/
+ cp ${S}/driver/etc/hostap_cs.conf ${D}/etc/pcmcia/
+ if [ -r /etc/pcmcia/prism2.conf ]; then
+ einfo "You may need to edit or remove /etc/pcmcia/prism2.conf"
+ einfo "This is usually a result of conflicts with the"
+ einfo "linux-wlan-ng drivers."
+ fi
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *pci* ]]; then
+ cp ${S}/driver/modules/hostap_pci.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ if [[ "${HOSTAP_DRIVERS}" = *plx* ]]; then
+ cp ${S}/driver/modules/hostap_plx.o\
+ ${D}${LIB_PATH}/net/
+ fi
+
+ fi
+
+ dodoc FAQ README README.prism2 ChangeLog
+
+ dosbin hostapd/hostapd
+}
+pkg_postinst(){
+ /sbin/depmod -a
+}