summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-04-17 13:38:48 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-04-17 13:38:48 +0000
commit35b3a853fd133d5bba947f3f293ff524a5c33985 (patch)
tree7a0c95ae2f8788fb20200dc0ad99ef0bf9811001 /net-wireless
parentRemove net-libs/xulrunner from alternative || ( ) dependency wrt #403415 (diff)
downloadhistorical-35b3a853fd133d5bba947f3f293ff524a5c33985.tar.gz
historical-35b3a853fd133d5bba947f3f293ff524a5c33985.tar.bz2
historical-35b3a853fd133d5bba947f3f293ff524a5c33985.zip
Initial import, bug #90667. Based on ebuild from Lukas Sandström.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gnuradio/ChangeLog10
-rw-r--r--net-wireless/gnuradio/Manifest4
-rw-r--r--net-wireless/gnuradio/gnuradio-3.5.3.ebuild178
-rw-r--r--net-wireless/gnuradio/metadata.xml16
4 files changed, 208 insertions, 0 deletions
diff --git a/net-wireless/gnuradio/ChangeLog b/net-wireless/gnuradio/ChangeLog
new file mode 100644
index 000000000000..e7a69eb871f2
--- /dev/null
+++ b/net-wireless/gnuradio/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-wireless/gnuradio
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnuradio/ChangeLog,v 1.1 2012/04/17 13:38:48 chithanh Exp $
+
+*gnuradio-3.5.3 (17 Apr 2012)
+
+ 17 Apr 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +gnuradio-3.5.3.ebuild, +metadata.xml:
+ Initial import, bug #90667. Based on ebuild from Lukas Sandström.
+
diff --git a/net-wireless/gnuradio/Manifest b/net-wireless/gnuradio/Manifest
new file mode 100644
index 000000000000..255e52f6185b
--- /dev/null
+++ b/net-wireless/gnuradio/Manifest
@@ -0,0 +1,4 @@
+DIST gnuradio-3.5.3.tar.gz 4330883 RMD160 1400582718c45de6486d0d409d6b61aceacf5927 SHA1 661b9ac54cefa6d1b3de3dbd4f3bf466ac846ee4 SHA256 7c3a12233189f5334a7023c6cefdac506ccf7d55cc0cd965870f6f736211608f
+EBUILD gnuradio-3.5.3.ebuild 4842 RMD160 1d1d3c7058e2151125b25415e290da76e38051d4 SHA1 f2fb4035468530e512f3dca7eea0d463d219a14b SHA256 1e871a7a836982f19a2c33cd3dd1ceada784381921de80f7ad2aa77591170f06
+MISC ChangeLog 428 RMD160 8e90879aba9fd743fca0bc2b290ef04ad536055b SHA1 812d8ff5375bf8159207a522ee51f0132cc927dc SHA256 accd5eabe808f49e644968474e7eccf3bfc19b423b53e163178b73b30eac512d
+MISC metadata.xml 654 RMD160 174932e0ee2d7f490ff7409881e19f528c001991 SHA1 5ac43c785e2dc66aded860a01d1f7e0a4a16496b SHA256 5b95faa2ff38c43ce0b17fbb2f01f73bbfbe20e42546f68cb1fcd5cf597e9261
diff --git a/net-wireless/gnuradio/gnuradio-3.5.3.ebuild b/net-wireless/gnuradio/gnuradio-3.5.3.ebuild
new file mode 100644
index 000000000000..59d7d98ef1de
--- /dev/null
+++ b/net-wireless/gnuradio/gnuradio-3.5.3.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/gnuradio/gnuradio-3.5.3.ebuild,v 1.1 2012/04/17 13:38:48 chithanh Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+
+inherit eutils fdo-mime python
+
+DESCRIPTION="Toolkit that provides signal processing blocks to implement software radios"
+HOMEPAGE="http://gnuradio.org/"
+SRC_URI="http://gnuradio.org/redmine/attachments/download/320/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="audio doc dot examples fcd grc guile qt4 sdl utils wxwidgets"
+REQUIRED_USE="utils? ( wxwidgets )
+ fcd? ( audio )"
+
+# bug #348206
+# comedi? ( >=sci-electronics/comedilib-0.7 )
+# uhd? ( dev-libs/uhd )
+RDEPEND="dev-libs/boost
+ dev-python/numpy
+ dev-util/cppunit
+ sci-libs/fftw:3.0
+ sci-libs/gsl
+ virtual/cblas
+ fcd? ( virtual/libusb:1 )
+ audio? (
+ media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ >=media-libs/portaudio-19_pre
+ )
+ grc? (
+ dev-python/cheetah
+ dev-python/lxml
+ dev-python/pygtk:2
+ )
+ guile? ( >=dev-scheme/guile-1.8.4 )
+ qt4? (
+ dev-python/PyQt4[X,opengl]
+ dev-python/pyqwt:5
+ x11-libs/qt-gui
+ )
+ sdl? ( media-libs/libsdl )
+ wxwidgets? (
+ dev-python/wxpython:2.8
+ dev-python/numpy
+ )
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ dev-util/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.5.7.1[dot?]
+ app-text/xmlto
+ )
+ grc? (
+ x11-misc/xdg-utils
+ )
+"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -q -r 2 "${S}"
+ # TODO: DEPDIR is not created, need to investigate why
+ mkdir "${S}"/gnuradio-core/src/lib/general/.deps || die
+ mkdir "${S}"/gnuradio-core/src/lib/gengen/.deps || die
+ mkdir "${S}"/gr-trellis/src/lib/.deps || die
+}
+
+src_configure() {
+ # --with-lv_arch=32 fails to build on amd64
+ # TODO: more elegant solution is required before keywording on other arches
+ # TODO: docs are installed to /usr/share/doc/${PN} not /usr/share/doc/${PF}
+ econf \
+ --enable-all-components \
+ --enable-gnuradio-core \
+ --enable-gruel \
+ --enable-python \
+ --disable-gr-comedi \
+ --disable-gr-shd \
+ --disable-gr-uhd \
+ --with-lv_arch="generic 64 3dnow abm popcount mmx sse sse2 sse3 ssse3 sse4_a sse4_1 sse4_2 avx" \
+ $(use_enable audio gr-audio) \
+ $(use_enable doc doxygen) \
+ $(use_enable doc docs) \
+ $(use_enable dot) \
+ $(use_enable examples gnuradio-examples) \
+ $(use_enable fcd gr-fcd) \
+ $(use_enable grc) \
+ $(use_enable guile) \
+ $(use_enable utils gr-utils) \
+ $(use_enable wxwidgets gr-wxgui) \
+ $(use_enable sdl gr-video-sdl) \
+ $(use sdl || echo "--disable-sdltest") \
+ $(use_enable qt4 gr-qtgui) \
+ $(use_with qt4 qwt-incdir "${EPREFIX}"/usr/include/qwt5)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ python_clean_installation_image -q
+
+ # Install examples to /usr/share/doc/$PF
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/
+ mv "${ED}"/usr/share/gnuradio/examples "${ED}"/usr/share/doc/${PF}/ || die "failed installing examples"
+ else
+ # It seems that the examples are installed whether configured or not
+ rm -rf "${ED}"/usr/share/gnuradio/examples || die
+ fi
+
+ # Remove useless files in the doc dir
+ if use doc; then
+ rm -f "${ED}"/usr/share/doc/${PN}/html/*.md5 || die
+ fi
+
+ # We install the mimetypes to the correct locations from the ebuild
+ rm -rf "${ED}"/usr/share/gnuradio/grc/freedesktop || die
+ rm -f "${ED}"/usr/bin/grc_setup_freedesktop || die
+
+ # Install icons, menu items and mime-types for GRC
+ if use grc ; then
+ local fd_path="${S}/grc/freedesktop"
+ insinto /usr/share/mime/packages
+ doins "${fd_path}/gnuradio-grc.xml"
+
+ domenu "${fd_path}/"*.desktop
+ doicon "${fd_path}/"*.png
+ fi
+}
+
+pkg_postinst()
+{
+ local GRC_ICON_SIZES="32 48 64 128 256"
+ python_mod_optimize gnuradio
+
+ if use grc ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ for size in ${GRC_ICON_SIZES} ; do
+ xdg-icon-resource install --noupdate --context mimetypes --size ${size} \
+ "${ROOT}/usr/share/pixmaps/grc-icon-${size}.png" application-gnuradio-grc \
+ || die "icon resource installation failed"
+ xdg-icon-resource install --noupdate --context apps --size ${size} \
+ "${ROOT}/usr/share/pixmaps/grc-icon-${size}.png" gnuradio-grc \
+ || die "icon resource installation failed"
+ done
+ xdg-icon-resource forceupdate
+ fi
+}
+
+pkg_postrm()
+{
+ local GRC_ICON_SIZES="32 48 64 128 256"
+ python_mod_cleanup gnuradio
+
+ if use grc ; then
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ for size in ${GRC_ICON_SIZES} ; do
+ xdg-icon-resource uninstall --noupdate --context mimetypes --size ${size} \
+ application-gnuradio-grc || ewarn "icon uninstall failed"
+ xdg-icon-resource uninstall --noupdate --context apps --size ${size} \
+ gnuradio-grc || ewarn "icon uninstall failed"
+
+ done
+ xdg-icon-resource forceupdate
+ fi
+}
diff --git a/net-wireless/gnuradio/metadata.xml b/net-wireless/gnuradio/metadata.xml
new file mode 100644
index 000000000000..391ed9871094
--- /dev/null
+++ b/net-wireless/gnuradio/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+ </maintainer>
+ <use>
+ <flag name='audio'>enable audio output</flag>
+ <flag name='dot'>create dot graphs in documentation</flag>
+ <flag name='fcd'>enable Funcube Dongle source block</flag>
+ <flag name='grc'>enable GNU Radio Companion graphical tool to design signal processing flow graphs</flag>
+ <flag name='utils'>install scripts to enable viewing and analysis of files produced by flow graphs</flag>
+ </use>
+</pkgmetadata>
+