summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2006-07-11 18:55:35 +0000
committerAlin Năstac <mrness@gentoo.org>2006-07-11 18:55:35 +0000
commit88022a5e8315ad4f78c04e8b052347ce5e1b64df (patch)
tree4021868f694e512569f3ec48ac9268e22e0ec4d3 /net-proxy/squid
parentfix SRC_URI - depend on newer version of bglibs - fixes bug #117521 - thanks ... (diff)
downloadhistorical-88022a5e8315ad4f78c04e8b052347ce5e1b64df.tar.gz
historical-88022a5e8315ad4f78c04e8b052347ce5e1b64df.tar.bz2
historical-88022a5e8315ad4f78c04e8b052347ce5e1b64df.zip
Add current upstream patches (#139962)
Package-Manager: portage-2.1-r1
Diffstat (limited to 'net-proxy/squid')
-rw-r--r--net-proxy/squid/ChangeLog8
-rw-r--r--net-proxy/squid/files/digest-squid-2.6.1-r16
-rw-r--r--net-proxy/squid/metadata.xml2
-rw-r--r--net-proxy/squid/squid-2.6.1-r1.ebuild191
4 files changed, 205 insertions, 2 deletions
diff --git a/net-proxy/squid/ChangeLog b/net-proxy/squid/ChangeLog
index 7654478819b3..b990f12b8add 100644
--- a/net-proxy/squid/ChangeLog
+++ b/net-proxy/squid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/squid
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.80 2006/07/10 18:25:01 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/ChangeLog,v 1.81 2006/07/11 18:55:35 mrness Exp $
+
+*squid-2.6.1-r1 (11 Jul 2006)
+
+ 11 Jul 2006; Alin Nastac <mrness@gentoo.org> metadata.xml,
+ -squid-2.6.1.ebuild, +squid-2.6.1-r1.ebuild:
+ Add current upstream patches (#139962).
*squid-2.6.1 (10 Jul 2006)
diff --git a/net-proxy/squid/files/digest-squid-2.6.1-r1 b/net-proxy/squid/files/digest-squid-2.6.1-r1
new file mode 100644
index 000000000000..dcac16bc522a
--- /dev/null
+++ b/net-proxy/squid/files/digest-squid-2.6.1-r1
@@ -0,0 +1,6 @@
+MD5 478b6871baf83f98f57eaa0e51b4416f squid-2.6.STABLE1-patches-20060711.tar.gz 24063
+RMD160 9cc2daf35f22fcf0dc2bf4109b39ac8032b78985 squid-2.6.STABLE1-patches-20060711.tar.gz 24063
+SHA256 edea461781c676b8c6a2ad5e181436594c64325ac8f76d9d870e77d4596801b6 squid-2.6.STABLE1-patches-20060711.tar.gz 24063
+MD5 f1e7f7693c3d2ed329c31a7a855c83cb squid-2.6.STABLE1.tar.gz 1579299
+RMD160 6b1740a6db8117b12ba8b859d56a28669d29d10a squid-2.6.STABLE1.tar.gz 1579299
+SHA256 e52a4c8b35a0644f0b1285874e4b0c0905e6415140d134c30ed2a4717392692e squid-2.6.STABLE1.tar.gz 1579299
diff --git a/net-proxy/squid/metadata.xml b/net-proxy/squid/metadata.xml
index 79229f18aad9..fc7d93d62b31 100644
--- a/net-proxy/squid/metadata.xml
+++ b/net-proxy/squid/metadata.xml
@@ -2,5 +2,5 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-proxy</herd>
-<longdescription>A caching web proxy, with advanced features</longdescription>
+<longdescription>A full-featured web proxy cache</longdescription>
</pkgmetadata>
diff --git a/net-proxy/squid/squid-2.6.1-r1.ebuild b/net-proxy/squid/squid-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..babde3b53716
--- /dev/null
+++ b/net-proxy/squid/squid-2.6.1-r1.ebuild
@@ -0,0 +1,191 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/squid/squid-2.6.1-r1.ebuild,v 1.1 2006/07/11 18:55:35 mrness Exp $
+
+inherit eutils pam toolchain-funcs flag-o-matic autotools
+
+#lame archive versioning scheme..
+S_PV="${PV%.*}"
+S_PL="${PV##*.}"
+S_PL="${S_PL/_rc/-RC}"
+S_PP="${PN}-${S_PV}.STABLE${S_PL}"
+PATCH_VERSION="20060711"
+
+DESCRIPTION="A full-featured web proxy cache"
+HOMEPAGE="http://www.squid-cache.org/"
+SRC_URI="http://www.squid-cache.org/Versions/v2/${S_PV}/${S_PP}.tar.gz
+ mirror://gentoo/${S_PP}-patches-${PATCH_VERSION}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="pam ldap sasl nis ssl snmp selinux logrotate \
+ pf-transparent ipf-transparent \
+ elibc_uclibc kernel_linux \
+ underscores customlog zero-penalty-hit follow-xff" #Dead flags; should be removed when <squid-2.6.1 versions are removed
+
+RDEPEND="pam? ( virtual/pam )
+ ldap? ( >=net-nds/openldap-2.1.26 )
+ ssl? ( >=dev-libs/openssl-0.9.7j )
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.21 )
+ selinux? ( sec-policy/selinux-squid )
+ !x86-fbsd? ( logrotate? ( app-admin/logrotate ) )"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+S="${WORKDIR}/${S_PP}"
+
+pkg_setup() {
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+
+ use zero-penalty-hit && ewarn "zero-penalty-hit patch has been removed because the homepage has vanished."
+ use underscores && ewarn "underscores USE flag has no effect (the option is available through allow_underscore configuration directive)."
+ use customlog && ewarn "customlog USE flag has no effect (the correspondent patch has been included in the main version)."
+ use follow-xff && ewarn "follow-xff USE flag has no effect (the correspondent patch has been included in the main version)."
+}
+
+src_unpack() {
+ unpack ${A} || die "unpack failed"
+ cd "${S}" || die "dir ${S} not found"
+
+ # Do bulk patching from squids bug fix list as well as our patches
+ EPATCH_SUFFIX="patch"
+ epatch "${WORKDIR}/patch"
+
+ sed -i -e 's%LDFLAGS="-g"%LDFLAGS=""%' configure.in
+
+ #disable lazy bindings on (some at least) suided basic auth programs
+ sed -i -e '$aAM_LDFLAGS = '$(bindnow-flags) \
+ helpers/basic_auth/*/Makefile.am
+
+ eautoreconf
+}
+
+src_compile() {
+ local basic_modules="getpwnam,NCSA,SMB,MSNT,multi-domain-NTLM"
+ use ldap && basic_modules="LDAP,${basic_modules}"
+ use pam && basic_modules="PAM,${basic_modules}"
+ use sasl && basic_modules="SASL,${basic_modules}"
+ use nis && ! use elibc_uclibc && basic_modules="YP,${basic_modules}"
+
+ local ext_helpers="ip_user,session,unix_group,wbinfo_group"
+ use ldap && ext_helpers="ldap_group,${ext_helpers}"
+
+ local myconf=""
+
+ # Support for uclibc #61175
+ if use elibc_uclibc; then
+ myconf="${myconf} --enable-storeio=ufs,diskd,aufs,null"
+ myconf="${myconf} --disable-async-io"
+ else
+ myconf="${myconf} --enable-storeio=ufs,diskd,coss,aufs,null"
+ myconf="${myconf} --enable-async-io"
+ fi
+
+ if use kernel_linux; then
+ myconf="${myconf} --enable-linux-netfilter --enable-epoll"
+ elif use kernel_freebsd || use kernel_openbsd || use kernel_netbsd ; then
+ myconf="${myconf} --enable-kqueue"
+ if use pf-transparent; then
+ myconf="${myconf} --enable-pf-transparent"
+ elif use ipf-transparent; then
+ myconf="${myconf} --enable-ipf-transparent"
+ fi
+ fi
+
+ export CC=$(tc-getCC)
+
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --exec-prefix=/usr \
+ --sbindir=/usr/sbin \
+ --localstatedir=/var \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/squid \
+ --libexecdir=/usr/lib/squid \
+ --datadir=/usr/share/squid \
+ --enable-auth="basic,digest,ntlm" \
+ --enable-removal-policies="lru,heap" \
+ --enable-digest-auth-helpers="password" \
+ --enable-basic-auth-helpers="${basic_modules}" \
+ --enable-external-acl-helpers="${ext_helpers}" \
+ --enable-ntlm-auth-helpers="SMB,fakeauth" \
+ --enable-ident-lookups \
+ --enable-useragent-log \
+ --enable-cache-digests \
+ --enable-delay-pools \
+ --enable-referer-log \
+ --enable-truncate \
+ --enable-arp-acl \
+ --with-pthreads \
+ --with-large-files \
+ --enable-htcp \
+ --enable-carp \
+ --enable-follow-x-forwarded-for \
+ $(use_enable snmp) \
+ $(use_enable ssl) \
+ --host=${CHOST} ${myconf} || die "bad ./configure"
+
+ sed -i -e "s:^#define SQUID_MAXFD.*:#define SQUID_MAXFD 8192:" \
+ include/autoconf.h
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ #need suid root for looking into /etc/shadow
+ fowners root:squid /usr/lib/squid/ncsa_auth
+ fowners root:squid /usr/lib/squid/pam_auth
+ fperms 4750 /usr/lib/squid/ncsa_auth
+ fperms 4750 /usr/lib/squid/pam_auth
+
+ #some clean ups
+ rm -f "${D}"/usr/bin/Run*
+
+ #simply switch this symlink to choose the desired language..
+ dosym /usr/share/squid/errors/English /etc/squid/errors
+
+ dodoc CONTRIBUTORS CREDITS ChangeLog QUICKSTART SPONSORS doc/*.txt \
+ helpers/ntlm_auth/no_check/README.no_check_ntlm_auth
+ newdoc helpers/basic_auth/SMB/README README.auth_smb
+ dohtml helpers/basic_auth/MSNT/README.html RELEASENOTES.html
+ newdoc helpers/basic_auth/LDAP/README README.auth_ldap
+ doman helpers/basic_auth/LDAP/*.8
+ dodoc helpers/basic_auth/SASL/squid_sasl_auth*
+
+ newpamd "${FILESDIR}/squid.pam" squid
+ newconfd "${FILESDIR}/squid.confd" squid
+ if use logrotate; then
+ newinitd "${FILESDIR}/squid.initd-logrotate" squid
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/squid.logrotate" squid
+ else
+ newinitd "${FILESDIR}/squid.initd" squid
+ exeinto /etc/cron.weekly
+ newexe "${FILESDIR}/squid.cron" squid.cron
+ fi
+
+ rm -rf "${D}"/var
+ diropts -m0755 -o squid -g squid
+ keepdir /var/cache/squid /var/log/squid
+}
+
+pkg_preinst() {
+ enewgroup squid 31
+ enewuser squid 31 -1 /var/cache/squid squid
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Squid authentication helpers have been installed suid root."
+ ewarn "This allows shadow based authentication (see bug #52977 for more)."
+ echo
+ ewarn "Be careful what type of cache_dir you select!"
+ ewarn " 'diskd' is optimized for high levels of traffic, but it might seem slow"
+ ewarn "when there isn't sufficient traffic to keep squid reasonably busy."
+ ewarn " If your traffic level is low to moderate, use 'aufs' or 'ufs'."
+ echo
+}