summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-04-22 19:15:12 +0000
committerAlin Năstac <mrness@gentoo.org>2005-04-22 19:15:12 +0000
commitf37e8c80d1499334a8b5d51bf781f5a655e68147 (patch)
tree00cd35d8f79526e3d16c31f19bf342992ba539c2 /net-proxy/httpush
parentAdding pcmcia flag. Closes #90025, Cheers Georgi (diff)
downloadhistorical-f37e8c80d1499334a8b5d51bf781f5a655e68147.tar.gz
historical-f37e8c80d1499334a8b5d51bf781f5a655e68147.tar.bz2
historical-f37e8c80d1499334a8b5d51bf781f5a655e68147.zip
www-proxy -> net-proxy
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-proxy/httpush')
-rw-r--r--net-proxy/httpush/ChangeLog13
-rw-r--r--net-proxy/httpush/Manifest4
-rw-r--r--net-proxy/httpush/files/digest-httpush-0.9_beta111
-rw-r--r--net-proxy/httpush/httpush-0.9_beta11.ebuild60
-rw-r--r--net-proxy/httpush/metadata.xml6
5 files changed, 84 insertions, 0 deletions
diff --git a/net-proxy/httpush/ChangeLog b/net-proxy/httpush/ChangeLog
new file mode 100644
index 000000000000..398c417d82cf
--- /dev/null
+++ b/net-proxy/httpush/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for www-proxy/httpush
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/httpush/ChangeLog,v 1.1 2005/04/22 19:15:11 mrness Exp $
+
+ 22 Apr 2005; Alin Nastac <mrness@gentoo.org> :
+ Rename category & herd www-proxy to net-proxy
+
+*httpush-0.9_beta11 (01 Apr 2005)
+
+ 01 Apr 2005; Alin Nastac <mrness@gentoo.org> +metadata.xml,
+ +httpush-0.9_beta11.ebuild:
+ Initial import from bug #87307.
+
diff --git a/net-proxy/httpush/Manifest b/net-proxy/httpush/Manifest
new file mode 100644
index 000000000000..86dc3121ce44
--- /dev/null
+++ b/net-proxy/httpush/Manifest
@@ -0,0 +1,4 @@
+MD5 5d6738eb89a93379cf55d6341be67333 httpush-0.9_beta11.ebuild 1407
+MD5 f0cc5b23cd201a1cef5030837239f1ff ChangeLog 467
+MD5 4465953c86462494dd13e67580e4fd8b metadata.xml 415
+MD5 c9beb4a47643787632f3a8010dba451f files/digest-httpush-0.9_beta11 65
diff --git a/net-proxy/httpush/files/digest-httpush-0.9_beta11 b/net-proxy/httpush/files/digest-httpush-0.9_beta11
new file mode 100644
index 000000000000..a11bcc3deab8
--- /dev/null
+++ b/net-proxy/httpush/files/digest-httpush-0.9_beta11
@@ -0,0 +1 @@
+MD5 bad2220807a6b2345887ce25953d6ae4 httpush-0.9b11.tar.gz 39342
diff --git a/net-proxy/httpush/httpush-0.9_beta11.ebuild b/net-proxy/httpush/httpush-0.9_beta11.ebuild
new file mode 100644
index 000000000000..625d2972d2d8
--- /dev/null
+++ b/net-proxy/httpush/httpush-0.9_beta11.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/httpush/httpush-0.9_beta11.ebuild,v 1.1 2005/04/22 19:15:11 mrness Exp $
+
+inherit eutils
+
+MY_P="${P/_beta/b}"
+
+DESCRIPTION="Httpush is an intercepting proxy, allowing user to modify HTTP requests on-the-fly"
+HOMEPAGE="http://httpush.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="xml2"
+
+RDEPEND="dev-perl/URI
+ dev-perl/MIME-Base64
+ dev-perl/libwww-perl
+ dev-perl/Net-SSLeay
+ dev-perl/Crypt-SSLeay
+ dev-perl/HTML-Parser
+ xml2? ( dev-perl/XML-Twig )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! useq xml2 ; then
+ echo
+ einfo "If you'd like to use httpush's learning mode, please CTRL-C now"
+ einfo "and enable the xml2 USE flag."
+ epause 3
+ echo
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:^\(require httpush;\)$:push @INC, "/usr/lib/httpush";\n\1:' \
+ httpush.pl || die "sed INC failed"
+ sed -i 's:^\(.*DATADIR="\)data\(.*\)$:\1/var/lib/httpush\2:' *.pl \
+ lib/plugin/broker.pm || die "sed DATADIR= failed"
+}
+
+src_install() {
+ keepdir /var/lib/httpush
+
+ insinto /usr/lib/httpush
+ doins -r httpush.{dtd,lck,pem,pm} lib
+
+ insinto /usr/share/httpush/plugins
+ doins plugins/*
+
+ newbin httpush.pl httpush
+ newbin reindex.pl reindex
+
+ dodoc README ChangeLog LICENSE doc/*
+}
diff --git a/net-proxy/httpush/metadata.xml b/net-proxy/httpush/metadata.xml
new file mode 100644
index 000000000000..da12e1aef8d6
--- /dev/null
+++ b/net-proxy/httpush/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-proxy</herd>
+<longdescription>HTTPush aims at providing an easy way to audit HTTP and HTTPS application/server security. It supports on-the-fly request modification, automated decision making and vulnerability detection through the use of plugins.</longdescription>
+</pkgmetadata>