summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-16 23:33:52 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-16 23:33:52 +0000
commit935b238d5a72cbd102de373e96e7024fcc1811dc (patch)
tree9bfd8856d14bd76d9423ffacfaaebef586660b60 /net-p2p
parentAdd support for latest kernels that no longer define KERNEL_VERSION in versio... (diff)
downloadhistorical-935b238d5a72cbd102de373e96e7024fcc1811dc.tar.gz
historical-935b238d5a72cbd102de373e96e7024fcc1811dc.tar.bz2
historical-935b238d5a72cbd102de373e96e7024fcc1811dc.zip
Filter -fomit-frame-pointer on x86 as it clash with execeptions handling.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/Manifest14
-rw-r--r--net-p2p/rtorrent/files/digest-rtorrent-0.2.7-r11
-rw-r--r--net-p2p/rtorrent/rtorrent-0.2.7-r1.ebuild40
4 files changed, 51 insertions, 12 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index 3d3398535b5a..ee2059c0ba1d 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.8 2005/07/07 00:59:17 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.9 2005/07/16 23:33:52 flameeyes Exp $
+
+*rtorrent-0.2.7-r1 (16 Jul 2005)
+
+ 16 Jul 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +rtorrent-0.2.7-r1.ebuild:
+ Filter -fomit-frame-pointer on x86 as it clash with execeptions handling.
*rtorrent-0.2.7 (07 Jul 2005)
diff --git a/net-p2p/rtorrent/Manifest b/net-p2p/rtorrent/Manifest
index e78304891f9c..b570514f9966 100644
--- a/net-p2p/rtorrent/Manifest
+++ b/net-p2p/rtorrent/Manifest
@@ -1,21 +1,13 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 53d4a6ec36cc18f9473c5d8a215554ed ChangeLog 1711
+MD5 8abcc623d43ef20fd3bd868dc470f015 ChangeLog 1904
MD5 dc4336d6e768b550ef6da8f6c965d234 metadata.xml 374
MD5 c43b98111be37185ebd50e404a825ed2 rtorrent-0.2.5.ebuild 1013
MD5 a113e6025d34c13d500b44e4f0e06889 rtorrent-0.2.4.ebuild 1095
MD5 6783d9b425e5554cecb8ac747add14d3 rtorrent-0.2.6.ebuild 1013
MD5 e9fc4f6b4cf85e33b617ad50bf488949 rtorrent-0.2.7.ebuild 1013
+MD5 66a7de61931ded0d9e04607128587660 rtorrent-0.2.7-r1.ebuild 1108
MD5 070b0554790fa378ce49cbf22f43e7fb files/rtorrent-0.2.3-fix.patch 731
MD5 4f2a4166407519efdcaf059209a593bd files/digest-rtorrent-0.2.4 66
MD5 94d3b21f15578f05ae6d68d2acdda38e files/digest-rtorrent-0.2.5 66
MD5 fafeedade74a647d1262acf6811e4db0 files/digest-rtorrent-0.2.6 66
MD5 2e39b042dbe93da4428d71bcf4d642ce files/digest-rtorrent-0.2.7 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCzH57j5H05b2HAEkRAu3OAKCBEnPE9AdO0sftixgwYJ/UAkiY9gCgosrw
-F1CfOchd0kcShuDo2szkv3A=
-=wVXk
------END PGP SIGNATURE-----
+MD5 2e39b042dbe93da4428d71bcf4d642ce files/digest-rtorrent-0.2.7-r1 66
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.2.7-r1 b/net-p2p/rtorrent/files/digest-rtorrent-0.2.7-r1
new file mode 100644
index 000000000000..102cae0c512d
--- /dev/null
+++ b/net-p2p/rtorrent/files/digest-rtorrent-0.2.7-r1
@@ -0,0 +1 @@
+MD5 e315ede1ccba95b94b9f5652c423f464 rtorrent-0.2.7.tar.gz 191881
diff --git a/net-p2p/rtorrent/rtorrent-0.2.7-r1.ebuild b/net-p2p/rtorrent/rtorrent-0.2.7-r1.ebuild
new file mode 100644
index 000000000000..76ec6fc93189
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.2.7-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.2.7-r1.ebuild,v 1.1 2005/07/16 23:33:52 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="~net-libs/libtorrent-0.6.7
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}