summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-03-16 19:22:07 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-03-16 19:22:07 +0000
commit1a38f5124325b490f8e9eddc1a1ea58ab819a8a1 (patch)
tree593e5198a4b14e884a975bb84748b13029222291 /net-p2p
parentswitch to using rpm.eclass, which fixes bug #32872 by JF Burdet <jean-francoi... (diff)
downloadhistorical-1a38f5124325b490f8e9eddc1a1ea58ab819a8a1.tar.gz
historical-1a38f5124325b490f8e9eddc1a1ea58ab819a8a1.tar.bz2
historical-1a38f5124325b490f8e9eddc1a1ea58ab819a8a1.zip
Version bump.
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/azureus-bin/ChangeLog8
-rw-r--r--net-p2p/azureus-bin/Manifest4
-rw-r--r--net-p2p/azureus-bin/azureus-bin-2.0.8.2.ebuild120
-rw-r--r--net-p2p/azureus-bin/files/digest-azureus-bin-2.0.8.23
4 files changed, 133 insertions, 2 deletions
diff --git a/net-p2p/azureus-bin/ChangeLog b/net-p2p/azureus-bin/ChangeLog
index 7c897672823e..732eca33c5b9 100644
--- a/net-p2p/azureus-bin/ChangeLog
+++ b/net-p2p/azureus-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/azureus-bin
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/ChangeLog,v 1.6 2004/03/16 19:14:02 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/ChangeLog,v 1.7 2004/03/16 19:22:07 eradicator Exp $
+
+*azureus-bin-2.0.8.2 (16 Mar 2004)
+
+ 16 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ azureus-bin-2.0.8.2.ebuild:
+ Version bump.
16 Mar 2004; Jeremy Huddleston <eradicator@gentoo.org>
azureus-bin-2.0.8.0a.ebuild:
diff --git a/net-p2p/azureus-bin/Manifest b/net-p2p/azureus-bin/Manifest
index 2557abbf3169..cce4e5af3d89 100644
--- a/net-p2p/azureus-bin/Manifest
+++ b/net-p2p/azureus-bin/Manifest
@@ -1,8 +1,10 @@
MD5 3d5dc27f2b59c9471eaf7d6a8a83ac7a azureus-bin-2.0.7.1_pre20040224.ebuild 3519
MD5 b4c0a83cdb02ca2b9e6196fce003adb2 azureus-bin-2.0.8.0a.ebuild 3426
-MD5 3fb044c1ec08f11f60b9ed22e51f8f9e ChangeLog 1122
+MD5 0b01bdf06ff5a59d1bfd6e4a11a9176b ChangeLog 1262
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
+MD5 ec45ac12f5951850a59aa99c059cc7c0 azureus-bin-2.0.8.2.ebuild 3435
MD5 492b5db31f8be8a352cc1eb3adb23ba1 files/digest-azureus-bin-2.0.7.1_pre20040224 299
+MD5 c0959f46e1818bc659dd103124e1ecab files/digest-azureus-bin-2.0.8.2 222
MD5 0b7b4678fdb7cc0211a089ce94dfc87f files/azureus-bin-2.0.8.0a-gentoo.sh 1768
MD5 05e40b9feac40ba41ddb08f80eb60654 files/digest-azureus-bin-2.0.8.0a 224
MD5 a5ae00888f1b5e4910a2005c77002994 files/azureus-bin-2.0.7.1_pre20040224-gentoo.sh 2505
diff --git a/net-p2p/azureus-bin/azureus-bin-2.0.8.2.ebuild b/net-p2p/azureus-bin/azureus-bin-2.0.8.2.ebuild
new file mode 100644
index 000000000000..a9b84164adc5
--- /dev/null
+++ b/net-p2p/azureus-bin/azureus-bin-2.0.8.2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus-bin/azureus-bin-2.0.8.2.ebuild,v 1.1 2004/03/16 19:22:07 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="Azureus - Java BitTorent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+
+MY_PN=${PN/-bin/}
+MY_DT=20040224
+
+S=${WORKDIR}/${MY_PN}
+SRC_URI="mirror://sourceforge/${MY_PN}/Azureus_${PV}_linux.GTK.tar.bz2
+ mirror://sourceforge/${MY_PN}/Azureus_${PV}_linux.Motif.tar.bz2
+ mirror://gentoo/seda-${MY_DT}.zip"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+
+# Still in progress... trying to get most external classes in through DEPENDs rather than
+KEYWORDS="~x86"
+IUSE="gtk kde"
+
+DEPEND="virtual/glibc"
+
+RDEPEND="${DEPEND}
+ dev-java/commons-cli
+ dev-java/log4j
+ kde? ( dev-java/systray4j )
+ dev-java/junit
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? ( =x11-libs/openmotif-2.1* )
+ >=virtual/jre-1.4"
+
+# Where to install the package
+PROGRAM_DIR="/usr/lib/${MY_PN}"
+
+src_unpack() {
+ if ! use kde; then
+ einfo "The kde use flag is off, so the systray support will be disabled."
+ einfo "kde is required to build dev-java/systray4j."
+ fi
+
+ if use gtk; then
+ unpack Azureus_${PV}_linux.GTK.tar.bz2
+ echo
+ einfo "Using the GTK Azureus package, to use the Motif package"
+ einfo " set USE=\"-gtk\" in /etc/make.conf."
+ echo
+ else
+ unpack Azureus_${PV}_linux.Motif.tar.bz2
+ echo
+ einfo "Using the Motif Azureus package, to use the GTK package"
+ einfo " set USE=\"gtk\" in /etc/make.conf."
+ echo
+
+ # These are provided by =x11-libs/openmotif-2.1.*
+ rm ${S}/libXm.so ${S}/libXm.so.2 ${S}/libXm.so.2.1
+ fi
+
+ # This is pulled in through dev-java/systray4j
+ rm ${S}/libsystray4j.so ${S}/systray4j.jar
+
+ cp ${FILESDIR}/${PN}-2.0.8.0a-gentoo.sh ${S}/azureus
+
+ # Set runtime settings in the startup script
+ sed -i "s:##PROGRAM_DIR##:${PROGRAM_DIR}:" ${MY_PN}/azureus
+
+ # Unpack seda
+ cd ${S}
+ unpack seda-${MY_DT}.zip
+ tar xjf seda-jnilibs-linux.tar.bz2
+ rm seda*bz2
+}
+
+src_compile() {
+ einfo "Binary only installation. No compilation required."
+}
+
+src_install() {
+ cd ${S}
+
+ insinto ${PROGRAM_DIR}
+ exeinto ${PROGRAM_DIR}
+
+ doins *.jar id.azureus.dir.file
+ doexe *.so
+
+ dobin azureus
+
+ dodoc README.linux seda-README.txt
+ dohtml swt-about.html
+}
+
+pkg_postinst() {
+ echo
+ einfo "Due to the nature of the portage system, we recommend"
+ einfo "that users check portage for new versions of Azureus"
+ einfo "instead of attempting to use the auto-update feature."
+ einfo "You can disable the upgrade warning in"
+ einfo "View->Configuration->Interface->Start"
+ echo
+ einfo "After running azureus for the first time, configuration"
+ einfo "options will be placed in ~/.azureus/gentoo.config"
+ einfo "It is recommended that you modify this file rather than"
+ einfo "the azureus startup script directly."
+ echo
+ einfo "Currently, only the swt interface is available (ie, the setting"
+ einfo "in ~/.azureus/gentoo.config is ignored). If you want to use"
+ einfo "any of the other interfaces, you will need to get a CVS version"
+ einfo "of the Azureus2.jar from http://azureus.sourceforge.net/index_CVS.php"
+ einfo "and replace ${PROGRAM_DIR}/Azureus2.jar with it. If you do this,"
+ einfo "the setting in ~/.azureus/gentoo.config will be properly used, but"
+ einfo "you should report all bugs pertaining to the CVS release to the"
+ einfo "azureus developers and not Gentoo."
+ echo
+}
diff --git a/net-p2p/azureus-bin/files/digest-azureus-bin-2.0.8.2 b/net-p2p/azureus-bin/files/digest-azureus-bin-2.0.8.2
new file mode 100644
index 000000000000..3276a9ca282b
--- /dev/null
+++ b/net-p2p/azureus-bin/files/digest-azureus-bin-2.0.8.2
@@ -0,0 +1,3 @@
+MD5 a2247feefc701d88b6660b508fb5fffd Azureus_2.0.8.2_linux.GTK.tar.bz2 3053259
+MD5 dbd6a899345dbd6cbb8075e6b0fa8f39 Azureus_2.0.8.2_linux.Motif.tar.bz2 3961225
+MD5 5f79ac344851884646166d733b5cde8d seda-20040224.zip 755126