summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2003-10-01 13:07:04 +0000
committerHeinrich Wendel <lanius@gentoo.org>2003-10-01 13:07:04 +0000
commit8daa617886781cca5f2d14818510d355cc42243b (patch)
treed8137047bfb3273496008776e2fc3dc6759ca2b1 /net-p2p/zuul
parentchangelog:p (diff)
downloadhistorical-8daa617886781cca5f2d14818510d355cc42243b.tar.gz
historical-8daa617886781cca5f2d14818510d355cc42243b.tar.bz2
historical-8daa617886781cca5f2d14818510d355cc42243b.zip
changelog:p
Diffstat (limited to 'net-p2p/zuul')
-rw-r--r--net-p2p/zuul/Manifest4
-rw-r--r--net-p2p/zuul/files/digest-zuul-1.1.21
-rw-r--r--net-p2p/zuul/zuul-1.1.2.ebuild51
3 files changed, 54 insertions, 2 deletions
diff --git a/net-p2p/zuul/Manifest b/net-p2p/zuul/Manifest
index 9b7720c1c7d0..a182cee3a566 100644
--- a/net-p2p/zuul/Manifest
+++ b/net-p2p/zuul/Manifest
@@ -1,5 +1,5 @@
MD5 07942936b14ce221c70c5c407366ffdf zuul-1.0.0.ebuild 1431
-MD5 7c6c9bfcedf96ae7b414ad9e223bec5a zuul-1.1.2.ebuild 1428
-MD5 0c45fd223edb3d1b63045143dad0ed13 ChangeLog 248
+MD5 b43b1f23e5a7c7f9087dd625a7154d03 zuul-1.1.2.ebuild 1436
+MD5 f37d6e8f6e98fb8a6ec7e94ad8ae5d3d ChangeLog 384
MD5 79aebd3adca669a7baa793ff03748417 files/digest-zuul-1.0.0 61
MD5 cd4f98be101a25b70d78c04ce72d6981 files/digest-zuul-1.1.2 61
diff --git a/net-p2p/zuul/files/digest-zuul-1.1.2 b/net-p2p/zuul/files/digest-zuul-1.1.2
new file mode 100644
index 000000000000..5f4a30545411
--- /dev/null
+++ b/net-p2p/zuul/files/digest-zuul-1.1.2
@@ -0,0 +1 @@
+MD5 29ad85aa76f0f67003a1f55df8ea193e zuul-1.1.2.tar.gz 41913
diff --git a/net-p2p/zuul/zuul-1.1.2.ebuild b/net-p2p/zuul/zuul-1.1.2.ebuild
new file mode 100644
index 000000000000..bb4f6acccbb2
--- /dev/null
+++ b/net-p2p/zuul/zuul-1.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/zuul/zuul-1.1.2.ebuild,v 1.1 2003/10/01 13:06:58 lanius Exp $
+
+HOSTNAME=`hostname`
+DESCRIPTION="Zuul is yet another PHP front-end for mldonkey. It will allow full access to all the features of mldonkey including starting/viewing downloads, viewing uploads, viewing servers, and setting all the options."
+HOMEPAGE="http://zuul.sourceforge.net"
+
+# Handle RC versions
+MY_PV="${PV/_/-}"
+SRC_URI="mirror://sourceforge/zuul/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+RDEPEND="virtual/php
+ >=net-p2p/mldonkey-2.5"
+DEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+HTTPD_ROOT="`grep -s '^DocumentRoot' /etc/apache/conf/apache.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="`grep -s '^DocumentRoot' /etc/apache2/conf/apache2.conf | cut -d\ -f2`"
+[ -z "${HTTPD_ROOT}" ] && HTTPD_ROOT="/home/httpd/htdocs"
+HTTPD_USER="apache"
+HTTPD_GROUP="apache"
+
+
+src_compile() {
+ echo "Nothing to compile"
+}
+
+src_install() {
+ cd ${S}
+ dodir ${HTTPD_ROOT}/zuul
+ cp -r * ${D}/${HTTPD_ROOT}/zuul
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Installation complete."
+ einfo
+ einfo "You need to configure zuul by editing"
+ einfo "${HTTPD_ROOT}/zuul/conf/config.php and"
+ einfo "${HTTPD_ROOT}/zuul/bin/startup.sh."
+ einfo
+ einfo "http://$HOSTNAME/zuul"
+ einfo
+}