summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-01-12 14:23:05 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-01-12 14:23:05 +0000
commit5cd1b2b390d0b064b734e8042738978221aa2303 (patch)
tree6262172b98d45028a0f5bdc920527be24f6d52ac /net-p2p/phex
parentunmask net-p2p/phex again (diff)
downloadhistorical-5cd1b2b390d0b064b734e8042738978221aa2303.tar.gz
historical-5cd1b2b390d0b064b734e8042738978221aa2303.tar.bz2
historical-5cd1b2b390d0b064b734e8042738978221aa2303.zip
Remove broken ebuilds, version bump, fix bug 119416
Package-Manager: portage-2.1.1-r2
Diffstat (limited to 'net-p2p/phex')
-rw-r--r--net-p2p/phex/ChangeLog12
-rw-r--r--net-p2p/phex/files/digest-phex-3.0.0.993
-rw-r--r--net-p2p/phex/files/phex-3.0.0.99.sh7
-rw-r--r--net-p2p/phex/phex-3.0.0.99.ebuild31
4 files changed, 51 insertions, 2 deletions
diff --git a/net-p2p/phex/ChangeLog b/net-p2p/phex/ChangeLog
index a738fb0f0377..ab43bf89bf43 100644
--- a/net-p2p/phex/ChangeLog
+++ b/net-p2p/phex/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/phex
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/ChangeLog,v 1.9 2006/12/09 09:17:28 mr_bones_ Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/ChangeLog,v 1.10 2007/01/12 14:23:05 armin76 Exp $
+
+*phex-3.0.0.99 (12 Jan 2007)
+
+ 12 Jan 2007; Raúl Porcel <armin76@gentoo.org> -files/phex-2.6.4.89.sh,
+ -files/phex-2.8.2.92.sh, +files/phex-3.0.0.99.sh, -files/phex.sh,
+ -phex-2.0.0.76.ebuild, -phex-2.6.0.87.ebuild, -phex-2.8.2.92.ebuild,
+ +phex-3.0.0.99.ebuild:
+ Remove broken ebuilds, version bump, fix bug 119416
09 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org>
-phex-2.1.2.79.ebuild, -phex-2.1.4.80.ebuild, -phex-2.6.4.89.ebuild:
diff --git a/net-p2p/phex/files/digest-phex-3.0.0.99 b/net-p2p/phex/files/digest-phex-3.0.0.99
new file mode 100644
index 000000000000..bdcfbd5cb159
--- /dev/null
+++ b/net-p2p/phex/files/digest-phex-3.0.0.99
@@ -0,0 +1,3 @@
+MD5 238d5c59a1aa3c0d85db569794378051 phex_3.0.0.99.zip 3566529
+RMD160 85f1139ea419887b9c1ff77d5917c31f4bbe6ace phex_3.0.0.99.zip 3566529
+SHA256 f2b945f275c4ee1b31a7834f36e71a24b6592e1cfc1314a4593411279ed429bf phex_3.0.0.99.zip 3566529
diff --git a/net-p2p/phex/files/phex-3.0.0.99.sh b/net-p2p/phex/files/phex-3.0.0.99.sh
new file mode 100644
index 000000000000..86ef34c5e00b
--- /dev/null
+++ b/net-p2p/phex/files/phex-3.0.0.99.sh
@@ -0,0 +1,7 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/files/phex-3.0.0.99.sh,v 1.1 2007/01/12 14:23:05 armin76 Exp $
+
+#!/bin/sh
+
+java -classpath $(java-config -p commons-logging,commons-httpclient-3,phex,jgoodies-looks-2.0,jgoodies-forms) phex.Main
diff --git a/net-p2p/phex/phex-3.0.0.99.ebuild b/net-p2p/phex/phex-3.0.0.99.ebuild
new file mode 100644
index 000000000000..95db066fbddb
--- /dev/null
+++ b/net-p2p/phex/phex-3.0.0.99.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/phex/phex-3.0.0.99.ebuild,v 1.1 2007/01/12 14:23:05 armin76 Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="java gnutella file-sharing application"
+HOMEPAGE="http://phex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/phex/${P/-/_}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND=">=virtual/jdk-1.5
+ =dev-java/commons-httpclient-3.0*
+ >=dev-java/commons-logging-1.1
+ >=dev-java/jgoodies-forms-1.0.5
+ >=dev-java/jgoodies-looks-1.3.2"
+
+S=${WORKDIR}/${P/-/_}
+
+src_install() {
+ cd ${S}
+ java-pkg_dojar lib/phex.jar
+
+ exeinto /usr/bin
+ newexe ${FILESDIR}/${P}.sh ${PN}
+
+ dohtml docs/readme/*
+}