summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-06-22 11:33:46 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-06-22 11:33:46 +0000
commit931ff39c8211283010f43580e182fc26df9f7dc8 (patch)
tree301936984b1193d91141b93cfd901f79033bca15 /net-nds
parenttthat pesky cleanilness will break 1.0 profile. reintroducing openldap 2.0.25. (diff)
downloadhistorical-931ff39c8211283010f43580e182fc26df9f7dc8.tar.gz
historical-931ff39c8211283010f43580e182fc26df9f7dc8.tar.bz2
historical-931ff39c8211283010f43580e182fc26df9f7dc8.zip
tthat pesky cleanilness will break 1.0 profile. reintroducing openldap 2.0.25.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/Manifest6
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.25-r11
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.25-r21
-rw-r--r--net-nds/openldap/openldap-2.0.25-r1.ebuild91
-rw-r--r--net-nds/openldap/openldap-2.0.25-r2.ebuild101
5 files changed, 197 insertions, 3 deletions
diff --git a/net-nds/openldap/Manifest b/net-nds/openldap/Manifest
index 5f293de713d3..1652e78f9b83 100644
--- a/net-nds/openldap/Manifest
+++ b/net-nds/openldap/Manifest
@@ -1,6 +1,6 @@
-MD5 fc4d349ab15fbcfab9f92dcb620a0f82 ChangeLog 8599
-MD5 7e223bf5e395fd7b935ed34f7833724a openldap-2.0.25-r1.ebuild 2420
-MD5 c2c34f94c7826e325e1d114aaf17cd1e openldap-2.0.25-r2.ebuild 2583
+MD5 5f4ace03974e3595d111eba89596eced ChangeLog 8803
+MD5 6b611092dd59bc62ddba9578e60e23b2 openldap-2.0.25-r1.ebuild 2530
+MD5 63a967c1c320ba41db8fcacae617976a openldap-2.0.25-r2.ebuild 2609
MD5 405655723adfa7c4470f1984f5463dd1 openldap-2.0.27.ebuild 2325
MD5 44504b7fefa587532782f057a83ba290 openldap-2.0.27-r4.ebuild 4795
MD5 5f9e081b9be4ec33dea8b4d169d2ed2b openldap-2.1.21.ebuild 5295
diff --git a/net-nds/openldap/files/digest-openldap-2.0.25-r1 b/net-nds/openldap/files/digest-openldap-2.0.25-r1
new file mode 100644
index 000000000000..8f386fb0e4ef
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.25-r1
@@ -0,0 +1 @@
+MD5 57ed9ea3d872595076d6eab7b93337bd openldap-2.0.25.tgz 1304098
diff --git a/net-nds/openldap/files/digest-openldap-2.0.25-r2 b/net-nds/openldap/files/digest-openldap-2.0.25-r2
new file mode 100644
index 000000000000..8f386fb0e4ef
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.25-r2
@@ -0,0 +1 @@
+MD5 57ed9ea3d872595076d6eab7b93337bd openldap-2.0.25.tgz 1304098
diff --git a/net-nds/openldap/openldap-2.0.25-r1.ebuild b/net-nds/openldap/openldap-2.0.25-r1.ebuild
new file mode 100644
index 000000000000..aa31a30ebd0c
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.25-r1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.25-r1.ebuild,v 1.9 2003/06/22 11:33:37 liquidx Exp $
+
+### WARNING !! Do not remove openldap 2.0.25 or else it will break for
+#### default-1.0 profile!
+
+IUSE="ssl ipv6 sasl readline tcpd gdbm"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc sparc "
+LICENSE="OPENLDAP"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ sasl? ( >=dev-libs/cyrus-sasl-1.5.27 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ use tcpd && myconf="${myconf} --enable-wrappers" \
+ || myconf="${myconf} --disable-wrappers"
+ use ssl && myconf="${myconf} --with-tls" \
+ || myconf="${myconf} --without-tls"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm" \
+ || myconf="${myconf} --disable-ldbm"
+ use ipv6 && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+ use sasl && myconf="${myconf} --enable-cyrus-sasl" \
+ || myconf="${myconf} --disable-cyrus-sasl"
+
+
+ ./configure --host=${CHOST} \
+ --enable-passwd \
+ --enable-shell \
+ --enable-shared \
+ --enable-static \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state/openldap \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/openldap \
+ ${myconf} || die "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state/openldap \
+ mandir=${D}/usr/share/man \
+ libexecdir=${D}/usr/lib/openldap \
+ install || die "install problem"
+
+ #fix ${D} in manpages
+ cd ${S}/doc/man
+ make DESTDIR=${D} clean all install || die "install doc problem"
+ cd ${S}
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ dosed $i
+ done
+}
diff --git a/net-nds/openldap/openldap-2.0.25-r2.ebuild b/net-nds/openldap/openldap-2.0.25-r2.ebuild
new file mode 100644
index 000000000000..de2dd4e7ee53
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.25-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.25-r2.ebuild,v 1.11 2003/06/22 11:33:37 liquidx Exp $
+
+### WARNING !! Do not remove openldap 2.0.25 or else it will break for
+#### default-1.0 profile!
+
+IUSE="ssl tcpd sasl readline ipv6 berkdb gdbm ldap"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="OPENLDAP"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ sasl? ( >=dev-libs/cyrus-sasl-1.5.27 )
+ berkdb? ( >=sys-libs/db-3.2.9 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ use tcpd \
+ && myconf="${myconf} --enable-wrappers" \
+ || myconf="${myconf} --disable-wrappers"
+
+ use ssl \
+ && myconf="${myconf} --with-tls" \
+ || myconf="${myconf} --without-tls"
+
+ use readline \
+ && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+
+ if use berkdb; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=berkeley"
+ elif use gdbm; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ elif use ldap-none; then
+ myconf="${myconf} --disable-ldbm"
+ else
+ myconf="${myconf} --enable-ldbm --with-ldbmi-api=auto"
+ fi
+ use ipv6 && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+ use sasl && myconf="${myconf} --enable-cyrus-sasl" \
+ || myconf="${myconf} --disable-cyrus-sasl"
+
+
+ econf \
+ --enable-passwd \
+ --enable-shell \
+ --enable-shared \
+ --enable-static \
+ --localstatedir=/var/state/openldap \
+ --libexecdir=/usr/lib/openldap \
+ ${myconf} || die "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
+}
+
+src_install() {
+ einstall \
+ sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state/openldap \
+ libexecdir=${D}/usr/lib/openldap \
+ || die "install problem"
+
+ #fix ${D} in manpages
+ cd ${S}/doc/man
+ make DESTDIR=${D} clean all install || die "install doc problem"
+ cd ${S}
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ dosed $i
+ done
+}