summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-05-28 00:09:27 +0000
committerAron Griffis <agriffis@gentoo.org>2002-05-28 00:09:27 +0000
commit33d08732c75958d70cd2fd2b2c3de2996ab11e22 (patch)
treea8c9a883da1daad5f92c1dad508b731e6952a89f /net-nds
parentgtk+-1.2.10-r8 masked (diff)
downloadhistorical-33d08732c75958d70cd2fd2b2c3de2996ab11e22.tar.gz
historical-33d08732c75958d70cd2fd2b2c3de2996ab11e22.tar.bz2
historical-33d08732c75958d70cd2fd2b2c3de2996ab11e22.zip
Updated ypbind to run after ypserv in the case that the localhost is
the NIS server.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.111
-rw-r--r--net-nds/ypbind/files/ypbind.confd5
-rw-r--r--net-nds/ypbind/files/ypbind.rc610
-rw-r--r--net-nds/ypbind/ypbind-1.11.ebuild30
4 files changed, 41 insertions, 5 deletions
diff --git a/net-nds/ypbind/files/digest-ypbind-1.11 b/net-nds/ypbind/files/digest-ypbind-1.11
new file mode 100644
index 000000000000..091937543226
--- /dev/null
+++ b/net-nds/ypbind/files/digest-ypbind-1.11
@@ -0,0 +1 @@
+MD5 c37228a2877a59578227ff9e1b1a060b ypbind-mt-1.11.tar.bz2 143359
diff --git a/net-nds/ypbind/files/ypbind.confd b/net-nds/ypbind/files/ypbind.confd
new file mode 100644
index 000000000000..e049624808dd
--- /dev/null
+++ b/net-nds/ypbind/files/ypbind.confd
@@ -0,0 +1,5 @@
+# Config file for /etc/init.d/ypbind
+
+# NIS domain (not necessary the same as DNS domain)
+
+#YP_DOMAIN=myYPdomain
diff --git a/net-nds/ypbind/files/ypbind.rc6 b/net-nds/ypbind/files/ypbind.rc6
index e17928f50131..9c3933f6d53b 100644
--- a/net-nds/ypbind/files/ypbind.rc6
+++ b/net-nds/ypbind/files/ypbind.rc6
@@ -1,17 +1,17 @@
#!/sbin/runscript
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/files/ypbind.rc6,v 1.2 2001/12/06 20:17:02 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/files/ypbind.rc6,v 1.3 2002/05/28 00:09:27 agriffis Exp $
depend() {
need net portmap
+ use ypserv
}
checkconfig() {
- if [ -z "$YP_DOMAIN" ] ; then
- eerror "You need to setup YP_DOMAIN /etc/rc.conf"
- return 1
- fi
+ [ -s "$YP_DOMAIN" ] && return 0
+ eerror "You need to setup YP_DOMAIN in /etc/conf.d/ypbind"
+ return 1
}
start() {
diff --git a/net-nds/ypbind/ypbind-1.11.ebuild b/net-nds/ypbind/ypbind-1.11.ebuild
new file mode 100644
index 000000000000..2c61ad001bca
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.11.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.11.ebuild,v 1.1 2002/05/28 00:09:27 agriffis Exp $
+
+MY_P=${PN}-mt-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+
+DEPEND="net-nds/yp-tools
+ net-nds/portmap"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc ; doins etc/yp.conf
+ insinto /etc/conf.d ; newins ${FILESDIR}/ypbind.confd ypbind
+ exeinto /etc/init.d ; newexe ${FILESDIR}/ypbind.rc6 ypbind
+}