summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-11-14 03:02:05 +0000
committerAlec Warner <antarus@gentoo.org>2006-11-14 03:02:05 +0000
commit2e29b1ea49a250d78eee15a53a94a41c1c968c67 (patch)
tree9a2b608467cf5fba3639e7c5e36e7939037781a4 /net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild
parentPush out accumulated fixes. (diff)
downloadhistorical-2e29b1ea49a250d78eee15a53a94a41c1c968c67.tar.gz
historical-2e29b1ea49a250d78eee15a53a94a41c1c968c67.tar.bz2
historical-2e29b1ea49a250d78eee15a53a94a41c1c968c67.zip
Add patch and bump ebuild for it such that users get the patch for bug # 130056
Package-Manager: portage-2.1.2_pre3-r9
Diffstat (limited to 'net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild')
-rw-r--r--net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild b/net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..53bc9c978a18
--- /dev/null
+++ b/net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nis-utils/nis-utils-1.4.1-r2.ebuild,v 1.1 2006/11/14 03:02:05 antarus Exp $
+
+inherit eutils
+
+DESCRIPTION="NIS+ utilities"
+HOMEPAGE="http://www.linux-nis.org/"
+SRC_URI="mirror://kernel/linux/utils/net/NIS+/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc sparc x86"
+IUSE="nls"
+
+DEPEND="dev-libs/gmp"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${PN}-gmp-fixes.patch"
+}
+
+src_compile() {
+ econf $(use_enable nls) || die "Configure failed"
+ emake || die "Make Failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install Failed"
+ mv "${D}"/usr/etc "${D}"/
+ dodoc AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
+ newinitd "${FILESDIR}"/keyserv.rc keyserv
+}