summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2006-01-26 13:18:20 +0000
committerCaleb Tennis <caleb@gentoo.org>2006-01-26 13:18:20 +0000
commitf9ea504e7a6dd51db0a3ea653bda0fd3ad670714 (patch)
tree5f2c58fb296c103dc449dc688e0d31202c3545bc /net-misc
parentNew version. (diff)
downloadhistorical-f9ea504e7a6dd51db0a3ea653bda0fd3ad670714.tar.gz
historical-f9ea504e7a6dd51db0a3ea653bda0fd3ad670714.tar.bz2
historical-f9ea504e7a6dd51db0a3ea653bda0fd3ad670714.zip
Add a patch to make the ebuild work with qt3/qt4
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/kiax/ChangeLog8
-rw-r--r--net-misc/kiax/Manifest7
-rw-r--r--net-misc/kiax/files/configure.patch8
-rw-r--r--net-misc/kiax/kiax-0.8.4.ebuild5
4 files changed, 21 insertions, 7 deletions
diff --git a/net-misc/kiax/ChangeLog b/net-misc/kiax/ChangeLog
index b6eb81f374fc..fdae9cec81a9 100644
--- a/net-misc/kiax/ChangeLog
+++ b/net-misc/kiax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/kiax
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kiax/ChangeLog,v 1.4 2005/08/15 20:37:15 stkn Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kiax/ChangeLog,v 1.5 2006/01/26 13:18:20 caleb Exp $
+
+ 26 Jan 2006; Caleb Tennis <caleb@gentoo.org> +files/configure.patch,
+ kiax-0.8.4.ebuild:
+ Add a patch to make the ebuild work with qt3/qt4
15 Aug 2005; <stkn@gentoo.org> kiax-0.8.4.ebuild:
Kiax doesn't like parallel builds, adding -j1
diff --git a/net-misc/kiax/Manifest b/net-misc/kiax/Manifest
index 645659fcc576..d3b79a15e28b 100644
--- a/net-misc/kiax/Manifest
+++ b/net-misc/kiax/Manifest
@@ -1,5 +1,6 @@
-MD5 b5828652b74b7897fc54217c00b2135b kiax-0.8.4.ebuild 933
-MD5 de41c503f05f5f99a8635b0e333729a5 metadata.xml 217
-MD5 4f9ba88be0ec7792368100790c526104 ChangeLog 665
+MD5 d58412c448afdcc1310ec513c2e87297 ChangeLog 810
+MD5 33b9a00e2b3455e3a7580c4d6ccc6aa0 files/configure.patch 261
MD5 245d14d9a58bf769539219bc03fb653f files/digest-kiax-0.8.4 63
MD5 d496dea872c013c74b229c4c9192df60 files/kiax-0.8.4-iaxwrapper.patch 702
+MD5 f090f789742f05762cfaa8a4fbc6879f kiax-0.8.4.ebuild 970
+MD5 de41c503f05f5f99a8635b0e333729a5 metadata.xml 217
diff --git a/net-misc/kiax/files/configure.patch b/net-misc/kiax/files/configure.patch
new file mode 100644
index 000000000000..25827a813872
--- /dev/null
+++ b/net-misc/kiax/files/configure.patch
@@ -0,0 +1,8 @@
+--- configure.orig 2005-04-05 16:53:41.000000000 -0500
++++ configure 2006-01-26 08:15:32.000000000 -0500
+@@ -20,4 +20,4 @@
+ ./repath.pl --prefix=$prefix
+ esac
+
+-qmake -o Makefile qkiax.pro
++${QTDIR}/bin/qmake QMAKE=${QTDIR}/bin/qmake -o Makefile qkiax.pro
diff --git a/net-misc/kiax/kiax-0.8.4.ebuild b/net-misc/kiax/kiax-0.8.4.ebuild
index 1e41641c4eb2..2ce4c757e31d 100644
--- a/net-misc/kiax/kiax-0.8.4.ebuild
+++ b/net-misc/kiax/kiax-0.8.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/kiax/kiax-0.8.4.ebuild,v 1.4 2005/08/15 20:37:15 stkn Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/kiax/kiax-0.8.4.ebuild,v 1.5 2006/01/26 13:18:20 caleb Exp $
inherit eutils kde-functions
@@ -21,6 +21,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-0.8.4-iaxwrapper.patch
+ epatch ${FILESDIR}/configure.patch
# add prefix for make install
sed -i -e "s:\(\$(DEST_PATH)\):\${INSTALL_ROOT}\1:" \