summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2004-02-19 00:17:46 +0000
committerStefan Knoblich <stkn@gentoo.org>2004-02-19 00:17:46 +0000
commitc532cf92eb3d1291e9d037f3ca8a01790046f528 (patch)
tree675de3870ccaf08b2fd86f72ca530c2a23ded05d /net-misc
parentAdded the patch for the mremap/munmap vulnerability. Bug #42024. (diff)
downloadhistorical-c532cf92eb3d1291e9d037f3ca8a01790046f528.tar.gz
historical-c532cf92eb3d1291e9d037f3ca8a01790046f528.tar.bz2
historical-c532cf92eb3d1291e9d037f3ca8a01790046f528.zip
initial import
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk-sccp/ChangeLog10
-rw-r--r--net-misc/asterisk-sccp/Manifest5
-rw-r--r--net-misc/asterisk-sccp/asterisk-sccp-0.2.ebuild39
-rw-r--r--net-misc/asterisk-sccp/files/asterisk-sccp-0.2-makefile.diff22
-rw-r--r--net-misc/asterisk-sccp/files/digest-asterisk-sccp-0.21
-rw-r--r--net-misc/asterisk-sccp/metadata.xml8
6 files changed, 85 insertions, 0 deletions
diff --git a/net-misc/asterisk-sccp/ChangeLog b/net-misc/asterisk-sccp/ChangeLog
new file mode 100644
index 000000000000..bb370207b84f
--- /dev/null
+++ b/net-misc/asterisk-sccp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/asterisk-sccp
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-sccp/ChangeLog,v 1.1 2004/02/19 00:17:46 stkn Exp $
+
+*asterisk-sccp-0.2 (19 Feb 2004)
+
+ 19 Feb 2004; Stefan Knoblich <stkn@gentoo.org> asterisk-sccp-0.2.ebuild,
+ metadata.xml, files/asterisk-sccp-0.2-makefile.diff:
+ Initial import
+
diff --git a/net-misc/asterisk-sccp/Manifest b/net-misc/asterisk-sccp/Manifest
new file mode 100644
index 000000000000..54ea7f11f078
--- /dev/null
+++ b/net-misc/asterisk-sccp/Manifest
@@ -0,0 +1,5 @@
+MD5 062c76e509713f06584e5b066045366f asterisk-sccp-0.2.ebuild 864
+MD5 de41c503f05f5f99a8635b0e333729a5 metadata.xml 217
+MD5 5bef825682f01a9bab5cf5349ef71943 ChangeLog 406
+MD5 743fb0b56579c0c7b6912c9f3c21924a files/digest-asterisk-sccp-0.2 64
+MD5 02b226ed4084249e98f947a4832b9aba files/asterisk-sccp-0.2-makefile.diff 867
diff --git a/net-misc/asterisk-sccp/asterisk-sccp-0.2.ebuild b/net-misc/asterisk-sccp/asterisk-sccp-0.2.ebuild
new file mode 100644
index 000000000000..0f3856e44d03
--- /dev/null
+++ b/net-misc/asterisk-sccp/asterisk-sccp-0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-sccp/asterisk-sccp-0.2.ebuild,v 1.1 2004/02/19 00:17:46 stkn Exp $
+
+IUSE="debug"
+
+DESCRIPTION="SCCP plugin for the Asterisk soft PBX"
+HOMEPAGE="http://www.zozo.org.uk/pages.shtml?page=sccp"
+SRC_URI="http://www.zozo.org.uk/downloads/chan_sccp-${PV}.tar.gz"
+S="${WORKDIR}/chan_sccp-${PV}"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefile.diff
+
+ if [ -z "`use debug`" ]; then
+ sed -i -e "s:^\(DEBUG=-g\):#\1:" Makefile
+ fi
+
+ # set cflags
+ sed -i -e "s:^CFLAG=\(.*\)\$(DEBUG):CFLAG=${CFLAGS} \$(DEBUG):" \
+ Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+
+ dodoc README conf/*.xml
+}
diff --git a/net-misc/asterisk-sccp/files/asterisk-sccp-0.2-makefile.diff b/net-misc/asterisk-sccp/files/asterisk-sccp-0.2-makefile.diff
new file mode 100644
index 000000000000..10732317e2b4
--- /dev/null
+++ b/net-misc/asterisk-sccp/files/asterisk-sccp-0.2-makefile.diff
@@ -0,0 +1,22 @@
+--- Makefile.orig 2004-02-19 01:04:10.727418600 +0100
++++ Makefile 2004-02-19 01:05:58.225076472 +0100
+@@ -1,4 +1,4 @@
+-ASTERISK_SOURCE=/usr/src/asterisk
++ASTERISK_SOURCE=/usr
+ AST_MODULES_DIR=/usr/lib/asterisk/modules
+
+ DEBUG=-g
+@@ -31,9 +31,10 @@
+ @$(CC) -I/usr/include/ $(CFLAGS) -I$(ASTERISK_SOURCE) $(DEFINE) -c $*.c -o .tmp/$*.o
+
+ install: chan_sccp.so
+- rm -f $(AST_MODULES_DIR)/chan_sccp.so
+- cp chan_sccp.so $(AST_MODULES_DIR)
+- if ! [ -f /etc/asterisk/sccp.conf ]; then cp conf/sccp.conf /etc/asterisk/; fi
++ if ! [ -d $(DESTDIR)$(AST_MODULES_DIR) ]; then mkdir -p $(DESTDIR)$(AST_MODULES_DIR); fi
++ if ! [ -d $(DESTDIR)/etc/asterisk ]; then mkdir -p $(DESTDIR)/etc/asterisk; fi
++ cp chan_sccp.so $(DESTDIR)$(AST_MODULES_DIR)
++ if ! [ -f /etc/asterisk/sccp.conf ]; then cp conf/sccp.conf $(DESTDIR)/etc/asterisk/; fi
+
+ clean:
+ rm -rf chan_sccp.so .tmp
diff --git a/net-misc/asterisk-sccp/files/digest-asterisk-sccp-0.2 b/net-misc/asterisk-sccp/files/digest-asterisk-sccp-0.2
new file mode 100644
index 000000000000..968fce1498ae
--- /dev/null
+++ b/net-misc/asterisk-sccp/files/digest-asterisk-sccp-0.2
@@ -0,0 +1 @@
+MD5 5d816be2ab8b6cc4b8f3437a4fbe00ee chan_sccp-0.2.tar.gz 35234
diff --git a/net-misc/asterisk-sccp/metadata.xml b/net-misc/asterisk-sccp/metadata.xml
new file mode 100644
index 000000000000..a3cddc42f9cc
--- /dev/null
+++ b/net-misc/asterisk-sccp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>voip</herd>
+<maintainer>
+ <email>stkn@gentoo.org</email>
+</maintainer>
+</pkgmetadata>