summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-08-27 03:11:06 +0000
committerDonny Davies <woodchip@gentoo.org>2002-08-27 03:11:06 +0000
commit904d8a6382931262e8d5496a846c77c53337e2e5 (patch)
treebe55f5d0309b6c246d933213e1286b5d0be3ab69 /net-misc
parentnut went 1.0 and baselayout is out (diff)
downloadhistorical-904d8a6382931262e8d5496a846c77c53337e2e5.tar.gz
historical-904d8a6382931262e8d5496a846c77c53337e2e5.tar.bz2
historical-904d8a6382931262e8d5496a846c77c53337e2e5.zip
fix #6814
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tightvnc/ChangeLog8
-rw-r--r--net-misc/tightvnc/files/digest-tightvnc-1.2.5-r11
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.5-r1.ebuild57
3 files changed, 65 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index 5e5ec441e6d4..8120045eac9c 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.7 2002/08/18 00:34:19 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.8 2002/08/27 03:11:06 woodchip Exp $
+
+*tightvnc-1.2.5-r1 (26 Aug 2002)
+
+ 26 Aug 2002; Donny Davies <woodchip@gentoo.org> tightvnc-1.2.5-r1.ebuild :
+
+ Squash #6814.
*tightvnc-1.2.5 (18 Aug 2002)
diff --git a/net-misc/tightvnc/files/digest-tightvnc-1.2.5-r1 b/net-misc/tightvnc/files/digest-tightvnc-1.2.5-r1
new file mode 100644
index 000000000000..f6df76668abe
--- /dev/null
+++ b/net-misc/tightvnc/files/digest-tightvnc-1.2.5-r1
@@ -0,0 +1 @@
+MD5 039b4bca1ba81f57f9f564a6d86aad0c tightvnc-1.2.5_unixsrc.tar.bz2 1710193
diff --git a/net-misc/tightvnc/tightvnc-1.2.5-r1.ebuild b/net-misc/tightvnc/tightvnc-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..b30cf56b947c
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.2.5-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $ Header: $
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com"
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.1.0
+ >=sys-devel/perl-5.6.1
+ ~media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.4"
+
+RDEPEND=$DEPEND
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+ patch <${FILESDIR}/tightvnc-gentoo.diff || die
+
+ # fix #6814
+ cp vncserver vncserver.orig
+ sed -e 's%^if (!xauthorityFile) {%if (!\$xauthorityFile) {%' \
+ vncserver.orig > vncserver
+}
+
+src_compile() {
+
+ cd ${S}
+ xmkmf || die
+ make World || die
+ cd Xvnc
+ ./configure || die
+ make || die
+
+}
+
+src_install() {
+
+ cd ${S}
+ mkdir -p ${D}/usr/man
+ mkdir -p ${D}/usr/man/man1
+ mkdir -p ${D}/usr/bin
+
+ # fix the web based interface, it needs the java class files
+ mkdir -p ${D}/usr/share/tightvnc
+ mkdir -p ${D}/usr/share/tightvnc/classes
+ insinto /usr/share/tightvnc/classes ; doins classes/*
+
+ # and then patch vncserver to point to /usr/share/tightvnc/classes
+ patch -p0 < ${FILESDIR}/tightvnc-gentoo.diff || die
+
+ ./vncinstall ${D}/usr/bin ${D}/usr/man || die
+}