summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-10-20 22:24:41 +0000
committerAron Griffis <agriffis@gentoo.org>2005-10-20 22:24:41 +0000
commit7faa5e625f3fbd90cdd7c3433139e2cbe1ce0d51 (patch)
treeef31970e7b3976b7885086ca6fd0287742003eb8 /net-misc
parentMake setxkbmap work. (diff)
downloadhistorical-7faa5e625f3fbd90cdd7c3433139e2cbe1ce0d51.tar.gz
historical-7faa5e625f3fbd90cdd7c3433139e2cbe1ce0d51.tar.bz2
historical-7faa5e625f3fbd90cdd7c3433139e2cbe1ce0d51.zip
Add lib -> $(get_libdir) symlink in /usr/NX; seems to be necessary for
nxclient to start Package-Manager: portage-2.0.53_rc5
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/nxcomp/ChangeLog6
-rw-r--r--net-misc/nxcomp/Manifest10
-rw-r--r--net-misc/nxcomp/nxcomp-1.5.0.ebuild6
3 files changed, 20 insertions, 2 deletions
diff --git a/net-misc/nxcomp/ChangeLog b/net-misc/nxcomp/ChangeLog
index 34666c6153cf..ed835f562423 100644
--- a/net-misc/nxcomp/ChangeLog
+++ b/net-misc/nxcomp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/nxcomp
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcomp/ChangeLog,v 1.18 2005/10/20 21:24:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcomp/ChangeLog,v 1.19 2005/10/20 22:24:41 agriffis Exp $
+
+ 20 Oct 2005; Aron Griffis <agriffis@gentoo.org> nxcomp-1.5.0.ebuild:
+ Add lib -> $(get_libdir) symlink in /usr/NX; seems to be necessary for
+ nxclient to start
*nxcomp-1.5.0 (20 Oct 2005)
diff --git a/net-misc/nxcomp/Manifest b/net-misc/nxcomp/Manifest
index 02705cec1dd3..6e40d6d2cf62 100644
--- a/net-misc/nxcomp/Manifest
+++ b/net-misc/nxcomp/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 726255af8c0c26825382b01d6c899f08 ChangeLog 2567
MD5 bbbdf1a4b71647d0606017837bb7fc69 files/digest-nxcomp-1.3.2-r1 66
MD5 eb79d26514557a9076393ddca0e9db75 files/digest-nxcomp-1.5.0 67
@@ -5,3 +8,10 @@ MD5 b3913b98fb03efcd7677b50a7d8d0b71 files/nxcomp-1.5.0-pic.patch 513
MD5 8e92b9291198042d907534cb08b013f8 metadata.xml 361
MD5 10613855f29c1af490bb1bb997eb46a3 nxcomp-1.3.2-r1.ebuild 979
MD5 dd9f164f3ed12ba4eb1b422aea61f3b8 nxcomp-1.5.0.ebuild 1053
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDWBkzJrHF4yAQTrARAjOlAJ934Wr/AsEkcalgQnNsp4WEMj3pNgCglfgb
+dj6ogNmpQfPx/IVklvKCaLE=
+=sn+W
+-----END PGP SIGNATURE-----
diff --git a/net-misc/nxcomp/nxcomp-1.5.0.ebuild b/net-misc/nxcomp/nxcomp-1.5.0.ebuild
index f7cc2603864f..4dc74bef8f96 100644
--- a/net-misc/nxcomp/nxcomp-1.5.0.ebuild
+++ b/net-misc/nxcomp/nxcomp-1.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcomp/nxcomp-1.5.0.ebuild,v 1.1 2005/10/20 21:24:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/nxcomp/nxcomp-1.5.0.ebuild,v 1.2 2005/10/20 22:24:41 agriffis Exp $
inherit eutils multilib
@@ -35,6 +35,10 @@ src_compile() {
src_install() {
into /usr/NX
dolib libXcomp.so.${PV}
+ if [[ $(get_libdir) != lib ]]; then
+ # necessary for nxclient to work, it seems
+ ln -s "$(get_libdir)" ${D}/usr/NX/lib
+ fi
insinto /usr/NX/include
doins NX.h