summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-12 03:00:05 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-12 03:00:05 +0000
commit7ce77a705f7586ba0cbfccc69f8526905e9fa253 (patch)
tree5a478efb2cab3925cc6e8302b151771e9b8b6b59 /net-misc
parentstabilize (diff)
downloadhistorical-7ce77a705f7586ba0cbfccc69f8526905e9fa253.tar.gz
historical-7ce77a705f7586ba0cbfccc69f8526905e9fa253.tar.bz2
historical-7ce77a705f7586ba0cbfccc69f8526905e9fa253.zip
Version bump #88800 by michael.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/entropy/ChangeLog9
-rw-r--r--net-misc/entropy/Manifest4
-rw-r--r--net-misc/entropy/entropy-0.8.2.418.ebuild65
-rw-r--r--net-misc/entropy/files/digest-entropy-0.8.2.4181
4 files changed, 76 insertions, 3 deletions
diff --git a/net-misc/entropy/ChangeLog b/net-misc/entropy/ChangeLog
index 938628721275..c881a5c03a9f 100644
--- a/net-misc/entropy/ChangeLog
+++ b/net-misc/entropy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/entropy
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/ChangeLog,v 1.4 2004/06/24 23:43:25 agriffis Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/ChangeLog,v 1.5 2005/04/12 03:00:04 vapier Exp $
+
+*entropy-0.8.2.418 (12 Apr 2005)
+
+ 12 Apr 2005; Mike Frysinger <vapier@gentoo.org> +entropy-0.8.2.418.ebuild:
+ Version bump #88800 by michael.
*entropy-0.8.2.415 (02 May 2004)
diff --git a/net-misc/entropy/Manifest b/net-misc/entropy/Manifest
index 125685be89a3..2cbfaf8d38ac 100644
--- a/net-misc/entropy/Manifest
+++ b/net-misc/entropy/Manifest
@@ -1,5 +1,7 @@
-MD5 7bce416c4e8ee40633647930fb35f2af ChangeLog 600
+MD5 f1d507cc6f96a1026a779b6e57012cda ChangeLog 744
+MD5 512857a326479cdbdaa95d4c5a7dc6c6 entropy-0.8.2.418.ebuild 1725
MD5 f3b322751da0ad252e828695a14833a3 entropy-0.8.2.415.ebuild 1716
MD5 5b5d42195d023961aff488df450727af files/entropy.conf.d 274
+MD5 a2c703df6b4ccde79bda3817adfefb2c files/digest-entropy-0.8.2.418 66
MD5 3881e0923ce99231017d5c9dde6f543b files/digest-entropy-0.8.2.415 66
MD5 aa6b3f2bfb13e8b73685cb547ebb5809 files/entropy.rc 616
diff --git a/net-misc/entropy/entropy-0.8.2.418.ebuild b/net-misc/entropy/entropy-0.8.2.418.ebuild
new file mode 100644
index 000000000000..6aec563d6b48
--- /dev/null
+++ b/net-misc/entropy/entropy-0.8.2.418.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/entropy/entropy-0.8.2.418.ebuild,v 1.1 2005/04/12 03:00:04 vapier Exp $
+
+inherit eutils
+
+MY_PV_BUILD=${PV/*.}
+MY_PV=${PV/.${MY_PV_BUILD}}
+DESCRIPTION="A p2p-node to share your files, infos, philosophy ... anonymously"
+HOMEPAGE="http://entropy.stop1984.com/"
+SRC_URI="http://entropy.stop1984.com/files/entropy-${MY_PV}-${MY_PV_BUILD}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+DEPEND="sys-libs/zlib
+ dev-libs/expat
+ mysql? ( dev-db/mysql )"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_compile() {
+ local myconf=""
+ use mysql && myconf="--with-mysql=/usr"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dobin entropy monoopt storechg || die
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/entropy.rc entropy
+ insinto /etc/conf.d
+ newins ${FILESDIR}/entropy.conf.d entropy
+
+ pkg_preinst
+ diropts -o entropy -g entropy
+ insopts -o entropy -g entropy -m0644
+ dodir /var/entropy/{de,node,store,tmp}
+ insinto /var/entropy/de
+ doins de/*
+ insinto /var/entropy/node
+ doins node/*
+
+ sed -e "3,$ s:#::g" seed.txt-dist > seed.txt
+ sed \
+ -e "s:seednodes=seed.txt:seednodes=/var/entropy/seed.txt:g" \
+ -e "s:logfile=entropy.log:logfile=/var/entropy/entropy.log:g" \
+ -e "s:storepath=store:storepath=/var/entropy/store:g" \
+ -e "s:temppath=tmp:temppath=/var/entropy/tmp:g" \
+ entropy.conf-dist > entropy.conf
+ insinto /var/entropy
+ doins entropy.conf seed.txt
+
+ dodoc README TODO entropy.conf-dist seed.txt-dist
+ dohtml ENTROPY.html
+ use mysql && dodoc README.MySQL
+}
+
+pkg_preinst() {
+ enewgroup entropy
+ enewuser entropy -1 /bin/false /var/entropy entropy
+}
diff --git a/net-misc/entropy/files/digest-entropy-0.8.2.418 b/net-misc/entropy/files/digest-entropy-0.8.2.418
new file mode 100644
index 000000000000..7f07b2e465b1
--- /dev/null
+++ b/net-misc/entropy/files/digest-entropy-0.8.2.418
@@ -0,0 +1 @@
+MD5 4dbd84f7c33abfc1a5cb13c7f56945d4 entropy-0.8.2-418.tgz 790526