summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-03-28 05:59:02 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-03-28 05:59:02 +0000
commit04947b1d933b97b4fe0cd82391ab547a7150ae93 (patch)
tree332f495911900052f01f935eb439f0ba8006a2a3 /net-misc/tightvnc
parentogle libxml fix (diff)
downloadhistorical-04947b1d933b97b4fe0cd82391ab547a7150ae93.tar.gz
historical-04947b1d933b97b4fe0cd82391ab547a7150ae93.tar.bz2
historical-04947b1d933b97b4fe0cd82391ab547a7150ae93.zip
added libjpeg as a compile-time dependency.
Diffstat (limited to 'net-misc/tightvnc')
-rw-r--r--net-misc/tightvnc/ChangeLog9
-rw-r--r--net-misc/tightvnc/files/digest-tightvnc-1.2.3-r11
-rw-r--r--net-misc/tightvnc/tightvnc-1.2.3-r1.ebuild35
3 files changed, 44 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index faaafd901883..314e89cdf5ec 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.2 2002/03/25 10:55:39 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.3 2002/03/28 05:59:02 seemant Exp $
+
+*tightvnc-1.2.3-r1 (27 Mar 2002)
+
+ 27 Mar 2002; Seemant Kulleen <seemant@gentoo.org> tightvnc-1.2.3-r1.ebuild :
+
+ tightvnc needs libjpeg in order to compile correctly, so it has been added as
+ a dependency. Thanks to kpullin@socal.rr.com for spotting it.
*tightvnc-1.2.3 (25 March 2002)
diff --git a/net-misc/tightvnc/files/digest-tightvnc-1.2.3-r1 b/net-misc/tightvnc/files/digest-tightvnc-1.2.3-r1
new file mode 100644
index 000000000000..eef258320fd2
--- /dev/null
+++ b/net-misc/tightvnc/files/digest-tightvnc-1.2.3-r1
@@ -0,0 +1 @@
+MD5 35a2561f83eeabec7b0c91c251fbcfb4 tightvnc-1.2.3_unixsrc.tar.bz2 1688195
diff --git a/net-misc/tightvnc/tightvnc-1.2.3-r1.ebuild b/net-misc/tightvnc/tightvnc-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..ec1c307efc89
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.2.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Bart Verwilst <verwilst@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.2.3-r1.ebuild,v 1.1 2002/03/28 05:59:02 seemant Exp $
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="http://prdownloads.sourceforge.net/vnc-tight/${P}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com"
+SLOT="0"
+DEPEND="virtual/glibc
+ >=x11-base/xfree-4.1.0
+ >=sys-devel/perl-5.6.1
+ ~media-libs/jpeg-6b
+ >=sys-libs/zlib-1.1.4"
+
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ cd ${S}
+ xmkmf || die
+ make World || die
+ cd Xvnc
+ make World || die
+
+}
+
+src_install() {
+
+ cd ${S}
+ mkdir -p ${D}/usr/bin
+ ./vncinstall ${D}/usr/bin || die
+
+}