summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-07 20:31:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-07 20:31:13 +0000
commit681fef10d2f5027c08a4e12c90fcd7252e6d37b0 (patch)
tree6710da800ed2f86d87ba805e174efb57a07b17fc /net-misc/taptap/taptap-1.0.ebuild
parentDelete older ebuild. (diff)
downloadhistorical-681fef10d2f5027c08a4e12c90fcd7252e6d37b0.tar.gz
historical-681fef10d2f5027c08a4e12c90fcd7252e6d37b0.tar.bz2
historical-681fef10d2f5027c08a4e12c90fcd7252e6d37b0.zip
Initial commit wrt #340861 by Alex Buell.
Package-Manager: portage-2.2.0_alpha4/cvs/Linux x86_64
Diffstat (limited to 'net-misc/taptap/taptap-1.0.ebuild')
-rw-r--r--net-misc/taptap/taptap-1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/taptap/taptap-1.0.ebuild b/net-misc/taptap/taptap-1.0.ebuild
new file mode 100644
index 000000000000..4d0dae141d2c
--- /dev/null
+++ b/net-misc/taptap/taptap-1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/taptap/taptap-1.0.ebuild,v 1.1 2010/11/07 20:31:13 ssuominen Exp $
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="A program to link two /dev/net/tun to form virtual ethernet"
+HOMEPAGE="http://www.munted.org.uk/programming/taptap/"
+SRC_URI="http://www.munted.org.uk/programming/${PN}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:= -Wall -s:+= -Wall:' \
+ -e 's:$(CFLAGS):$(LDFLAGS) &:' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}