summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-20 14:15:26 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-20 14:15:26 +0000
commit876213ab91d7f5a64d35d3673da140ff72ac7cd5 (patch)
tree5b20292f297f783050f927bd44a760f7736988ed /net-misc/sjphone/sjphone-1.60.2235.ebuild
parentStable x86. (diff)
downloadhistorical-876213ab91d7f5a64d35d3673da140ff72ac7cd5.tar.gz
historical-876213ab91d7f5a64d35d3673da140ff72ac7cd5.tar.bz2
historical-876213ab91d7f5a64d35d3673da140ff72ac7cd5.zip
Version bump, bug 132064, thanks karpi
Package-Manager: portage-2.1_rc1-r2
Diffstat (limited to 'net-misc/sjphone/sjphone-1.60.2235.ebuild')
-rw-r--r--net-misc/sjphone/sjphone-1.60.2235.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/sjphone/sjphone-1.60.2235.ebuild b/net-misc/sjphone/sjphone-1.60.2235.ebuild
new file mode 100644
index 000000000000..93104a33150c
--- /dev/null
+++ b/net-misc/sjphone/sjphone-1.60.2235.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sjphone/sjphone-1.60.2235.ebuild,v 1.1 2006/05/20 14:15:26 genstef Exp $
+
+inherit eutils
+
+MY_P="SJphoneLnx-${PV}"
+DESCRIPTION=" VOIP softphone supports both SIP and H.323 standards "
+HOMEPAGE="http://www.sjlabs.com/sjp.html"
+SRC_URI="http://www.sjlabs.com/preview/linux/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="|| ( ( x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp )
+ virtual/x11 )"
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ insinto /opt/sjphone
+ doins -r lib/*
+ fperms a+x /opt/sjphone/sjphone
+
+ sed -i -e 's:$(dirname "$0"):/opt/sjphone:' \
+ -e 's:$WD/lib:$WD:' sjphone
+ dobin sjphone
+ dodoc LICENSE README
+ doicon lib/sjphone.png
+ make_desktop_entry sjphone
+}