summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-06-03 15:58:01 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-06-03 15:58:01 +0000
commitaa881b875a89639d57c6bdd3f02d5f386e7a7be1 (patch)
tree880abb7e99c1eb102191f5d46b28650356f0d31e /net-misc/putty
parentinitial import, putty ssh client. (diff)
downloadhistorical-aa881b875a89639d57c6bdd3f02d5f386e7a7be1.tar.gz
historical-aa881b875a89639d57c6bdd3f02d5f386e7a7be1.tar.bz2
historical-aa881b875a89639d57c6bdd3f02d5f386e7a7be1.zip
initial import, putty ssh client.
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/Manifest3
-rw-r--r--net-misc/putty/files/digest-putty-200306031
-rw-r--r--net-misc/putty/putty-20030603.ebuild63
3 files changed, 66 insertions, 1 deletions
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 88bd1bfc7809..2db9cbc00be6 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,2 +1,3 @@
-MD5 ecea3626f3b38d9094d7ac8dca02613c putty-20030603.ebuild 1090
+MD5 af22b195d693c4b2feeb70dde90baa9a ChangeLog 365
+MD5 4ca2fb56d51d27690bcec4597fc2fd3b putty-20030603.ebuild 1345
MD5 bcc49e4648a2fa3b47fb42141928e0e0 files/digest-putty-20030603 70
diff --git a/net-misc/putty/files/digest-putty-20030603 b/net-misc/putty/files/digest-putty-20030603
new file mode 100644
index 000000000000..d30e2d4aa6fa
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-20030603
@@ -0,0 +1 @@
+MD5 42b86dc2d018ab752477e6e17416311b putty-cvs-20030603.tar.gz 814537
diff --git a/net-misc/putty/putty-20030603.ebuild b/net-misc/putty/putty-20030603.ebuild
new file mode 100644
index 000000000000..2b6e72447bea
--- /dev/null
+++ b/net-misc/putty/putty-20030603.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20030603.ebuild,v 1.1 2003/06/03 15:57:53 taviso Exp $
+
+cvs_update="20030603"
+DESCRIPTION="UNIX port of the famous Windows SSH client"
+
+inherit ccc
+
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://cvs.gentoo.org/~taviso/putty-cvs-${cvs_update}.tar.gz"
+
+LICENSE="MIT"
+
+SLOT="0"
+
+KEYWORDS="~x86 ~alpha"
+
+IUSE=""
+DEPEND="dev-lang/perl
+ >=sys-apps/sed-4
+ virtual/x11
+ ~dev-libs/glib-1.2.10
+ ~x11-libs/gtk+-1.2.10"
+
+RDEPEND="virtual/x11
+ ~dev-libs/glib-1.2.10
+ ~x11-libs/gtk+-1.2.10"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+
+ # generate the makefiles
+ ${S}/mkfiles.pl || die "failed to create makefiles."
+
+ # change the CFLLAGS to those requested by user.
+ sed -i "s/-O2/${CFLAGS}/g" ${S}/unix/Makefile.gtk
+
+ # build putty.
+ cd ${S}/unix; emake -f Makefile.gtk || die "build failed."
+}
+
+src_install() {
+
+ cd ${S}/unix
+
+ # man pages...
+ doman plink.1 pterm.1 putty.1 puttytel.1
+
+ # binaries...
+ dobin plink pterm putty puttytel
+
+ cd ${S}
+
+ # docs...
+ dodoc README README.txt LICENSE doc/*
+}
+
+pkg_postinst() {
+ einfo "Please note that pterm will not work without UNIX98 PTYS support"
+ einfo "If you want to use pterm, you may have to enable it."
+}