summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-11-02 18:11:14 +0000
committerNed Ludd <solar@gentoo.org>2004-11-02 18:11:14 +0000
commita02df70671175dae8bbfb0610345c3b97bf196a2 (patch)
tree28b53ceb736459bf18f7dcf8bb197a492724c5c8 /net-misc/proxytunnel/proxytunnel-1.2.3.ebuild
parentStable on sparc wrt #69825 (diff)
downloadhistorical-a02df70671175dae8bbfb0610345c3b97bf196a2.tar.gz
historical-a02df70671175dae8bbfb0610345c3b97bf196a2.tar.bz2
historical-a02df70671175dae8bbfb0610345c3b97bf196a2.zip
security bump
Diffstat (limited to 'net-misc/proxytunnel/proxytunnel-1.2.3.ebuild')
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.2.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/proxytunnel/proxytunnel-1.2.3.ebuild b/net-misc/proxytunnel/proxytunnel-1.2.3.ebuild
new file mode 100644
index 000000000000..b4361397d3c8
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/proxytunnel/proxytunnel-1.2.3.ebuild,v 1.1 2004/11/02 18:11:14 solar Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="program that connects stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
+HOMEPAGE="http://proxytunnel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/proxytunnel/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="static"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-makefile.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc CHANGES CREDITS README
+}