summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-04-10 22:24:08 +0000
committerDonny Davies <woodchip@gentoo.org>2002-04-10 22:24:08 +0000
commit220f0db5879dc37100ec4a6166741d33c4513b81 (patch)
tree2fd3259c299154595cc3cf9d7b1dc415674f834b /net-misc/oidentd
parentsandbox fix (diff)
downloadhistorical-220f0db5879dc37100ec4a6166741d33c4513b81.tar.gz
historical-220f0db5879dc37100ec4a6166741d33c4513b81.tar.bz2
historical-220f0db5879dc37100ec4a6166741d33c4513b81.zip
new package; contributed and fixed up a little
Diffstat (limited to 'net-misc/oidentd')
-rw-r--r--net-misc/oidentd/ChangeLog9
-rw-r--r--net-misc/oidentd/files/digest-oidentd-2.0.31
-rw-r--r--net-misc/oidentd/files/oidentd-init20
-rw-r--r--net-misc/oidentd/files/oidentd.conf22
-rw-r--r--net-misc/oidentd/files/oidentd_masq.conf10
-rw-r--r--net-misc/oidentd/oidentd-2.0.3.ebuild21
6 files changed, 83 insertions, 0 deletions
diff --git a/net-misc/oidentd/ChangeLog b/net-misc/oidentd/ChangeLog
new file mode 100644
index 000000000000..8dfb3c5b6c0a
--- /dev/null
+++ b/net-misc/oidentd/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-print/oidentd
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/ChangeLog,v 1.1 2002/04/10 22:24:08 woodchip Exp $
+
+*oidentd-2.0.3 (10 Apr 2002)
+
+ 10 Apr 2002; Donny Davies <woodchip@gentoo.org> oidentd-2.0.3.ebuild :
+
+ New package contributed by phoen][x <eqc_phoenix@gmx.de>.
diff --git a/net-misc/oidentd/files/digest-oidentd-2.0.3 b/net-misc/oidentd/files/digest-oidentd-2.0.3
new file mode 100644
index 000000000000..27e5a472eee7
--- /dev/null
+++ b/net-misc/oidentd/files/digest-oidentd-2.0.3
@@ -0,0 +1 @@
+MD5 a8404689d89e1e5beafd8eb10f85359f oidentd-2.0.3.tar.gz 159414
diff --git a/net-misc/oidentd/files/oidentd-init b/net-misc/oidentd/files/oidentd-init
new file mode 100644
index 000000000000..1e4f588087bb
--- /dev/null
+++ b/net-misc/oidentd/files/oidentd-init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/files/oidentd-init,v 1.1 2002/04/10 22:24:08 woodchip Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting oidentd"
+ start-stop-daemon --start --quiet --exec /usr/sbin/oidentd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping oidentd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/oidentd
+ eend $?
+}
diff --git a/net-misc/oidentd/files/oidentd.conf b/net-misc/oidentd/files/oidentd.conf
new file mode 100644
index 000000000000..03b28d827802
--- /dev/null
+++ b/net-misc/oidentd/files/oidentd.conf
@@ -0,0 +1,22 @@
+# Configuration for oidentd
+# see oidentd.conf(5)
+#
+default {
+ default {
+ deny spoof
+ deny spoof_all
+ deny spoof_privport
+ allow random
+ allow random_numeric
+ allow numeric
+ deny hide
+ }
+}
+
+# you may want to hide root connections
+#user "root" {
+# default {
+# force reply "UNKNOWN"
+# }
+#}
+
diff --git a/net-misc/oidentd/files/oidentd_masq.conf b/net-misc/oidentd/files/oidentd_masq.conf
new file mode 100644
index 000000000000..6811288ff4cf
--- /dev/null
+++ b/net-misc/oidentd/files/oidentd_masq.conf
@@ -0,0 +1,10 @@
+# oident masquarded connections configuration
+
+# use this file if your host is masquarading connections for several
+# hosts and you want to return a reply based on the hostname of
+# the originating machine
+# add "-f" to OIDENT_OPTIONS in /etc/conf.d/oidentd if you want
+# to forward ident requests to the real host
+
+# add hosts in the following format, see oidentd_masq.conf(5) for details:
+# <ip or host>[/mask] <username> <os>
diff --git a/net-misc/oidentd/oidentd-2.0.3.ebuild b/net-misc/oidentd/oidentd-2.0.3.ebuild
new file mode 100644
index 000000000000..0cab2a0df37f
--- /dev/null
+++ b/net-misc/oidentd/oidentd-2.0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/oidentd/oidentd-2.0.3.ebuild,v 1.1 2002/04/10 22:24:08 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Another (RFC1413 compliant) ident daemon"
+HOMEPAGE="http://dev.ojnk.net/"
+SRC_URI="http://prdownloads.sourceforge.net/ojnk/${P}.tar.gz"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --prefix=/usr --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog README TODO NEWS
+ exeinto /etc/init.d ; newexe ${FILESDIR}/oidentd-init oidentd
+}