summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-02 07:20:45 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-02 07:20:45 +0000
commit6dbc7ddf1ab755f17825192a9e0f595090fb0b70 (patch)
tree62a17378275c10a38c3216ad8545a0bc97d0c3ea /net-misc/logjam
parentinclude file fixes (diff)
downloadhistorical-6dbc7ddf1ab755f17825192a9e0f595090fb0b70.tar.gz
historical-6dbc7ddf1ab755f17825192a9e0f595090fb0b70.tar.bz2
historical-6dbc7ddf1ab755f17825192a9e0f595090fb0b70.zip
moved from app-office
Diffstat (limited to 'net-misc/logjam')
-rw-r--r--net-misc/logjam/logjam-3.0.4-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-misc/logjam/logjam-3.0.4-r2.ebuild b/net-misc/logjam/logjam-3.0.4-r2.ebuild
new file mode 100644
index 000000000000..11d9b1169002
--- /dev/null
+++ b/net-misc/logjam/logjam-3.0.4-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logjam/logjam-3.0.4-r2.ebuild,v 1.1 2002/10/02 07:20:45 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK-based LiveJournal client"
+HOMEPAGE="http://logjam.danga.com/"
+SRC_URI=http://logjam.danga.com/download/${P}.tar.gz
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=x11-libs/gtk+-1.2.10
+ net-ftp/curl
+ gnome? ( >=gnome-base/gnome-core-1.4.0 )
+ xmms? ( media-sound/xmms )"
+
+src_compile () {
+ local myconf
+
+ use gnome && myconf="${myconf} --with-gnome=yes"
+ use xmms && myconf="${myconf} --enable-xmms"
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc README TODO ChangeLog COPYING AUTHORS
+}