summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 22:01:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-06-07 22:01:01 +0000
commite2a3b04e4fe6945ae81c1ed8ae620869955ed80d (patch)
tree3c1c18d88f657ae6545ddbdc68a6bc4876870b98 /net-misc/icaclient/icaclient-7.0.ebuild
parentNew release: 0.93. Closes bug #50144. (diff)
downloadhistorical-e2a3b04e4fe6945ae81c1ed8ae620869955ed80d.tar.gz
historical-e2a3b04e4fe6945ae81c1ed8ae620869955ed80d.tar.bz2
historical-e2a3b04e4fe6945ae81c1ed8ae620869955ed80d.zip
dyn_fetch() -> pkg_nofetch(); tidy
Diffstat (limited to 'net-misc/icaclient/icaclient-7.0.ebuild')
-rw-r--r--net-misc/icaclient/icaclient-7.0.ebuild33
1 files changed, 16 insertions, 17 deletions
diff --git a/net-misc/icaclient/icaclient-7.0.ebuild b/net-misc/icaclient/icaclient-7.0.ebuild
index d3108f35de16..9213b0ed70d0 100644
--- a/net-misc/icaclient/icaclient-7.0.ebuild
+++ b/net-misc/icaclient/icaclient-7.0.ebuild
@@ -1,28 +1,27 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/icaclient/icaclient-7.0.ebuild,v 1.1 2003/10/10 18:16:27 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/icaclient/icaclient-7.0.ebuild,v 1.2 2004/06/07 22:01:01 mr_bones_ Exp $
-S=${WORKDIR}/usr
DESCRIPTION="ICA Client"
-SRC_URI="ICAClient-7.00-1.i386.rpm"
HOMEPAGE="http://www.citrix.com/download/unix-downloads.asp"
-RDEPEND="virtual/glibc virtual/x11"
-DEPEND="${RDEPEND} >=app-arch/rpm-3.0.6"
+SRC_URI="ICAClient-7.00-1.i386.rpm"
+
LICENSE="as-is"
SLOT="0"
-RESTRICT="fetch"
KEYWORDS="~x86 ~sparc"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="virtual/glibc
+ virtual/x11"
+DEPEND="${RDEPEND}
+ >=app-arch/rpm-3.0.6"
+
+S="${WORKDIR}/usr"
-dyn_fetch() {
- for y in ${A}
- do
- digest_check ${y}
- if [ $? -ne 0 ]; then
- einfo "Please download this yourself from www.citrix.com"
- einfo "and place it in ${DISTDIR}"
- exit 1
- fi
- done
+pkg_nofetch() {
+ einfo "Please download ${A} yourself from www.citrix.com"
+ einfo "and place it in ${DISTDIR}"
}
src_unpack() {