summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Warner <antarus@gentoo.org>2006-08-26 05:14:08 +0000
committerAlec Warner <antarus@gentoo.org>2006-08-26 05:14:08 +0000
commit9afb7188d56aa21031eb4ec6e3234eb718daed2d (patch)
tree6ae3b67a48e9cff51a6c091f5ec5a5b90784b7dc /net-misc/freenet6
parentPunting bidwatcher for bug # 140630 (diff)
downloadhistorical-9afb7188d56aa21031eb4ec6e3234eb718daed2d.tar.gz
historical-9afb7188d56aa21031eb4ec6e3234eb718daed2d.tar.bz2
historical-9afb7188d56aa21031eb4ec6e3234eb718daed2d.zip
I deleted this by complete accident, restoring
Package-Manager: portage-1445-svn
Diffstat (limited to 'net-misc/freenet6')
-rw-r--r--net-misc/freenet6/ChangeLog10
-rw-r--r--net-misc/freenet6/freenet6-0.9.7.ebuild51
-rw-r--r--net-misc/freenet6/freenet6-1.0.0.ebuild51
3 files changed, 112 insertions, 0 deletions
diff --git a/net-misc/freenet6/ChangeLog b/net-misc/freenet6/ChangeLog
new file mode 100644
index 000000000000..3313bf931be0
--- /dev/null
+++ b/net-misc/freenet6/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-misc/freenet6
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/ChangeLog,v 1.14 2006/08/26 05:14:08 antarus Exp $
+
+*freenet6-0.9.7 (28 May 2003)
+
+ 28 May 2003; Peter Johanson <latexer@gentoo.org> freenet6-0.9.7.ebuild,
+ files/freenet6-0.9.2.diff, files/tspc.conf, files/tspc.rc:
+ Initial import. bug#9020
+
diff --git a/net-misc/freenet6/freenet6-0.9.7.ebuild b/net-misc/freenet6/freenet6-0.9.7.ebuild
new file mode 100644
index 000000000000..13f6c8e7787b
--- /dev/null
+++ b/net-misc/freenet6/freenet6-0.9.7.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-0.9.7.ebuild,v 1.9 2006/08/26 05:14:08 antarus Exp $
+
+DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
+HOMEPAGE="http://www.freenet6.net/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="VPL-1.0"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+DEPEND=""
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/freenet6-0.9.2.diff || die "Failed to patch"
+
+ mv -f src/Makefile ${T}
+ sed "s:gcc -g -I\$(INC) -Wall:${CC} -I\$(INC) ${CFLAGS}:" \
+ ${T}/Makefile > src/Makefile
+}
+
+src_compile() {
+ emake all target=linux || die "Build Failed"
+}
+
+src_install() {
+ dosbin bin/tspc
+
+ insopts -m 600
+ insinto /etc/freenet6
+ doins ${FILESDIR}/tspc.conf
+ exeinto /etc/freenet6/template
+ doexe template/{linux,checktunnel}.sh
+
+ dodoc CONTRIB.txt LEGAL LEGAL.html README
+ doman man/{man5/tspc.conf.5,man8/tspc.8}
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/tspc.rc tspc
+}
+
+pkg_postinst() {
+ einfo "The freenet6 ebuild installs an init script named 'tspc'"
+ einfo "to coincide with the name of the client binary installed"
+ einfo "To add support for a freenet6 connection at startup, do"
+ einfo ""
+ einfo "# rc-update add tspc default"
+}
diff --git a/net-misc/freenet6/freenet6-1.0.0.ebuild b/net-misc/freenet6/freenet6-1.0.0.ebuild
new file mode 100644
index 000000000000..b089653dc34b
--- /dev/null
+++ b/net-misc/freenet6/freenet6-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-1.0.0.ebuild,v 1.11 2006/08/26 05:14:08 antarus Exp $
+
+DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
+HOMEPAGE="http://www.freenet6.net/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="VPL-1.0"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa"
+DEPEND=""
+S=${WORKDIR}/freenet6-client-1.0
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mv -f src/Makefile ${T}
+ sed "s:gcc -g -I\$(INC) -Wall:${CC} -I\$(INC) ${CFLAGS}:" \
+ ${T}/Makefile > src/Makefile
+}
+
+src_compile() {
+ emake all target=linux || die "Build Failed"
+}
+
+src_install() {
+ dosbin bin/tspc
+
+ insopts -m 600
+ insinto /etc/freenet6
+ doins ${FILESDIR}/tspc.conf
+ exeinto /etc/freenet6/template
+ doexe template/{linux,checktunnel}.sh
+ doexe ${FILESDIR}/gentoo.sh
+
+ dodoc CONTRIB.txt LEGAL README
+ doman man/{man5/tspc.conf.5,man8/tspc.8}
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/tspc.rc tspc
+}
+
+pkg_postinst() {
+ einfo "The freenet6 ebuild installs an init script named 'tspc'"
+ einfo "to coincide with the name of the client binary installed"
+ einfo "To add support for a freenet6 connection at startup, do"
+ einfo ""
+ einfo "# rc-update add tspc default"
+}