summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2003-12-07 17:06:09 +0000
committerGuy Martin <gmsoft@gentoo.org>2003-12-07 17:06:09 +0000
commit51240819945f1b4cdbe481e47b42cd26ff9c294a (patch)
tree0925c7af63b373acf3a16eafdc50941d2c9b6528 /net-misc/freenet6
parentNew version (diff)
downloadhistorical-51240819945f1b4cdbe481e47b42cd26ff9c294a.tar.gz
historical-51240819945f1b4cdbe481e47b42cd26ff9c294a.tar.bz2
historical-51240819945f1b4cdbe481e47b42cd26ff9c294a.zip
New version
Diffstat (limited to 'net-misc/freenet6')
-rw-r--r--net-misc/freenet6/Manifest6
-rw-r--r--net-misc/freenet6/files/digest-freenet6-1.0.01
-rw-r--r--net-misc/freenet6/files/tspc.conf2
-rw-r--r--net-misc/freenet6/files/tspc.rc4
-rw-r--r--net-misc/freenet6/freenet6-1.0.0.ebuild51
5 files changed, 58 insertions, 6 deletions
diff --git a/net-misc/freenet6/Manifest b/net-misc/freenet6/Manifest
index 7a342ee2dc9a..e7acbd8432d3 100644
--- a/net-misc/freenet6/Manifest
+++ b/net-misc/freenet6/Manifest
@@ -1,7 +1,7 @@
-MD5 889a7ea6708aa9456a623a40aa94b0c5 ChangeLog 939
+MD5 1a4079d1ca02f1199b82f564dfd89c30 ChangeLog 938
MD5 509e86f85d6fb5b41cc3c0abe7919f07 freenet6-0.9.7.ebuild 1338
-MD5 ee6d58c6a50dadf916bacf6170f87166 freenet6-1.0.0.ebuild 1295
-MD5 6ddc5bf2741f45d7b1411280b786662f files/tspc.rc 440
+MD5 008502a3ede214dee71544714b8bb8b4 freenet6-1.0.0.ebuild 1297
+MD5 1beab2175e3e7ffbcb79fef1ac0e3ca6 files/tspc.rc 439
MD5 b9d2127ddd9f73a468979e10bba5e06b files/digest-freenet6-0.9.7 63
MD5 7b3923fbb5cdc1bee32e08037ff62d08 files/freenet6-0.9.2.diff 4538
MD5 edc450e3ee1fd520d5e2936ca0f0c949 files/gentoo.sh 4568
diff --git a/net-misc/freenet6/files/digest-freenet6-1.0.0 b/net-misc/freenet6/files/digest-freenet6-1.0.0
new file mode 100644
index 000000000000..aaaf67ec7e47
--- /dev/null
+++ b/net-misc/freenet6/files/digest-freenet6-1.0.0
@@ -0,0 +1 @@
+MD5 a2b4edb1d52b874587533b4cf40de1ba freenet6-1.0.0.tgz 330953
diff --git a/net-misc/freenet6/files/tspc.conf b/net-misc/freenet6/files/tspc.conf
index 13df8e013b3d..6a028a88e554 100644
--- a/net-misc/freenet6/files/tspc.conf
+++ b/net-misc/freenet6/files/tspc.conf
@@ -40,7 +40,7 @@ template=linux
# server=FQDN
# Freenet6 server address
-server=tsps1.freenet6.net
+server=tsps2.freenet6.net
# retry_delay=time
# retry tells the client to retry connection after time (seconds) in case of
diff --git a/net-misc/freenet6/files/tspc.rc b/net-misc/freenet6/files/tspc.rc
index 19e6b56fe843..30f4cec541bb 100644
--- a/net-misc/freenet6/files/tspc.rc
+++ b/net-misc/freenet6/files/tspc.rc
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/files/tspc.rc,v 1.2 2003/06/11 15:11:13 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/files/tspc.rc,v 1.3 2003/12/07 17:05:50 gmsoft Exp $
depend() {
need net
@@ -9,7 +9,7 @@ depend() {
start() {
ebegin "Starting Freenet6 IPv6 Client"
- tspc
+ tspc -f /etc/freenet6/tspc.conf
eend $?
}
diff --git a/net-misc/freenet6/freenet6-1.0.0.ebuild b/net-misc/freenet6/freenet6-1.0.0.ebuild
new file mode 100644
index 000000000000..dac3f8336856
--- /dev/null
+++ b/net-misc/freenet6/freenet6-1.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/freenet6/freenet6-1.0.0.ebuild,v 1.1 2003/12/07 17:05:50 gmsoft Exp $
+
+DESCRIPTION="Client to configure an IPv6 tunnel to freenet6"
+HOMEPAGE="http://www.freenet6.net/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="VPL-1.0"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~hppa"
+DEPEND=""
+S=${WORKDIR}/freenet6-client-1.0
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ mv -f src/Makefile ${T}
+ sed "s:gcc -g -I\$(INC) -Wall:${CC} -I\$(INC) ${CFLAGS}:" \
+ ${T}/Makefile > src/Makefile
+}
+
+src_compile() {
+ emake all target=linux || die "Build Failed"
+}
+
+src_install() {
+ dosbin bin/tspc
+
+ insopts -m 600
+ insinto /etc/freenet6
+ doins ${FILESDIR}/tspc.conf
+ exeinto /etc/freenet6/template
+ doexe template/{linux,checktunnel}.sh
+ doexe ${FILESDIR}/gentoo.sh
+
+ dodoc CONTRIB.txt LEGAL README
+ doman man/{man5/tspc.conf.5,man8/tspc.8}
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/tspc.rc tspc
+}
+
+pkg_postinst() {
+ einfo "The freenet6 ebuild installs an init script named 'tspc'"
+ einfo "to coincide with the name of the client binary installed"
+ einfo "To add support for a freenet6 connection at startup, do"
+ einfo ""
+ einfo "# rc-update add tspc default"
+}