summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2006-10-27 19:39:41 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2006-10-27 19:39:41 +0000
commit3b5ba82856671f09abff6a6c5172492ff21319cd (patch)
tree6aab51d2477e171181d30d3723b79eb9289e6338 /net-misc/bwwhois
parentFixing segfault. Bug #151991 and removing ppc-macos keyword (diff)
downloadhistorical-3b5ba82856671f09abff6a6c5172492ff21319cd.tar.gz
historical-3b5ba82856671f09abff6a6c5172492ff21319cd.tar.bz2
historical-3b5ba82856671f09abff6a6c5172492ff21319cd.zip
Version bump, addition of support for eselect-whois.
Package-Manager: portage-2.1.2_pre3-r7
Diffstat (limited to 'net-misc/bwwhois')
-rw-r--r--net-misc/bwwhois/ChangeLog7
-rw-r--r--net-misc/bwwhois/bwwhois-3.4-r1.ebuild55
-rw-r--r--net-misc/bwwhois/files/digest-bwwhois-3.4-r13
3 files changed, 64 insertions, 1 deletions
diff --git a/net-misc/bwwhois/ChangeLog b/net-misc/bwwhois/ChangeLog
index 9b63585f2e6e..1274bca9137e 100644
--- a/net-misc/bwwhois/ChangeLog
+++ b/net-misc/bwwhois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/bwwhois
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/ChangeLog,v 1.13 2006/05/02 02:54:00 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/ChangeLog,v 1.14 2006/10/27 19:39:41 drizzt Exp $
+
+*bwwhois-3.4-r1 (27 Oct 2006)
+
+ 27 Oct 2006; Timothy Redaelli <drizzt@gentoo.org> +bwwhois-3.4-r1.ebuild:
+ Version bump, addition of support for eselect-whois.
02 May 2006; Jason Wever <weeve@gentoo.org> bwwhois-3.4.ebuild:
Stable on SPARC.
diff --git a/net-misc/bwwhois/bwwhois-3.4-r1.ebuild b/net-misc/bwwhois/bwwhois-3.4-r1.ebuild
new file mode 100644
index 000000000000..1a738708b793
--- /dev/null
+++ b/net-misc/bwwhois/bwwhois-3.4-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/bwwhois/bwwhois-3.4-r1.ebuild,v 1.1 2006/10/27 19:39:41 drizzt Exp $
+
+inherit perl-app
+
+MY_P=${P/bw/}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Perl-based whois client designed to work with the new Shared Registration System"
+SRC_URI="http://whois.bw.org/dist/${MY_P}.tgz"
+HOMEPAGE="http://whois.bw.org/"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="app-admin/eselect-whois"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+}
+
+src_compile() {
+ einfo "no compilation necessary"
+}
+
+src_install () {
+ exeinto usr/bin
+ newexe whois bwwhois
+
+ mv whois.1 bwwhois.1
+ doman bwwhois.1
+
+ insinto etc/whois
+ doins whois.conf tld.conf sd.conf
+
+ perlinfo
+ insinto ${SITE_LIB}
+ doins bwInclude.pm
+ updatepod
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/whois symlink"
+ eselect whois update --if-unset
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/whois symlink"
+ eselect whois update
+}
diff --git a/net-misc/bwwhois/files/digest-bwwhois-3.4-r1 b/net-misc/bwwhois/files/digest-bwwhois-3.4-r1
new file mode 100644
index 000000000000..84ce6d920288
--- /dev/null
+++ b/net-misc/bwwhois/files/digest-bwwhois-3.4-r1
@@ -0,0 +1,3 @@
+MD5 d2ec259e03450bd1ff9d9afc91975ec2 whois-3.4.tgz 41398
+RMD160 8a1455f173c7974ad436eea5dcb796668bdfcf41 whois-3.4.tgz 41398
+SHA256 2dcbe972a20c60eac9e4fd51b06d2cfdcf5efc508eb87600823e8e5fd6c628ea whois-3.4.tgz 41398