summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-11-17 20:27:09 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-11-17 20:27:09 +0000
commita2dae45552e34e937c30ee183ccebec169f0e3f7 (patch)
treeeeedd508e6e805540460378aae9642431220b4f1 /net-mail
parentmoved rp-l2tp from net-misc to net-dialup (diff)
downloadhistorical-a2dae45552e34e937c30ee183ccebec169f0e3f7.tar.gz
historical-a2dae45552e34e937c30ee183ccebec169f0e3f7.tar.bz2
historical-a2dae45552e34e937c30ee183ccebec169f0e3f7.zip
Version update.
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/tmda/ChangeLog8
-rw-r--r--net-mail/tmda/files/digest-tmda-0.891
-rw-r--r--net-mail/tmda/tmda-0.89.ebuild59
3 files changed, 67 insertions, 1 deletions
diff --git a/net-mail/tmda/ChangeLog b/net-mail/tmda/ChangeLog
index 25f8a5cf03df..abfea5b8a1cf 100644
--- a/net-mail/tmda/ChangeLog
+++ b/net-mail/tmda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/tmda
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.36 2003/10/15 03:04:12 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/ChangeLog,v 1.37 2003/11/17 20:27:09 agenkin Exp $
+
+*tmda-0.89 (17 Nov 2003)
+
+ 17 Nov 2003; Arcady Genkin <agenkin@gentoo.org> :
+ Version bump.
+ The docs have a new directory: html/img.
*tmda-0.87 (14 Oct 2003)
diff --git a/net-mail/tmda/files/digest-tmda-0.89 b/net-mail/tmda/files/digest-tmda-0.89
new file mode 100644
index 000000000000..18dbb5819e1b
--- /dev/null
+++ b/net-mail/tmda/files/digest-tmda-0.89
@@ -0,0 +1 @@
+MD5 6d56be04f5a2089035440e344c8437b5 tmda-0.89.tgz 398776
diff --git a/net-mail/tmda/tmda-0.89.ebuild b/net-mail/tmda/tmda-0.89.ebuild
new file mode 100644
index 000000000000..7f471be9d90e
--- /dev/null
+++ b/net-mail/tmda/tmda-0.89.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/tmda/tmda-0.89.ebuild,v 1.1 2003/11/17 20:27:09 agenkin Exp $
+
+DESCRIPTION="Python-based SPAM reduction system"
+HOMEPAGE="http://www.tmda.net/"
+LICENSE="GPL-2"
+
+DEPEND=">=dev-lang/python-2.2
+ virtual/mta"
+
+SRC_URI="http://tmda.net/releases/${P}.tgz
+ http://tmda.net/releases/old/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="x86 ~sparc"
+
+S="${WORKDIR}/${P}"
+
+src_compile () {
+ ./compileall || die
+}
+
+src_install () {
+ # Figure out python version
+ # below hack should be replaced w/ pkg-config, when we get it working
+ local pv=`python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:'`
+
+ # Executables
+ dobin bin/tmda-*
+
+ # The Python TMDA module
+ insinto "/usr/lib/python${pv}/site-packages/TMDA"
+ doins TMDA/*.py*
+ insinto "/usr/lib/python${pv}/site-packages/TMDA/pythonlib/email"
+ doins TMDA/pythonlib/email/*.py*
+
+ # The templates
+ insinto /etc/tmda
+ doins templates/*.txt
+
+ # Documentation
+ dodoc COPYING ChangeLog README THANKS UPGRADE CRYPTO CODENAMES INSTALL
+ dohtml -r htdocs/*.html
+ dohtml -r htdocs/img
+
+ # Contributed binaries and stuff
+ cd ${S}/contrib
+
+ exeinto /usr/lib/tmda/contrib
+ doexe collectaddys def2html getuserinfo-vpopmail.sh printcdb printdbm \
+ sendit.sh smtp-check-sender update-internaldomains vadduser-tmda \
+ vmailmgr-vdir.sh vpopmail-vdir.sh wrapfd3.sh
+
+ insinto /usr/lib/tmda/contrib
+ doins ChangeLog sample.config tmda.el tmda.spec \
+ tofmipd.init tofmipd.sysconfig vtmdarc
+
+}